<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>Latest three homicides in OKC happened over two days</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://freepressokc.com/xmlrpc.php" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<meta property="fb:app_id" content="1249330068491776" />

<link rel="icon" type="image/png" href="https://freepressokc.com/wp-content/uploads/2016/09/cropped-FPlogo-single-png.png">

<meta name="description" content="Over the weekend in Oklahoma City, three homicides occurred involving a fourth person who was injured but lived." />
<link rel="canonical" href="https://freepressokc.com/latest-three-homicides-in-okc-happened-over-two-days/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Latest three homicides in OKC happened over two days" />
<meta property="og:description" content="Over the weekend in Oklahoma City, three homicides occurred involving a fourth person who was injured but lived." />
<meta property="og:url" content="https://freepressokc.com/latest-three-homicides-in-okc-happened-over-two-days/" />
<meta property="og:site_name" content="Oklahoma City Free Press" />
<meta property="article:publisher" content="https://www.facebook.com/oklahomacityfreepress/" />
<meta property="article:published_time" content="2022-03-09T23:20:19+00:00" />
<meta property="article:modified_time" content="2022-03-09T23:37:01+00:00" />
<meta property="og:image" content="https://freepressokc.com/wp-content/uploads/2021/09/OKCPD-Crime-Scene-unit-DSC09757.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="720" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@freepressokc" />
<meta name="twitter:site" content="@freepressokc" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Brett Dickerson - Editor" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="2 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://freepressokc.com/#organization","name":"Oklahoma City Free Press LLC","url":"https://freepressokc.com/","sameAs":["https://www.facebook.com/oklahomacityfreepress/","https://www.instagram.com/freepressokc/?hl=en","https://www.youtube.com/channel/UCKnwaGON2-YbuX9-smgCafw","https://www.pinterest.com/oklahomacityfre/","https://twitter.com/freepressokc"],"logo":{"@type":"ImageObject","@id":"https://freepressokc.com/#logo","inLanguage":"en-US","url":"https://freepressokc.com/wp-content/uploads/2021/10/Masthead-w-skyline-201698-scale-reg-copy.jpeg","contentUrl":"https://freepressokc.com/wp-content/uploads/2021/10/Masthead-w-skyline-201698-scale-reg-copy.jpeg","width":800,"height":451,"caption":"Oklahoma City Free Press LLC"},"image":{"@id":"https://freepressokc.com/#logo"}},{"@type":"WebSite","@id":"https://freepressokc.com/#website","url":"https://freepressokc.com/","name":"Oklahoma City Free Press","description":"Local, independent, online news","publisher":{"@id":"https://freepressokc.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://freepressokc.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://freepressokc.com/latest-three-homicides-in-okc-happened-over-two-days/#primaryimage","inLanguage":"en-US","url":"https://freepressokc.com/wp-content/uploads/2021/09/OKCPD-Crime-Scene-unit-DSC09757.jpg","contentUrl":"https://freepressokc.com/wp-content/uploads/2021/09/OKCPD-Crime-Scene-unit-DSC09757.jpg","width":1280,"height":720},{"@type":"WebPage","@id":"https://freepressokc.com/latest-three-homicides-in-okc-happened-over-two-days/#webpage","url":"https://freepressokc.com/latest-three-homicides-in-okc-happened-over-two-days/","name":"Latest three homicides in OKC happened over two days","isPartOf":{"@id":"https://freepressokc.com/#website"},"primaryImageOfPage":{"@id":"https://freepressokc.com/latest-three-homicides-in-okc-happened-over-two-days/#primaryimage"},"datePublished":"2022-03-09T23:20:19+00:00","dateModified":"2022-03-09T23:37:01+00:00","description":"Over the weekend in Oklahoma City, three homicides occurred involving a fourth person who was injured but lived.","breadcrumb":{"@id":"https://freepressokc.com/latest-three-homicides-in-okc-happened-over-two-days/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://freepressokc.com/latest-three-homicides-in-okc-happened-over-two-days/"]}]},{"@type":"BreadcrumbList","@id":"https://freepressokc.com/latest-three-homicides-in-okc-happened-over-two-days/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://freepressokc.com/"},{"@type":"ListItem","position":2,"name":"Latest three homicides in OKC happened over two days"}]},{"@type":"Article","@id":"https://freepressokc.com/latest-three-homicides-in-okc-happened-over-two-days/#article","isPartOf":{"@id":"https://freepressokc.com/latest-three-homicides-in-okc-happened-over-two-days/#webpage"},"author":{"@id":"https://freepressokc.com/#/schema/person/fced127dfa4b8411ae5575b1402fc5df"},"headline":"Latest three homicides in OKC happened over two days","datePublished":"2022-03-09T23:20:19+00:00","dateModified":"2022-03-09T23:37:01+00:00","mainEntityOfPage":{"@id":"https://freepressokc.com/latest-three-homicides-in-okc-happened-over-two-days/#webpage"},"wordCount":392,"publisher":{"@id":"https://freepressokc.com/#organization"},"image":{"@id":"https://freepressokc.com/latest-three-homicides-in-okc-happened-over-two-days/#primaryimage"},"thumbnailUrl":"https://freepressokc.com/wp-content/uploads/2021/09/OKCPD-Crime-Scene-unit-DSC09757.jpg","keywords":["homicide","OKCPD","Oklahoma City Police Department"],"articleSection":["Crime"],"inLanguage":"en-US"},{"@type":"Person","@id":"https://freepressokc.com/#/schema/person/fced127dfa4b8411ae5575b1402fc5df","name":"Brett Dickerson - Editor","image":{"@type":"ImageObject","@id":"https://freepressokc.com/#personlogo","inLanguage":"en-US","url":"https://freepressokc.com/wp-content/uploads/2021/05/Brett-profile-pic-150x150.jpeg","contentUrl":"https://freepressokc.com/wp-content/uploads/2021/05/Brett-profile-pic-150x150.jpeg","caption":"Brett Dickerson - Editor"},"description":"Founder, editor, writer, photographer: Oklahoma City Free Press.","url":"https://freepressokc.com/author/brett-dickerson/"}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Oklahoma City Free Press &raquo; Feed" href="https://freepressokc.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Oklahoma City Free Press &raquo; Comments Feed" href="https://freepressokc.com/comments/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/freepressokc.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://freepressokc.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='wtr-css-css' href='https://freepressokc.com/wp-content/plugins/worth-the-read/css/wtr.css?ver=5.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-frontend-css' href='https://freepressokc.com/wp-content/plugins/wp-user-avatar/assets/css/frontend.min.css?ver=3.2.8' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-flatpickr-css' href='https://freepressokc.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.css?ver=3.2.8' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-select2-css' href='https://freepressokc.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.css?ver=5.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://freepressokc.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=23f7cf05c1213c4bc7a6753a64c58bf1' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Roboto+Slab%3A400%7CLato%3A400%7CRoboto%3A400%2C500%2C700%7COpen+Sans%3A400%2C600%2C700&#038;display=swap&#038;ver=11.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://freepressokc.com/wp-content/themes/childnewspaper7/style.css?ver=1.0' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='td-legacy-framework-front-style-css' href='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=23f7cf05c1213c4bc7a6753a64c58bf1' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css' href='https://freepressokc.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=4168705b165f7662fff7e5fdf2db6ef8' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css' href='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/includes/demos/politics/demo_style.css?ver=11.4.1' type='text/css' media='all' />
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.js?ver=5.9.1' id='ppress-flatpickr-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.js?ver=5.9.1' id='ppress-select2-js'></script>
<link rel="https://api.w.org/" href="https://freepressokc.com/wp-json/" /><link rel="alternate" type="application/json" href="https://freepressokc.com/wp-json/wp/v2/posts/17922" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://freepressokc.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://freepressokc.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.9.1" />
<link rel='shortlink' href='https://freepressokc.com/?p=17922' />
<link rel="alternate" type="application/json+oembed" href="https://freepressokc.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffreepressokc.com%2Flatest-three-homicides-in-okc-happened-over-two-days%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://freepressokc.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffreepressokc.com%2Flatest-three-homicides-in-okc-happened-over-two-days%2F&#038;format=xml" />


<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px; width:100%; max-width:1280px; height:100%; max-height:182px; }
	.g-3 { margin:0px 0px 0px 0px; width:100%; max-width:1280px; height:100%; max-height:182px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>

<style type="text/css">.wtr-time-wrap{ 
	/* wraps the entire label */
	margin: 0 10px;

}
.wtr-time-number{ 
	/* applies only to the number */
	
}</style><style id="wplmi-inline-css" type="text/css"> span.wplmi-user-avatar { width: 16px;display: inline-block !important;flex-shrink: 0; } img.wplmi-elementor-avatar { border-radius: 100%;margin-right: 3px; } 

</style>
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script>
        window.tdb_globals = {"wpRestNonce":"9acc81f528","wpRestUrl":"https:\/\/freepressokc.com\/wp-json\/","permalinkStructure":"\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
<style id="tdb-global-colors">
        :root {--accent-color: #fff;}
    </style>
<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/freepressokc.com\/wp-admin\/","wpRestNonce":"9acc81f528","wpRestUrl":"https:\/\/freepressokc.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>
<script>
        window.tdaGlobal = {"adminUrl":"https:\/\/freepressokc.com\/wp-admin\/","wpRestNonce":"9acc81f528","wpRestUrl":"https:\/\/freepressokc.com\/wp-json\/","permalinkStructure":"\/%postname%\/","postId":17922};
    </script>

<script>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</script>

<style>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</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-89779313-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-89779313-1');
</script>
<script>
(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
el = d.createElement('script');
el.id = "js-pp-banner";
el.src = "//dashboard.presspatron.com/dev/banner?b=pMamyM1ZSttVyfgPpMYw2zgS";
fjs.parentNode.insertBefore(el, fjs);
}(document));
</script>
<div id="pp-banner"></div>
<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://freepressokc.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://freepressokc.com/category/crime/",
                    "name": "Crime"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://freepressokc.com/latest-three-homicides-in-okc-happened-over-two-days/",
                    "name": "Latest three homicides in OKC happened over two days"                                
                }
            }    
        ]
    }
</script>
<link rel="icon" href="https://freepressokc.com/wp-content/uploads/2021/05/cropped-FPLogo-Nov1-black-32x32.png" sizes="32x32" />
<link rel="icon" href="https://freepressokc.com/wp-content/uploads/2021/05/cropped-FPLogo-Nov1-black-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://freepressokc.com/wp-content/uploads/2021/05/cropped-FPLogo-Nov1-black-180x180.png" />
<meta name="msapplication-TileImage" content="https://freepressokc.com/wp-content/uploads/2021/05/cropped-FPLogo-Nov1-black-270x270.png" />
<link rel="alternate" type="application/rss+xml" title="RSS" href="https://freepressokc.com/rsslatest.xml" /><style type="text/css" title="dynamic-css" class="options-output">.wtr-time-wrap{text-align:left;line-height:20px;font-weight:400;font-style:italic;color:#079603;font-size:14px;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading .wtr-time-wrap{opacity: 0;}.ie.wf-loading .wtr-time-wrap{visibility: hidden;}</style>

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                body .tdm-social-item i {
                    color: #dd3333;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #dd3333;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #dd3333;
                }
                .tdm-btn-style1 {
					background-color: #dd3333;
				}
				.tdm-btn-style2:before {
				    border-color: #dd3333;
				}
				.tdm-btn-style2 {
				    color: #dd3333;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #dd3333;
                    -moz-box-shadow: 0 2px 16px #dd3333;
                    box-shadow: 0 2px 16px #dd3333;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #dd3333;
                    -moz-box-shadow: 0 4px 26px #dd3333;
                    box-shadow: 0 4px 26px #dd3333;
				}
</style>
<style id="tdw-css-placeholder"></style></head>
<body class="post-template-default single single-post postid-17922 single-format-standard td-standard-pack latest-three-homicides-in-okc-happened-over-two-days global-block-template-1 td-politics single_template_3 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up  td-hide-scroll-up-on-mob" style="display:none;"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/oklahomacityfreepress/" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/freepressokc" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="/cdn-cgi/l/email-protection#3e575058517e584c5b5b4e4c5b4d4d51555d105d5153" title="Mail">
<i class="td-icon-font td-icon-mail-1"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.reddit.com/user/OKC_Free_Press/" title="Reddit">
<i class="td-icon-font td-icon-reddit"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://freepressokc.com/feed/" title="RSS">
<i class="td-icon-font td-icon-rss"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/freepressokc" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/channel/UCKnwaGON2-YbuX9-smgCafw" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span> </div>

<div class="td-mobile-close">
<a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-8600" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-8600"><a href="https://freepressokc.com/category/health-and-covid-19/">Health and COVID-19</a></li>
<li id="menu-item-10452" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-10452"><a href="https://freepressokc.com/category/seen-heard/">Seen and Heard<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-46" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46"><a href="https://freepressokc.com/category/cultures/">Cultures</a></li>
<li id="menu-item-16178" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16178"><a href="https://freepressokc.com/category/seen-heard/fire-activity/">OKC Fire Department</a></li>
<li id="menu-item-45" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-45"><a href="https://freepressokc.com/category/crime/">Crime</a></li>
<li id="menu-item-7689" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7689"><a href="https://freepressokc.com/category/neighborhood-news/">Neighborhood news</a></li>
</ul>
</li>
<li id="menu-item-231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-231"><a href="https://freepressokc.com/category/politics/">Politics<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-10122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10122"><a href="https://freepressokc.com/category/politics/protests/">Protests</a></li>
</ul>
</li>
<li id="menu-item-48" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48"><a href="https://freepressokc.com/category/government/">Government</a></li>
<li id="menu-item-17541" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17541"><a href="https://freepressokc.com/category/best-of-state-coverage/">Best of state coverage</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47"><a href="https://freepressokc.com/category/education/">Education</a></li>
<li id="menu-item-4328" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-4328"><a href="https://freepressokc.com/category/the-arts/">The Arts<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-416" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-416"><a href="https://freepressokc.com/category/the-arts/cinema/">Cinema<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-9394" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9394"><a href="https://freepressokc.com/category/the-arts/cinema/deadcenter/">deadCenter Film Festival</a></li>
</ul>
</li>
<li id="menu-item-8423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8423"><a href="https://freepressokc.com/category/music/">Music</a></li>
<li id="menu-item-16680" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16680"><a href="https://freepressokc.com/category/the-arts/music-and-film-column/">Music and Film column</a></li>
</ul>
</li>
<li id="menu-item-1033" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1033"><a href="https://freepressokc.com/category/business/">Business</a></li>
<li id="menu-item-13878" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13878"><a href="https://freepressokc.com/category/real-estate/">Real Estate</a></li>
<li id="menu-item-50" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50"><a href="https://freepressokc.com/category/technology/">Science and Technology</a></li>
<li id="menu-item-7892" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-7892"><a href="https://freepressokc.com/category/opinion/">Opinion &#8211; Community voices<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-10451" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10451"><a href="https://freepressokc.com/category/opinion/open-letters/">Open Letters</a></li>
<li id="menu-item-7647" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7647"><a href="https://freepressokc.com/category/first-person/">First Person</a></li>
<li id="menu-item-14905" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14905"><a href="https://freepressokc.com/category/opinion/paula-sophia-manhood/">First Person &#8211; Paula Sophia &#8211; Manhood, from the inside out</a></li>
<li id="menu-item-10449" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10449"><a href="https://freepressokc.com/category/opinion/editor-notes/">Editor&#8217;s Notes</a></li>
</ul>
</li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search">
<form method="get" class="td-search-form" action="https://freepressokc.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="tdc-header-wrap ">

<div class="td-header-wrap td-header-style-10 ">
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="td_data_time">
 <div>
Wednesday, March 9, 2022
</div>
</div>
<div class="menu-top-container"><ul id="menu-about-mission-and-goals-ad-pol" class="top-header-menu"><li id="menu-item-5465" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-5465"><a href="https://freepressokc.com/about/">About</a></li>
<li id="menu-item-5466" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-5466"><a href="https://freepressokc.com/mission-goals/">Mission and Goals</a></li>
<li id="menu-item-8933" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-8933"><a href="https://freepressokc.com/political-advertising-policy/">Political Advertising Policy</a></li>
<li id="menu-item-15468" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-15468"><a href="https://freepressokc.com/corrections-policy/">Corrections Policy</a></li>
<li id="menu-item-16502" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-16502"><a href="https://freepressokc.com/eventscalendar/">Events Calendar</a></li>
</ul></div></div>
<div class="td-header-sp-top-widget">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://freepressokc.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/oklahomacityfreepress/" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/freepressokc" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="/cdn-cgi/l/email-protection#a8c1c6cec7e8cedacdcdd8dacddbdbc7c3cb86cbc7c5" title="Mail">
<i class="td-icon-font td-icon-mail-1"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.reddit.com/user/OKC_Free_Press/" title="Reddit">
<i class="td-icon-font td-icon-reddit"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://freepressokc.com/feed/" title="RSS">
<i class="td-icon-font td-icon-rss"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/freepressokc" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/channel/UCKnwaGON2-YbuX9-smgCafw" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span> </div> </div>

<div id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
<div class="td-login-wrap">
<a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-modal-back"></i></a>
 <div id="td-login-div" class="td-login-form-div td-display-block">
<div class="td-login-panel-title">Sign in</div>
<div class="td-login-panel-descr">Welcome! Log into your account</div>
<div class="td_display_err"></div>
<form id="loginForm" action="#" method="post">
<div class="td-login-inputs"><input class="td-login-input" autocomplete="username" type="text" name="login_email" id="login_email" value="" required><label for="login_email">your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" autocomplete="current-password" type="password" name="login_pass" id="login_pass" value="" required><label for="login_pass">your password</label></div>
<input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
</form>
<div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
<div class="td-login-info-text"><a class="privacy-policy-link" href="https://freepressokc.com/privacy-statement/">Privacy Statement</a></div>
</div>
<div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
<div class="td-login-panel-title">Password recovery</div>
<div class="td-login-panel-descr">Recover your password</div>
<div class="td_display_err"></div>
<form id="forgotpassForm" action="#" method="post">
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label for="forgot_email">your email</label></div>
<input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
</form>
<div class="td-login-info-text">A password will be e-mailed to you.</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-banner-wrap-full td-logo-wrap-full  td-container-wrap ">
<div class="td-header-sp-logo">
<div class="td-logo-text-wrap">
<span class="td-logo-text-container">
<a class="td-logo-wrap" href="https://freepressokc.com/">
<span class="td-logo-text">Oklahoma City Free Press</span>
<span class="td-tagline-text">Oklahoma City's award-winning independent news</span>
</a>
</span>
</div>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap td-header-gradient td-header-menu-no-search">
<div class="td-container td-header-row td-header-main-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
</div>
<div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-8600"><a href="https://freepressokc.com/category/health-and-covid-19/">Health and COVID-19</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-10452"><a href="https://freepressokc.com/category/seen-heard/">Seen and Heard</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-46"><a href="https://freepressokc.com/category/cultures/">Cultures</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-16178"><a href="https://freepressokc.com/category/seen-heard/fire-activity/">OKC Fire Department</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-45"><a href="https://freepressokc.com/category/crime/">Crime</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7689"><a href="https://freepressokc.com/category/neighborhood-news/">Neighborhood news</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-231"><a href="https://freepressokc.com/category/politics/">Politics</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10122"><a href="https://freepressokc.com/category/politics/protests/">Protests</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-48"><a href="https://freepressokc.com/category/government/">Government</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-17541"><a href="https://freepressokc.com/category/best-of-state-coverage/">Best of state coverage</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-47"><a href="https://freepressokc.com/category/education/">Education</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-4328"><a href="https://freepressokc.com/category/the-arts/">The Arts</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-416"><a href="https://freepressokc.com/category/the-arts/cinema/">Cinema</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-9394"><a href="https://freepressokc.com/category/the-arts/cinema/deadcenter/">deadCenter Film Festival</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-8423"><a href="https://freepressokc.com/category/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-16680"><a href="https://freepressokc.com/category/the-arts/music-and-film-column/">Music and Film column</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1033"><a href="https://freepressokc.com/category/business/">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-13878"><a href="https://freepressokc.com/category/real-estate/">Real Estate</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-50"><a href="https://freepressokc.com/category/technology/">Science and Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-7892"><a href="https://freepressokc.com/category/opinion/">Opinion &#8211; Community voices</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10451"><a href="https://freepressokc.com/category/opinion/open-letters/">Open Letters</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7647"><a href="https://freepressokc.com/category/first-person/">First Person</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14905"><a href="https://freepressokc.com/category/opinion/paula-sophia-manhood/">First Person &#8211; Paula Sophia &#8211; Manhood, from the inside out</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10449"><a href="https://freepressokc.com/category/opinion/editor-notes/">Editor&#8217;s Notes</a></li>
</ul>
</li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<article id="post-17922" class="td-post-template-3 post-17922 post type-post status-publish format-standard has-post-thumbnail category-crime tag-homicide tag-okcpd tag-oklahoma-city-police-department td-container-wrap" itemscope itemtype="https://schema.org/Article">
<div class="td-post-header td-container">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://freepressokc.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Crime" class="entry-crumb" href="https://freepressokc.com/category/crime/">Crime</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Latest three homicides in OKC happened over two days</span></div></div>
<div class="td-post-header-holder td-image-gradient">
<div class="td-post-featured-image"><a href="https://freepressokc.com/wp-content/uploads/2021/09/OKCPD-Crime-Scene-unit-DSC09757.jpg" data-caption=""><img width="1068" height="601" class="entry-thumb td-modal-image" src="https://freepressokc.com/wp-content/uploads/2021/09/OKCPD-Crime-Scene-unit-DSC09757-1068x601.jpg" srcset="https://freepressokc.com/wp-content/uploads/2021/09/OKCPD-Crime-Scene-unit-DSC09757-1068x601.jpg 1068w, https://freepressokc.com/wp-content/uploads/2021/09/OKCPD-Crime-Scene-unit-DSC09757-300x169.jpg 300w, https://freepressokc.com/wp-content/uploads/2021/09/OKCPD-Crime-Scene-unit-DSC09757-1024x576.jpg 1024w, https://freepressokc.com/wp-content/uploads/2021/09/OKCPD-Crime-Scene-unit-DSC09757-768x432.jpg 768w, https://freepressokc.com/wp-content/uploads/2021/09/OKCPD-Crime-Scene-unit-DSC09757-696x392.jpg 696w, https://freepressokc.com/wp-content/uploads/2021/09/OKCPD-Crime-Scene-unit-DSC09757-747x420.jpg 747w, https://freepressokc.com/wp-content/uploads/2021/09/OKCPD-Crime-Scene-unit-DSC09757.jpg 1280w" sizes="(max-width: 1068px) 100vw, 1068px" alt="" title="OKCPD Crime Scene unit DSC09757" /></a></div>
<header class="td-post-title">
<ul class="td-category"><li class="entry-category"><a href="https://freepressokc.com/category/crime/">Crime</a></li></ul> <h1 class="entry-title">Latest three homicides in OKC happened over two days</h1>
<p class="td-post-sub-title">Homicides #13, #14, #15</p>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://freepressokc.com/author/brett-dickerson/">Brett Dickerson - Editor</a><div class="td-author-line"> - </div> </div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-03-09T17:20:19-06:00">March 9, 2022</time></span>  </div>
</header>
</div>
</div>
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 ">
<style>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</style>
<div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
<div class="td-social-but-icon"><i class="td-icon-share"></i></div>
<div class="td-social-but-text">Share</div>
</div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffreepressokc.com%2Flatest-three-homicides-in-okc-happened-over-two-days%2F" title="Facebook">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Latest+three+homicides+in+OKC+happened+over+two+days&url=https%3A%2F%2Ffreepressokc.com%2Flatest-three-homicides-in-okc-happened-over-two-days%2F&via=freepressokc" title="Twitter">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://freepressokc.com/latest-three-homicides-in-okc-happened-over-two-days/&title=Latest+three+homicides+in+OKC+happened+over+two+days" title="ReddIt">
<div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
<div class="td-social-but-text">ReddIt</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#79460a0c1b131c1a0d4435180d1c0a0d590d110b1c1c59111614101a101d1c0a5910175936323a59111809091c171c1d59160f1c0b590d0e16591d18000a5f1b161d0044110d0d090a4356561f0b1c1c090b1c0a0a16121a571a16145615180d1c0a0d540d110b1c1c54111614101a101d1c0a5410175416121a54111809091c171c1d54160f1c0b540d0e16541d18000a56" title="Email">
<div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
<div class="td-social-but-text">Email</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print">
<div class="td-social-but-icon"><i class="td-icon-print"></i></div>
<div class="td-social-but-text">Print</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top" title="More">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>
<div class="td-post-content tagdiv-type">
<span class="wtr-time-wrap before-content"><span class="wtr-time-number">2</span> minute read</span><div id="wtr-content" data-bg="#FFFFFF" data-fg="#f44813" data-width="5" data-mute="" data-fgopacity="0.5" data-mutedopacity="0.5" data-placement="left" data-placement-offset="0" data-content-offset="0" data-placement-touch="left" data-placement-offset-touch="0" data-transparent="" data-shadow="1" data-touch="1" data-non-touch="1" data-comments="0" data-commentsbg="#ffcece" data-location="page" data-mutedfg="#f44813" data-endfg="#f44813" data-rtl="">
<p>OKLAHOMA CITY (<a href="https://freepressokc.com">Free Press</a>) &#8212; In just the course of two days over the weekend in Oklahoma City, three homicides occurred involving a fourth person who was injured but lived. The count comes to 15 homicides for 2022 so far.</p>
<h2><strong>Homicide #13</strong></h2>
<p>Alexis Stevens survived a shooting on the south side Saturday night, March 5, but another victim of the same shooting did not. The name of the victim who died has still not been released by the Oklahoma City Police Department (OKCPD).</p>
<p>An altercation between an employee of the 7-11 store at 1245 SW 29<sup>th</sup>&nbsp;Street and the individual not yet named led to the victim being shot to death.</p>
<p>Stevens, the victim who lived, was struck in the hip by a stray shot. She was taken to a local hospital and treated &#8220;for a non-life-threatening injury,&#8221; an OKCPD press release stated.</p>
<p>No arrests have been made as of publication time and the case is still open.</p>
<h2><strong>Homicide #14 </strong></h2>
<p>OKCPD arrived at a convenience store at 12300 N. MacArthur Blvd Sunday at 3:35 a.m. having been called to check a gunshot victim inside a vehicle.</p>
<p>Officers found 20-year-old Malachi Titus (B/M 11-20-2002) dead on the passenger side of the front seat.</p>
<p>After observing signs that the vehicle had been hit multiple times by gunfire, officers then learned that the shooting might have taken place in the 6000 block of W. Wilshire as a drive-by shooting.</p>
<p>No arrests have been made and the case is still open as of publication time.</p>
<h2><strong>Homicide #15</strong></h2>
<p>Responding to a call of a &#8220;man down&#8221; later in the morning Sunday at 6:21 a.m., officers arrived in the 5300 block of Willow Cliff Drive and found one dead who appeared to have been shot to death.</p>
<p>The victim has been identified as Travian Jefferson. OKCPD has given no other identifying information.</p>
<p>No arrests have been made. The case is still open as of publication time.</p>
<h2><strong>Previous homicides in 2022</strong></h2>
<p>Free Press has covered earlier homicides in 2022:</p>
<ul><li>Homicide #12 &#8212; <strong><a href="https://freepressokc.com/one-man-dead-one-okcpd-officer-wounded-in-southside-shootout/">One man dead, one OKCPD officer wounded in southside shootout</a></strong></li><li>Homicide #11 &#8212; <strong><a href="https://freepressokc.com/okc-homicide-11-suspect-dies-in-crash-after-police-find-woman-dead/">OKC homicide #11 suspect dies in crash after police find woman dead</a></strong></li><li>Homicides #1-10 &#8212; <strong><a href="https://freepressokc.com/ten-homicides-so-far-in-2022-for-city-of-okc-here-is-what-we-know/">Ten homicides so far in 2022 for City of OKC — here is what we know</a></strong></li></ul>
<h2><strong>If you have information</strong></h2>
<p>If you have information about these homicides or any others, call the Homicide Tip-Line at 405/297-1200.</p>
<hr class="wp-block-separator" />
<p class="post-modified-info">Last Updated March 9, 2022, 5:37 PM by <a href="" target="_blank" class="last-modified-author">Brett Dickerson &#8211; Editor</a></p></div> </div>
<footer>
<div class="td-post-source-tags">
<ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://freepressokc.com/tag/homicide/">homicide</a></li><li><a href="https://freepressokc.com/tag/okcpd/">OKCPD</a></li><li><a href="https://freepressokc.com/tag/oklahoma-city-police-department/">Oklahoma City Police Department</a></li></ul> </div>
<div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
<div class="td-social-but-icon"><i class="td-icon-share"></i></div>
<div class="td-social-but-text">Share</div>
</div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffreepressokc.com%2Flatest-three-homicides-in-okc-happened-over-two-days%2F" title="Facebook">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Latest+three+homicides+in+OKC+happened+over+two+days&url=https%3A%2F%2Ffreepressokc.com%2Flatest-three-homicides-in-okc-happened-over-two-days%2F&via=freepressokc" title="Twitter">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://freepressokc.com/latest-three-homicides-in-okc-happened-over-two-days/&title=Latest+three+homicides+in+OKC+happened+over+two+days" title="ReddIt">
<div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
<div class="td-social-but-text">ReddIt</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#734c000611191610074e3f120716000753071b011616531b1c1e1a101a171600531a1d533c3830531b120303161d1617531c0516015307041c5317120a0055111c170a4e1b07070300495c5c1501161603011600001c18105d101c1e5c1f12071600075e071b0116165e1b1c1e1a101a1716005e1a1d5e1c18105e1b120303161d16175e1c0516015e07041c5e17120a005c" title="Email">
<div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
<div class="td-social-but-text">Email</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print">
<div class="td-social-but-icon"><i class="td-icon-print"></i></div>
<div class="td-social-but-text">Print</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom" title="More">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div> <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://freepressokc.com/norman-starbucks-baristas-petition-for-union-election-second-in-okla/">Norman Starbucks baristas petition for union election &#8212; second in Okla</a></div></div><div class="td-next-prev-separator"></div></div> <div class="author-box-wrap"><a href="https://freepressokc.com/author/brett-dickerson/" aria-label="author-photo"><img data-del="avatar" src='https://freepressokc.com/wp-content/uploads/2021/05/Brett-profile-pic-150x150.jpeg' class='avatar pp-user-avatar avatar-96 photo ' height='96' width='96' /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://freepressokc.com/author/brett-dickerson/">Brett Dickerson - Editor</a></span></div><div class="td-author-description">Founder, editor, writer, photographer: Oklahoma City Free Press.</div><div class="td-author-social"></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Brett Dickerson - Editor"><meta itemprop="url" content="https://freepressokc.com/author/brett-dickerson/"></span><meta itemprop="datePublished" content="2022-03-09T17:20:19-06:00"><meta itemprop="dateModified" content="2022-03-09T17:37:01-06:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://freepressokc.com/latest-three-homicides-in-okc-happened-over-two-days/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://freepressokc.com/latest-three-homicides-in-okc-happened-over-two-days/"></span><meta itemprop="name" content="Oklahoma City Free Press"></span><meta itemprop="headline " content="Latest three homicides in OKC happened over two days"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://freepressokc.com/wp-content/uploads/2021/09/OKCPD-Crime-Scene-unit-DSC09757.jpg"><meta itemprop="width" content="1280"><meta itemprop="height" content="720"></span> </footer>
<div class="td_block_wrap td_block_related_posts tdi_2 td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_2"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_2 = new tdBlock();
block_tdi_2.id = "tdi_2";
block_tdi_2.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_tags","td_ajax_filter_type":"td_custom_related","class":"tdi_2","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":17922,"live_filter_cur_post_author":"1","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_2","tdc_css_class_style":"tdi_2_rand_style"}';
block_tdi_2.td_column_number = "3";
block_tdi_2.block_type = "td_block_related_posts";
block_tdi_2.post_count = "3";
block_tdi_2.found_posts = "33";
block_tdi_2.header_color = "";
block_tdi_2.ajax_pagination_infinite_stop = "";
block_tdi_2.max_num_pages = "11";
tdBlocksArray.push(block_tdi_2);
</script><h4 class="td-related-title td-block-title"><a id="tdi_3" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_2" href="#">RELATED ARTICLES</a><a id="tdi_4" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_2" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_2 class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://freepressokc.com/one-man-dead-one-okcpd-officer-wounded-in-southside-shootout/" rel="bookmark" class="td-image-wrap " title="One man dead, one OKCPD officer wounded in southside shootout"><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2020/12/Bus-stabbing-12-22-20-DSC04430-218x150.jpg" srcset="https://freepressokc.com/wp-content/uploads/2020/12/Bus-stabbing-12-22-20-DSC04430-218x150.jpg 218w, https://freepressokc.com/wp-content/uploads/2020/12/Bus-stabbing-12-22-20-DSC04430-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="police" title="One man dead, one OKCPD officer wounded in southside shootout" /></a></div> <a href="https://freepressokc.com/category/crime/" class="td-post-category">Crime</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://freepressokc.com/one-man-dead-one-okcpd-officer-wounded-in-southside-shootout/" rel="bookmark" title="One man dead, one OKCPD officer wounded in southside shootout">One man dead, one OKCPD officer wounded in southside shootout</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://freepressokc.com/opinion-police-officers-should-understand-they-are-public-servants-first/" rel="bookmark" class="td-image-wrap " title="Opinion: Police officers should understand they are public servants first"><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2020/12/Bus-stabbing-12-22-20-DSC04430-218x150.jpg" srcset="https://freepressokc.com/wp-content/uploads/2020/12/Bus-stabbing-12-22-20-DSC04430-218x150.jpg 218w, https://freepressokc.com/wp-content/uploads/2020/12/Bus-stabbing-12-22-20-DSC04430-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="police" title="Opinion: Police officers should understand they are public servants first" /></a></div> <a href="https://freepressokc.com/category/opinion/" class="td-post-category">Opinion - Community voices</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://freepressokc.com/opinion-police-officers-should-understand-they-are-public-servants-first/" rel="bookmark" title="Opinion: Police officers should understand they are public servants first">Opinion: Police officers should understand they are public servants first</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://freepressokc.com/okc-city-council-to-consider-consultant-findings-police-reform/" rel="bookmark" class="td-image-wrap " title="OKC City Council to consider consultant findings for police reform"><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2020/05/DSC05976-218x150.jpg" srcset="https://freepressokc.com/wp-content/uploads/2020/05/DSC05976-218x150.jpg 218w, https://freepressokc.com/wp-content/uploads/2020/05/DSC05976-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="police" title="OKC City Council to consider consultant findings for police reform" /></a></div> <a href="https://freepressokc.com/category/government/" class="td-post-category">Government</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://freepressokc.com/okc-city-council-to-consider-consultant-findings-police-reform/" rel="bookmark" title="OKC City Council to consider consultant findings for police reform">OKC City Council to consider consultant findings for police reform</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_2" data-td_block_id="tdi_2"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_2" data-td_block_id="tdi_2"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div></div> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside id="60b995e127a1b-3" class="td_block_template_1 widget 60b995e127a1b-3 60b995e127a1b"><div class="a-single a-4"><center><a class="gofollow" data-track="NCwwLDEsMTU=" href="https://trueskycu.org/747loan/" target="_blank" rel="nofollow"><img src="https://freepressokc.com/wp-content/banners/truesky-747-digital-ads-01.jpeg" width="300" height="250" /></a></center></div></aside><aside id="60b995e127a1b-9" class="td_block_template_1 widget 60b995e127a1b-9 60b995e127a1b"><div class="a-single a-16"><center><a class="gofollow" data-track="MTYsMCwxLDE1" href="https://www.okcmoa.com/visit/events/the-perfect-shot/" target="_blank" rel="nofollow"><img src="https://freepressokc.com/wp-content/banners/okcmoa-looss-medium-rectangle-300x250.jpeg" width="300" height="250" /></a></center></div></aside><aside id="60b995e127a1b-10" class="td_block_template_1 widget 60b995e127a1b-10 60b995e127a1b"><div class="a-single a-11"><center><a class="gofollow" data-track="MTEsMCwxLDE1" href="https://workflowokc.com" target="_blank" rel="nofollow"><img src="https://freepressokc.com/wp-content/banners/free-press-sidebar-01.jpeg" width="300" height="250" /></a></center></div></aside> </div>
</div>
</div> 
</div> 
</article> 

<div class="tdc-footer-wrap ">

<div class="td-footer-wrapper td-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
<div class="td-pb-row">
<div class="td-pb-span12">
<aside class="td_block_template_1 widget 60b995e127a1b"><div class="a-single a-15"><center><a class="gofollow" data-track="MTUsMCwxLDE1" href="https://www.okcmoa.com/visit/events/the-perfect-shot/" target="_blank" rel="nofollow"><img src="https://freepressokc.com/wp-content/banners/okcmoa-looss-1024x145.jpeg" width="1024" height="145" /></a></center></div></aside> </div>
</div>
</div>
<div class="td-footer-bottom-full">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://freepressokc.com/"><img src="https://freepressokc.com/wp-content/uploads/2016/11/FPLogo-Nov1-white-150x150.png" alt="Oklahoma City Free Press" title="Oklahoma City Free Press" /></a></aside></div><div class="td-pb-span9"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div><hr>
<p><strong>Sustain our journalism by becoming a supporter<br></strong></p>
<p>Oklahoma City Free Press is dedicated to providing high quality journalism that positively impacts our community. We give voice to those who aren’t heard and expose that which is hidden from the public. Click this <a href="https://pp-staging.presspatron.com/donations/new?frame=1&t=VuVQRxLy7UcJsBNvasA5tDAz">link</a> or the red button below to support our mission.</p>
<div class="pp-donate-button"> </div>
<hr>
Published by Oklahoma City Free Press LLC, Oklahoma City, Oklahoma -- Publisher and Editor - Brett Dickerson. All photography and content is under copyright. We adhere to the Society of Professional Journalists Code of Ethics.</aside></div> </div>
</div>
</div>
</div>

<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
</div>
<div class="td-pb-span td-sub-footer-copy">
&copy; Oklahoma City Free Press LLC, 2016, 2017, 2018, 2019, 2020, 2021. <a href="//www.dmca.com/Protection/Status.aspx?ID=64fb634b-962d-4e3b-93ec-bed7c5a4d8ec" title="DMCA.com Protection Status" class="dmca-badge"> <img src="//images.dmca.com/Badges/dmca-badge-w100-5x1-11.png?ID=64fb634b-962d-4e3b-93ec-bed7c5a4d8ec" alt="DMCA.com Protection Status"></a> <script src="//images.dmca.com/Badges/DMCABadgeHelper.min.js"> </script> </div>
</div>
</div>
</div>
</div>
</div>
<script type="text/javascript">
				var _paq = _paq || [];
					_paq.push(['setCustomDimension', 1, '{"ID":1,"name":"Brett Dickerson - Editor","avatar":"7dcc38b2fd586a8125a7801d56f7c87c"}']);
				_paq.push(['trackPageView']);
								(function () {
					var u = "https://stats1.wpmudev.com/";
					_paq.push(['setTrackerUrl', u + 'track/']);
					_paq.push(['setSiteId', '22896']);
					var d   = document, g = d.createElement('script'), s = d.getElementsByTagName('script')[0];
					g.type  = 'text/javascript';
					g.async = true;
					g.defer = true;
					g.src   = 'https://stats.wpmucdn.com/analytics.js';
					s.parentNode.insertBefore(g, s);
				})();
			</script>
<div class="td-more-articles-box">
<i class="td-icon-close td-close-more-articles-box"></i>
<span class="td-more-articles-box-title">MORE STORIES</span>
<div class="td-content-more-articles-box">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://freepressokc.com/more-community-voices-heard-about-police-in-okc-city-council-meeting/" rel="bookmark" class="td-image-wrap " title="More community voices heard about police in OKC City Council meeting"><img width="100" height="70" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2020/06/DSC07318-100x70.jpg" srcset="https://freepressokc.com/wp-content/uploads/2020/06/DSC07318-100x70.jpg 100w, https://freepressokc.com/wp-content/uploads/2020/06/DSC07318-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="City Council" title="More community voices heard about police in OKC City Council meeting" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://freepressokc.com/more-community-voices-heard-about-police-in-okc-city-council-meeting/" rel="bookmark" title="More community voices heard about police in OKC City Council meeting">More community voices heard about police in OKC City Council meeting</a></h3> <div class="td-module-meta-info">
<a href="https://freepressokc.com/category/government/" class="td-post-category">Government</a> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-06-09T20:18:43-05:00">June 9, 2020</time></span> </div>
</div>
</div>
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://freepressokc.com/pierce-meets-okcpd-reps-second/" rel="bookmark" class="td-image-wrap " title="Pierce meets OKCPD reps second time"><img width="100" height="70" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2017/11/DSC_0173-100x70.jpg" srcset="https://freepressokc.com/wp-content/uploads/2017/11/DSC_0173-100x70.jpg 100w, https://freepressokc.com/wp-content/uploads/2017/11/DSC_0173-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Kelsey Pierce after second mtg" title="Pierce meets OKCPD reps second time" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://freepressokc.com/pierce-meets-okcpd-reps-second/" rel="bookmark" title="Pierce meets OKCPD reps second time">Pierce meets OKCPD reps second time</a></h3> <div class="td-module-meta-info">
<a href="https://freepressokc.com/category/government/" class="td-post-category">Government</a> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-11-03T00:49:18-05:00">November 3, 2017</time></span> </div> 
</div>
</div>
</div>
</div>

<script type='text/javascript' id='adrotate-dyngroup-js-extra'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"https:\/\/freepressokc.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.dyngroup.js' id='adrotate-dyngroup-js'></script>
<script type='text/javascript' id='adrotate-clicktracker-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/freepressokc.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js' id='adrotate-clicktracker-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/worth-the-read/js/wtr.js?ver=5.9.1' id='wtr-js-js'></script>
<script type='text/javascript' id='ppress-frontend-script-js-extra'>
/* <![CDATA[ */
var pp_ajax_form = {"ajaxurl":"https:\/\/freepressokc.com\/wp-admin\/admin-ajax.php","confirm_delete":"Are you sure?","deleting_text":"Deleting...","deleting_error":"An error occurred. Please try again.","nonce":"b35a289987","disable_ajax_form":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/wp-user-avatar/assets/js/frontend.min.js?ver=3.2.8' id='ppress-frontend-script-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=ecd3ae9d894693e4aa2a268d920aa306' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=11.4.1' id='td-site-min-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/comment-reply.min.js?ver=5.9.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=ecd3ae9d894693e4aa2a268d920aa306' id='tdb_js_files_for_front-js'></script>

<script>
    
</script>

<script type="text/javascript">
jQuery(document).ready(function(){if(jQuery.fn.gslider) {
	jQuery('.g-1').gslider({groupid:1,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-3').gslider({groupid:3,speed:6000,repeat_impressions:'Y'});
}});
</script>

</body>
</html>