<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>OK County Commissioners endorse recs for new jail on new site</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://freepressokc.com/xmlrpc.php" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<meta property="fb:app_id" content="1249330068491776" />

<link rel="icon" type="image/png" href="https://freepressokc.com/wp-content/uploads/2016/09/cropped-FPlogo-single-png.png">

<meta name="description" content="The Oklahoma County Board of County Commissioners (BoCC) voted Monday to accept recommendations for a new Jail facility on a new site. " />
<link rel="canonical" href="https://freepressokc.com/ok-county-commissioners-endorse-recs-for-new-jail-on-new-site/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="OK County Commissioners endorse recs for new jail on new site" />
<meta property="og:description" content="The Oklahoma County Board of County Commissioners (BoCC) voted Monday to accept recommendations for a new Jail facility on a new site. " />
<meta property="og:url" content="https://freepressokc.com/ok-county-commissioners-endorse-recs-for-new-jail-on-new-site/" />
<meta property="og:site_name" content="Oklahoma City Free Press" />
<meta property="article:publisher" content="https://www.facebook.com/oklahomacityfreepress/" />
<meta property="article:published_time" content="2021-12-06T21:51:11+00:00" />
<meta property="article:modified_time" content="2021-12-06T21:51:12+00:00" />
<meta property="og:image" content="https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="720" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@OKC_SPAN" />
<meta name="twitter:site" content="@freepressokc" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Marty Peercy" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="6 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">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</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Oklahoma City Free Press &raquo; Feed" href="https://freepressokc.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Oklahoma City Free Press &raquo; Comments Feed" href="https://freepressokc.com/comments/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/freepressokc.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://freepressokc.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='wtr-css-css' href='https://freepressokc.com/wp-content/plugins/worth-the-read/css/wtr.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-frontend-css' href='https://freepressokc.com/wp-content/plugins/wp-user-avatar/assets/css/frontend.min.css?ver=3.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-flatpickr-css' href='https://freepressokc.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.css?ver=3.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-select2-css' href='https://freepressokc.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://freepressokc.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=810534ce963cec6bd2e7978db2c935c9x' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Roboto+Slab%3A400%7CLato%3A400%7CRoboto%3A400%2C500%2C700%7COpen+Sans%3A400%2C600%2C700&#038;display=swap&#038;ver=11.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://freepressokc.com/wp-content/themes/childnewspaper7/style.css?ver=1.0' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='td-legacy-framework-front-style-css' href='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=810534ce963cec6bd2e7978db2c935c9x' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css' href='https://freepressokc.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=79f8a1d02f05c15c98a62e68cd419e0b' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css' href='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/includes/demos/politics/demo_style.css?ver=11.3.2' type='text/css' media='all' />
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.js?ver=5.8.2' id='ppress-flatpickr-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.js?ver=5.8.2' id='ppress-select2-js'></script>
<link rel="https://api.w.org/" href="https://freepressokc.com/wp-json/" /><link rel="alternate" type="application/json" href="https://freepressokc.com/wp-json/wp/v2/posts/16524" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://freepressokc.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://freepressokc.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.8.2" />
<link rel='shortlink' href='https://freepressokc.com/?p=16524' />
<link rel="alternate" type="application/json+oembed" href="https://freepressokc.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffreepressokc.com%2Fok-county-commissioners-endorse-recs-for-new-jail-on-new-site%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://freepressokc.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffreepressokc.com%2Fok-county-commissioners-endorse-recs-for-new-jail-on-new-site%2F&#038;format=xml" />


<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>

<style type="text/css">.wtr-time-wrap{ 
	/* wraps the entire label */
	margin: 0 10px;

}
.wtr-time-number{ 
	/* applies only to the number */
	
}</style><style id="wplmi-inline-css" type="text/css"> span.wplmi-user-avatar { width: 16px;display: inline-block !important;flex-shrink: 0; } img.wplmi-elementor-avatar { border-radius: 100%;margin-right: 3px; } 

</style>
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script>
        window.tdb_globals = {"wpRestNonce":"0655deca0b","wpRestUrl":"https:\/\/freepressokc.com\/wp-json\/","permalinkStructure":"\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/freepressokc.com\/wp-admin\/","wpRestNonce":"0655deca0b","wpRestUrl":"https:\/\/freepressokc.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>
<script>
        window.tdaGlobal = {"adminUrl":"https:\/\/freepressokc.com\/wp-admin\/","wpRestNonce":"0655deca0b","wpRestUrl":"https:\/\/freepressokc.com\/wp-json\/","permalinkStructure":"\/%postname%\/","postId":16524};
    </script>

<script>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</script>

<style>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</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-89779313-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-89779313-1');
</script>
<script>
(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
el = d.createElement('script');
el.id = "js-pp-banner";
el.src = "//dashboard.presspatron.com/dev/banner?b=pMamyM1ZSttVyfgPpMYw2zgS";
fjs.parentNode.insertBefore(el, fjs);
}(document));
</script>
<div id="pp-banner"></div>
<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://freepressokc.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://freepressokc.com/category/government/",
                    "name": "Government"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://freepressokc.com/ok-county-commissioners-endorse-recs-for-new-jail-on-new-site/",
                    "name": "OK County Commissioners endorse recs for new jail on new site"                                
                }
            }    
        ]
    }
</script>
<link rel="icon" href="https://freepressokc.com/wp-content/uploads/2021/05/cropped-FPLogo-Nov1-black-32x32.png" sizes="32x32" />
<link rel="icon" href="https://freepressokc.com/wp-content/uploads/2021/05/cropped-FPLogo-Nov1-black-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://freepressokc.com/wp-content/uploads/2021/05/cropped-FPLogo-Nov1-black-180x180.png" />
<meta name="msapplication-TileImage" content="https://freepressokc.com/wp-content/uploads/2021/05/cropped-FPLogo-Nov1-black-270x270.png" />
<link rel="alternate" type="application/rss+xml" title="RSS" href="https://freepressokc.com/rsslatest.xml" /><style type="text/css" title="dynamic-css" class="options-output">.wtr-time-wrap{text-align:left;line-height:20px;font-weight:400;font-style:italic;color:#079603;font-size:14px;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading .wtr-time-wrap{opacity: 0;}.ie.wf-loading .wtr-time-wrap{visibility: hidden;}</style>

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                body .tdm-social-item i {
                    color: #dd3333;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #dd3333;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #dd3333;
                }
                .tdm-btn-style1 {
					background-color: #dd3333;
				}
				.tdm-btn-style2:before {
				    border-color: #dd3333;
				}
				.tdm-btn-style2 {
				    color: #dd3333;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #dd3333;
                    -moz-box-shadow: 0 2px 16px #dd3333;
                    box-shadow: 0 2px 16px #dd3333;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #dd3333;
                    -moz-box-shadow: 0 4px 26px #dd3333;
                    box-shadow: 0 4px 26px #dd3333;
				}
</style>
<style id="tdw-css-placeholder"></style></head>
<body class="post-template-default single single-post postid-16524 single-format-standard td-standard-pack ok-county-commissioners-endorse-recs-for-new-jail-on-new-site global-block-template-1 td-politics single_template_3 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up  td-hide-scroll-up-on-mob" style="display:none;"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/oklahomacityfreepress/" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/freepressokc" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="/cdn-cgi/l/email-protection#8ae3e4ece5caecf8efeffaf8eff9f9e5e1e9a4e9e5e7" title="Mail">
<i class="td-icon-font td-icon-mail-1"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.reddit.com/user/OKC_Free_Press/" title="Reddit">
<i class="td-icon-font td-icon-reddit"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://freepressokc.com/feed/" title="RSS">
<i class="td-icon-font td-icon-rss"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/freepressokc" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/channel/UCKnwaGON2-YbuX9-smgCafw" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span> </div>

<div class="td-mobile-close">
<a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-8600" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-8600"><a href="https://freepressokc.com/category/health-and-covid-19/">Health and COVID-19</a></li>
<li id="menu-item-10452" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-10452"><a href="https://freepressokc.com/category/seen-heard/">Seen and Heard<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-16178" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16178"><a href="https://freepressokc.com/category/seen-heard/fire-activity/">OKC Fire Department</a></li>
</ul>
</li>
<li id="menu-item-231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-231"><a href="https://freepressokc.com/category/politics/">Politics<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-10122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10122"><a href="https://freepressokc.com/category/politics/protests/">Protests</a></li>
</ul>
</li>
<li id="menu-item-48" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-48"><a href="https://freepressokc.com/category/government/">Government</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47"><a href="https://freepressokc.com/category/education/">Education</a></li>
<li id="menu-item-4328" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-4328"><a href="https://freepressokc.com/category/the-arts/">The Arts<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-416" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-416"><a href="https://freepressokc.com/category/the-arts/cinema/">Cinema<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-9394" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9394"><a href="https://freepressokc.com/category/the-arts/cinema/deadcenter/">deadCenter Film Festival</a></li>
</ul>
</li>
<li id="menu-item-8423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8423"><a href="https://freepressokc.com/category/music/">Music</a></li>
</ul>
</li>
<li id="menu-item-46" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46"><a href="https://freepressokc.com/category/cultures/">Cultures</a></li>
<li id="menu-item-7689" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7689"><a href="https://freepressokc.com/category/neighborhood-news/">Neighborhood news</a></li>
<li id="menu-item-45" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45"><a href="https://freepressokc.com/category/crime/">Crime</a></li>
<li id="menu-item-1033" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1033"><a href="https://freepressokc.com/category/business/">Business</a></li>
<li id="menu-item-50" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50"><a href="https://freepressokc.com/category/technology/">Science and Technology</a></li>
<li id="menu-item-13878" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13878"><a href="https://freepressokc.com/category/real-estate/">Real Estate</a></li>
<li id="menu-item-7892" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-7892"><a href="https://freepressokc.com/category/opinion/">Opinion &#8211; Community voices<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-10451" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10451"><a href="https://freepressokc.com/category/opinion/open-letters/">Open Letters</a></li>
<li id="menu-item-7647" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7647"><a href="https://freepressokc.com/category/first-person/">First Person</a></li>
<li id="menu-item-14905" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14905"><a href="https://freepressokc.com/category/opinion/paula-sophia-manhood/">First Person &#8211; Paula Sophia &#8211; Manhood, from the inside out</a></li>
<li id="menu-item-10449" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10449"><a href="https://freepressokc.com/category/opinion/editor-notes/">Editor&#8217;s Notes</a></li>
</ul>
</li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search">
<form method="get" class="td-search-form" action="https://freepressokc.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="tdc-header-wrap ">

<div class="td-header-wrap td-header-style-10 ">
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="td_data_time">
<div>
Monday, December 6, 2021
</div>
</div>
<div class="menu-top-container"><ul id="menu-about-mission-and-goals-ad-pol" class="top-header-menu"><li id="menu-item-5465" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-5465"><a href="https://freepressokc.com/about/">About</a></li>
<li id="menu-item-5466" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-5466"><a href="https://freepressokc.com/mission-goals/">Mission and Goals</a></li>
<li id="menu-item-8933" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-8933"><a href="https://freepressokc.com/political-advertising-policy/">Political Advertising Policy</a></li>
<li id="menu-item-15468" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-15468"><a href="https://freepressokc.com/corrections-policy/">Corrections Policy</a></li>
<li id="menu-item-16502" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-16502"><a href="https://freepressokc.com/eventscalendar/">Events Calendar</a></li>
</ul></div></div>
<div class="td-header-sp-top-widget">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://freepressokc.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/oklahomacityfreepress/" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/freepressokc" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="/cdn-cgi/l/email-protection#046d6a626b446276616174766177776b6f672a676b69" title="Mail">
<i class="td-icon-font td-icon-mail-1"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.reddit.com/user/OKC_Free_Press/" title="Reddit">
<i class="td-icon-font td-icon-reddit"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://freepressokc.com/feed/" title="RSS">
<i class="td-icon-font td-icon-rss"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/freepressokc" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/channel/UCKnwaGON2-YbuX9-smgCafw" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span> </div> </div>

<div id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
<div class="td-login-wrap">
<a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-modal-back"></i></a>
<div id="td-login-div" class="td-login-form-div td-display-block">
<div class="td-login-panel-title">Sign in</div>
<div class="td-login-panel-descr">Welcome! Log into your account</div>
<div class="td_display_err"></div>
<form action="#" method="post">
<div class="td-login-inputs"><input class="td-login-input" autocomplete="username" type="text" name="login_email" id="login_email" value="" required><label for="login_email">your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" autocomplete="current-password" type="password" name="login_pass" id="login_pass" value="" required><label for="login_pass">your password</label></div>
<input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
</form>
<div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
<div class="td-login-info-text"><a class="privacy-policy-link" href="https://freepressokc.com/privacy-statement/">Privacy Statement</a></div>
</div>
<div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
<div class="td-login-panel-title">Password recovery</div>
<div class="td-login-panel-descr">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label for="forgot_email">your email</label></div>
<input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
<div class="td-login-info-text">A password will be e-mailed to you.</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-banner-wrap-full td-logo-wrap-full  td-container-wrap ">
<div class="td-header-sp-logo">
<div class="td-logo-text-wrap">
<span class="td-logo-text-container">
<a class="td-logo-wrap" href="https://freepressokc.com/">
<span class="td-logo-text">Oklahoma City Free Press</span>
<span class="td-tagline-text">Oklahoma City's award-winning independent, online news</span>
</a>
</span>
</div>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap td-header-gradient td-header-menu-no-search">
<div class="td-container td-header-row td-header-main-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
</div>
<div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-8600"><a href="https://freepressokc.com/category/health-and-covid-19/">Health and COVID-19</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-10452"><a href="https://freepressokc.com/category/seen-heard/">Seen and Heard</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-16178"><a href="https://freepressokc.com/category/seen-heard/fire-activity/">OKC Fire Department</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-231"><a href="https://freepressokc.com/category/politics/">Politics</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10122"><a href="https://freepressokc.com/category/politics/protests/">Protests</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-48"><a href="https://freepressokc.com/category/government/">Government</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-47"><a href="https://freepressokc.com/category/education/">Education</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-4328"><a href="https://freepressokc.com/category/the-arts/">The Arts</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-416"><a href="https://freepressokc.com/category/the-arts/cinema/">Cinema</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-9394"><a href="https://freepressokc.com/category/the-arts/cinema/deadcenter/">deadCenter Film Festival</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-8423"><a href="https://freepressokc.com/category/music/">Music</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-46"><a href="https://freepressokc.com/category/cultures/">Cultures</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7689"><a href="https://freepressokc.com/category/neighborhood-news/">Neighborhood news</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-45"><a href="https://freepressokc.com/category/crime/">Crime</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1033"><a href="https://freepressokc.com/category/business/">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-50"><a href="https://freepressokc.com/category/technology/">Science and Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-13878"><a href="https://freepressokc.com/category/real-estate/">Real Estate</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-7892"><a href="https://freepressokc.com/category/opinion/">Opinion &#8211; Community voices</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10451"><a href="https://freepressokc.com/category/opinion/open-letters/">Open Letters</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7647"><a href="https://freepressokc.com/category/first-person/">First Person</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14905"><a href="https://freepressokc.com/category/opinion/paula-sophia-manhood/">First Person &#8211; Paula Sophia &#8211; Manhood, from the inside out</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10449"><a href="https://freepressokc.com/category/opinion/editor-notes/">Editor&#8217;s Notes</a></li>
</ul>
</li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<article id="post-16524" class="td-post-template-3 post-16524 post type-post status-publish format-standard has-post-thumbnail category-government tag-oklahoma-county-detention-center tag-oklahoma-county-jail tag-oklahoma-county-jail-trust td-container-wrap" itemscope itemtype="https://schema.org/Article">
<div class="td-post-header td-container">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://freepressokc.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Government" class="entry-crumb" href="https://freepressokc.com/category/government/">Government</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">OK County Commissioners endorse recs for new jail on new site</span></div></div>
<div class="td-post-header-holder td-image-gradient">
<div class="td-post-featured-image"><figure><a href="https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage.jpg" data-caption="Oklahoma County Jail during the hostage crisis March 27, 2021. (BRETT DICKERSON/Okla City Free Press)"><img width="1068" height="601" class="entry-thumb td-modal-image" src="https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-1068x601.jpg" srcset="https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-1068x601.jpg 1068w, https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-300x169.jpg 300w, https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-1024x576.jpg 1024w, https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-768x432.jpg 768w, https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-696x392.jpg 696w, https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-747x420.jpg 747w, https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage.jpg 1280w" sizes="(max-width: 1068px) 100vw, 1068px" alt="Oklahoma County Jail" title="OK County Jail - hostage" /></a><figcaption class="wp-caption-text">Oklahoma County Jail during the hostage crisis March 27, 2021. (BRETT DICKERSON/Okla City Free Press)</figcaption></figure></div>
<header class="td-post-title">
<ul class="td-category"><li class="entry-category"><a href="https://freepressokc.com/category/government/">Government</a></li></ul> <h1 class="entry-title">OK County Commissioners endorse recs for new jail on new site</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://freepressokc.com/author/martypeercy/">Marty Peercy</a><div class="td-author-line"> - </div> </div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-12-06T15:51:11-06:00">December 6, 2021</time></span> </div>
</header>
</div>
</div>
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 ">
<style>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</style>
<div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
<div class="td-social-but-icon"><i class="td-icon-share"></i></div>
<div class="td-social-but-text">Share</div>
</div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffreepressokc.com%2Fok-county-commissioners-endorse-recs-for-new-jail-on-new-site%2F" title="Facebook">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=OK+County+Commissioners+endorse+recs+for+new+jail+on+new+site&url=https%3A%2F%2Ffreepressokc.com%2Fok-county-commissioners-endorse-recs-for-new-jail-on-new-site%2F&via=freepressokc" title="Twitter">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://freepressokc.com/ok-county-commissioners-endorse-recs-for-new-jail-on-new-site/&title=OK+County+Commissioners+endorse+recs+for+new+jail+on+new+site" title="ReddIt">
<div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
<div class="td-social-but-text">ReddIt</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#506f2325323a3533246d1f1b70133f253e242970133f3d3d392323393f3e35222370353e343f222335702235332370363f22703e3527703a31393c703f3e703e3527702339243576323f34296d38242420236a7f7f3622353520223523233f3b337e333f3d7f3f3b7d333f253e24297d333f3d3d392323393f3e3522237d353e343f2223357d223533237d363f227d3e35277d3a31393c7d3f3e7d3e35277d233924357f" title="Email">
<div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
<div class="td-social-but-text">Email</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print">
<div class="td-social-but-icon"><i class="td-icon-print"></i></div>
<div class="td-social-but-text">Print</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top" title="More">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>
<div class="td-post-content tagdiv-type">
<span class="wtr-time-wrap before-content"><span class="wtr-time-number">6</span> minute read</span><div id="wtr-content" data-bg="#FFFFFF" data-fg="#f44813" data-width="5" data-mute="" data-fgopacity="0.5" data-mutedopacity="0.5" data-placement="left" data-placement-offset="0" data-content-offset="0" data-placement-touch="left" data-placement-offset-touch="0" data-transparent="" data-shadow="1" data-touch="1" data-non-touch="1" data-comments="0" data-commentsbg="#ffcece" data-location="page" data-mutedfg="#f44813" data-endfg="#f44813" data-rtl="">
<p>OKLAHOMA CITY (<a href="https://freepressokc.com">Free Press</a>) &#8212; The Oklahoma County Board of County Commissioners (BoCC) voted Monday to accept recommendations for a new Jail facility on a new site. </p>
<p>The recommendations come from the Oklahoma County Criminal Justice Advisory Council (CJAC) and were recently adopted by the Oklahoma County Criminal Justice Authority (Jail Trust).</p>
<p>Monday’s vote is aspirational, as it is not a concrete plan of action. It does, however, begin the formal process of building a new Jail facility.</p>
<div class="wp-block-media-text alignwide is-stacked-on-mobile"><figure class="wp-block-media-text__media"><img loading="lazy" width="1024" height="576" src="https://freepressokc.com/wp-content/uploads/2021/05/Marty-Peercy-2020-DSC07876-1024x576.jpeg" alt="" class="wp-image-13831 size-full" srcset="https://freepressokc.com/wp-content/uploads/2021/05/Marty-Peercy-2020-DSC07876-1024x576.jpeg 1024w, https://freepressokc.com/wp-content/uploads/2021/05/Marty-Peercy-2020-DSC07876-300x169.jpeg 300w, https://freepressokc.com/wp-content/uploads/2021/05/Marty-Peercy-2020-DSC07876-768x432.jpeg 768w, https://freepressokc.com/wp-content/uploads/2021/05/Marty-Peercy-2020-DSC07876-696x392.jpeg 696w, https://freepressokc.com/wp-content/uploads/2021/05/Marty-Peercy-2020-DSC07876-1068x601.jpeg 1068w, https://freepressokc.com/wp-content/uploads/2021/05/Marty-Peercy-2020-DSC07876-747x420.jpeg 747w, https://freepressokc.com/wp-content/uploads/2021/05/Marty-Peercy-2020-DSC07876.jpeg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure><div class="wp-block-media-text__content">
<blockquote class="wp-block-quote"><p>Marty Peercy reports Local government</p></blockquote>
</div></div>
<p></p>
<h2><strong>Recommendations</strong></h2>
<p>The five recommendations accepted by the BoCC are:</p>
<ul><li>Build a new better facility that meets American Correctional Association (ACA) standards.</li><li>Hold a public vote to continue existing bonds to fund the construction.</li><li>The new facility will have no more than 950 housing units for a maximum population not to exceed 1,800.</li><li>Continue community criminal justice reform efforts to keep the facility with a 15% vacancy, per ACA standards.</li><li>A Site Selection Committee and a Construction Oversight Task Force should be appointed.</li></ul>
<p>These recommendations were developed by a subcommittee of CJAC. Readers will remember that CJAC is the county-wide body made up of law enforcement, elected officials, service providers, and the fabulously wealthy.&nbsp;</p>
<p>CJAC is a project of The Greater Oklahoma City Chamber of Commerce and the one staff person who does the most research for the group is funded by the Chamber.</p>
<p>The facility subcommittee was co-chaired by Sue Ann Arnall, who sits on the Jail Trust, and Dan Straughan, the Executive Director of the Homeless Alliance.&nbsp;</p>
<p>After assessing the Jail and its many problems, according to Straughan, the committee had to come to grips with the reality that the current Jail facility is not fixable.</p>
<p>“A new Jail is the only viable option,” Straughan told the Commissioners.</p>
<p>The subcommittee submitted their recommendations to the rest of CJAC with the consultants, FSB and HOK. CJAC adopted the recommendations last month and presented those recommendations to the Jail Trust last week. </p>
<ul><li><strong>See &#8212; <a href="https://freepressokc.com/ok-county-jail-trust-to-hear-recommendations-for-new-jail-on-new-site/">OK County Jail Trust to hear recommendations for new jail on new site</a></strong></li></ul>
<p>The Jail Trust unanimously accepted the recommendations in order to submit them to the BoCC.</p>
<ul><li><strong>See &#8212; <a href="https://freepressokc.com/jail-trust-approves-new-jail-plan-sends-to-ok-county-commissioners/">Jail Trust approves new jail plan — sends to OK County Commissioners</a></strong></li></ul>
<p>Please the rest of Free Press’s coverage on this process over recent months.</p>
<div class="wp-block-image"><figure class="aligncenter size-large"><img loading="lazy" width="1024" height="576" src="https://freepressokc.com/wp-content/uploads/2021/11/Jail-Trust-11-15-21-PB150813-1024x576.jpg" alt="jail trust" class="wp-image-16210" srcset="https://freepressokc.com/wp-content/uploads/2021/11/Jail-Trust-11-15-21-PB150813-1024x576.jpg 1024w, https://freepressokc.com/wp-content/uploads/2021/11/Jail-Trust-11-15-21-PB150813-300x169.jpg 300w, https://freepressokc.com/wp-content/uploads/2021/11/Jail-Trust-11-15-21-PB150813-768x432.jpg 768w, https://freepressokc.com/wp-content/uploads/2021/11/Jail-Trust-11-15-21-PB150813-696x392.jpg 696w, https://freepressokc.com/wp-content/uploads/2021/11/Jail-Trust-11-15-21-PB150813-1068x601.jpg 1068w, https://freepressokc.com/wp-content/uploads/2021/11/Jail-Trust-11-15-21-PB150813-746x420.jpg 746w, https://freepressokc.com/wp-content/uploads/2021/11/Jail-Trust-11-15-21-PB150813-scaled.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption>The full membership of the Jail Trust 11-15-21. (BRETT DICKERSON/Okla City Free Press)</figcaption></figure></div>
<h2><strong>Public Comment</strong></h2>
<p>The BoCC meeting room was full for Monday’s meeting, including many residents who came specifically to speak to the issue of building a new jail facility. Some familiar faces were present, but also a number of community members who took time away from their everyday lives to come and speak about the issue.</p>
<p>One speaker, Katrina Ward, posed a question to the Commissioners, asking simply how does somebody make something that is inherently harmful “better?”</p>
<p>Conversely, Joy Turner, a disability attorney, endorsed the plan for a new jail, stating that the current jail can’t be fixed.</p>
<p>Sean Cummings, a regular commenter at County meetings, compared the plan to use American Recovery Plan Act (ARPA) funds to construct a new jail to the meeting last year when Calvey gaveled in and called a vote on using $40 million in CARES Funds for the current Jail before Commissioner Blumert had even taken her seat.</p>
<p>Sara Bana, another regular participant in these meetings, compared the plan to former President Donald Trump’s declaration that “we will build a wall and Mexico will pay for it.”</p>
<p>Garland Pruitt of the local NAACP told the Commissioners that they were given an awesome responsibility. He said that the federal government is going to intervene soon if the County doesn’t start to pay more attention.</p>
<p>Hannah Royce, a local activist and graphic designer, echoed Representative Mauree Turner’s favorite quote, “Nothing about us without us,” declaring that this process “has definitely been without us.” Royce urged the Commissioners to wait to approve a plan until there has been sufficient input from the public, which Royce said would require more than two public “listening sessions.”</p>
<p>Royce went on to say that with the Chamber of Commerce’s fingerprints all over the plan, she could only assume it has nothing to do with the conditions in the Jail. She claimed that the purpose of this is to hide poor people from public view, so that tourism and commerce won’t be disrupted by people seeing poor people in the community.</p>
<h2><strong>Commissioners Respond</strong></h2>
<p>After public comment, each Commissioner took the opportunity to address their thoughts on the topic.</p>
<p>District 3 Commissioner Kevin Calvey first addressed a quote of his own from the previous week. At the last meeting of the Jail Trust, Calvey said, “If anything, I wish we could build it bigger.”</p>
<p>People were up in arms about the comment, as most members of the public tend to support reducing incarceration.</p>
<p>On Monday, Calvey backed off of that point and said that the plan for the new facility to hold a higher capacity than the current Jail is an appropriate plan. Calvey quoted Straughan, who said, “let’s not let the perfect become the enemy of the good.”</p>
<p>He went on to say that reforming cash bail too much results in a lack of public safety and invoked the recent parade incident in Waukesha, WI to support his contention.</p>
<div class="wp-block-image"><figure class="aligncenter size-large"><img loading="lazy" width="1024" height="576" src="https://freepressokc.com/wp-content/uploads/2021/11/BoCC-special-11-18-21-PB180118-2-1024x576.jpg" alt="BoCC" class="wp-image-16257" srcset="https://freepressokc.com/wp-content/uploads/2021/11/BoCC-special-11-18-21-PB180118-2-1024x576.jpg 1024w, https://freepressokc.com/wp-content/uploads/2021/11/BoCC-special-11-18-21-PB180118-2-300x169.jpg 300w, https://freepressokc.com/wp-content/uploads/2021/11/BoCC-special-11-18-21-PB180118-2-768x432.jpg 768w, https://freepressokc.com/wp-content/uploads/2021/11/BoCC-special-11-18-21-PB180118-2-696x392.jpg 696w, https://freepressokc.com/wp-content/uploads/2021/11/BoCC-special-11-18-21-PB180118-2-1068x601.jpg 1068w, https://freepressokc.com/wp-content/uploads/2021/11/BoCC-special-11-18-21-PB180118-2-746x420.jpg 746w, https://freepressokc.com/wp-content/uploads/2021/11/BoCC-special-11-18-21-PB180118-2-scaled.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption>The Board of Oklahoma County Commissioners, 11-18-21. L-R: Kevin Calvey, Dist 3; Brian Maughan, Dist 2; Carrie Blumert, Dist 1. (BRETT DICKERSON/Okla City Free Press)</figcaption></figure></div>
<p>District 1 Commissioner Carrie Blumert explained that while she campaigned on wanting to build a new Jail, she is not yet sold on using ARPA funds for it.</p>
<p>She pointed out that state statute requires the County to have and maintain a Jail. So, until that statute changes, we will have a Jail, so it needs to be less inhumane than what we have now.</p>
<p>District 2 Commissioner Brian Maughan said that previously he had been against building a new Jail, but that the current building the County has for a Jail is just not salvageable.</p>
<p>Maughan said that with the bond cycle turning over soon, and ARPA money headed to the County, it’s a once-in-a-lifetime opportunity to do this at very little cost to the taxpayers.</p>
<h2><strong>ARPA Funds</strong></h2>
<p>While the use of ARPA funds is on the table for building a new facility, the specific slate of recommendations does not include using those funds as a line item.</p>
<p>The Commissioners discussed that idea briefly. Blumert, as she said, was skeptical about the use of those funds. Maughan expressed concern about the legal parameters of using ARPA funds. Calvey, while eager to use that money for construction, acquiesced that it was a detail to be sorted out in the future.</p>
<p>Calvey moved to accept the recommendations, Blumert seconded.</p>
<p>The Board passed the motion unanimously.</p>
<p>Developing a plan to move forward on the recommendations will begin at once.</p>
<p>The BoCC will meet again on December 20 at 9:00 a.m.</p>
<hr class="wp-block-separator" />
<p class="post-modified-info">Last Updated December 6, 2021, 3:51 PM by <a href="" target="_blank" class="last-modified-author">Brett Dickerson &#8211; Editor</a></p></div> </div>
<footer>
<div class="td-post-source-tags">
<ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://freepressokc.com/tag/oklahoma-county-detention-center/">Oklahoma County Detention Center</a></li><li><a href="https://freepressokc.com/tag/oklahoma-county-jail/">Oklahoma County Jail</a></li><li><a href="https://freepressokc.com/tag/oklahoma-county-jail-trust/">Oklahoma County Jail Trust</a></li></ul> </div>
<div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
<div class="td-social-but-icon"><i class="td-icon-share"></i></div>
<div class="td-social-but-text">Share</div>
</div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffreepressokc.com%2Fok-county-commissioners-endorse-recs-for-new-jail-on-new-site%2F" title="Facebook">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=OK+County+Commissioners+endorse+recs+for+new+jail+on+new+site&url=https%3A%2F%2Ffreepressokc.com%2Fok-county-commissioners-endorse-recs-for-new-jail-on-new-site%2F&via=freepressokc" title="Twitter">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://freepressokc.com/ok-county-commissioners-endorse-recs-for-new-jail-on-new-site/&title=OK+County+Commissioners+endorse+recs+for+new+jail+on+new+site" title="ReddIt">
<div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
<div class="td-social-but-text">ReddIt</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#142b6761767e717760295b5f34577b617a606d34577b79797d67677d7b7a71666734717a707b666771346671776734727b66347a7163347e757d78347b7a347a716334677d607132767b706d297c606064672e3b3b7266717164667167677b7f773a777b793b7b7f39777b617a606d39777b79797d67677d7b7a71666739717a707b666771396671776739727b66397a7163397e757d78397b7a397a716339677d60713b" title="Email">
<div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
<div class="td-social-but-text">Email</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print">
<div class="td-social-but-icon"><i class="td-icon-print"></i></div>
<div class="td-social-but-text">Print</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom" title="More">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div> <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://freepressokc.com/manhood-from-the-inside-out-part-38-baseball-rebels/">Manhood – from the inside out – part 38 – baseball rebels</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://freepressokc.com/petition-filed-demanding-grand-jury-investigation-of-ok-county-da-prater/">Petition filed demanding grand jury investigation of OK County DA Prater</a></div></div></div> <div class="author-box-wrap"><a href="https://freepressokc.com/author/martypeercy/" aria-label="author-photo"><img data-del="avatar" src='https://freepressokc.com/wp-content/uploads/2020/01/Marty-avatar-150x150.jpg' class='avatar pp-user-avatar avatar-96 photo ' height='96' width='96' /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://freepressokc.com/author/martypeercy/">Marty Peercy</a></span></div><div class="td-author-description">Columnist covering local government in Oklahoma City and Oklahoma County. || "I'm a gadfly, former ne'er-do-well/current rare-do-well. I❤️OKC."
|| Editor's note: Marty can be found on Twitter @OKC_SPAN where he live-tweets local Oklahoma County and Oklahoma City government meetings. Patreon - https://www.patreon.com/martypeercy .</div><div class="td-author-social">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/OKC_SPAN" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Marty Peercy"></span><meta itemprop="datePublished" content="2021-12-06T15:51:11-06:00"><meta itemprop="dateModified" content="2021-12-06T15:51:12-06:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://freepressokc.com/ok-county-commissioners-endorse-recs-for-new-jail-on-new-site/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://freepressokc.com/ok-county-commissioners-endorse-recs-for-new-jail-on-new-site/"></span><meta itemprop="name" content="Oklahoma City Free Press"></span><meta itemprop="headline " content="OK County Commissioners endorse recs for new jail on new site"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage.jpg"><meta itemprop="width" content="1280"><meta itemprop="height" content="720"></span> </footer>
<div class="td_block_wrap td_block_related_posts tdi_2 td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_2"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_2 = new tdBlock();
block_tdi_2.id = "tdi_2";
block_tdi_2.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_tags","td_ajax_filter_type":"td_custom_related","class":"tdi_2","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":16524,"live_filter_cur_post_author":"29","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_2","tdc_css_class_style":"tdi_2_rand_style"}';
block_tdi_2.td_column_number = "3";
block_tdi_2.block_type = "td_block_related_posts";
block_tdi_2.post_count = "3";
block_tdi_2.found_posts = "75";
block_tdi_2.header_color = "";
block_tdi_2.ajax_pagination_infinite_stop = "";
block_tdi_2.max_num_pages = "25";
tdBlocksArray.push(block_tdi_2);
</script><h4 class="td-related-title td-block-title"><a id="tdi_3" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_2" href="#">RELATED ARTICLES</a><a id="tdi_4" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_2" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_2 class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://freepressokc.com/jail-trust-approves-new-jail-plan-sends-to-ok-county-commissioners/" rel="bookmark" class="td-image-wrap " title="Jail Trust approves new jail plan &#8212; sends to OK County Commissioners"><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2021/03/County-Jail-Hostage-sit-3-27-21-DSC07819-218x150.jpeg" srcset="https://freepressokc.com/wp-content/uploads/2021/03/County-Jail-Hostage-sit-3-27-21-DSC07819-218x150.jpeg 218w, https://freepressokc.com/wp-content/uploads/2021/03/County-Jail-Hostage-sit-3-27-21-DSC07819-100x70.jpeg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Jail" title="Jail Trust approves new jail plan &#8212; sends to OK County Commissioners" /></a></div> <a href="https://freepressokc.com/category/government/" class="td-post-category">Government</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://freepressokc.com/jail-trust-approves-new-jail-plan-sends-to-ok-county-commissioners/" rel="bookmark" title="Jail Trust approves new jail plan &#8212; sends to OK County Commissioners">Jail Trust approves new jail plan &#8212; sends to OK County Commissioners</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://freepressokc.com/ok-county-jail-trust-to-hear-recommendations-for-new-jail-on-new-site/" rel="bookmark" class="td-image-wrap " title="OK County Jail Trust to hear recommendations for new jail on new site"><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-218x150.jpg" srcset="https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-218x150.jpg 218w, https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Oklahoma County Jail" title="OK County Jail Trust to hear recommendations for new jail on new site" /></a></div> <a href="https://freepressokc.com/category/government/" class="td-post-category">Government</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://freepressokc.com/ok-county-jail-trust-to-hear-recommendations-for-new-jail-on-new-site/" rel="bookmark" title="OK County Jail Trust to hear recommendations for new jail on new site">OK County Jail Trust to hear recommendations for new jail on new site</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://freepressokc.com/jail-trust-criticized-by-activists-approves-contract-and-budget/" rel="bookmark" class="td-image-wrap " title="Jail Trust criticized by activists, approves contract and budget"><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-218x150.jpg" srcset="https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-218x150.jpg 218w, https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Oklahoma County Jail" title="Jail Trust criticized by activists, approves contract and budget" /></a></div> <a href="https://freepressokc.com/category/government/" class="td-post-category">Government</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://freepressokc.com/jail-trust-criticized-by-activists-approves-contract-and-budget/" rel="bookmark" title="Jail Trust criticized by activists, approves contract and budget">Jail Trust criticized by activists, approves contract and budget</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_2" data-td_block_id="tdi_2"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_2" data-td_block_id="tdi_2"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div></div> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside class="td_block_template_1 widget 60b995e127a1b"><div class="a-single a-4"><center><a class="gofollow" data-track="NCwwLDEsMTU=" href="https://trueskycu.org/747loan/" target="_blank" rel="nofollow"><img src="https://freepressokc.com/wp-content/banners/truesky-747-digital-ads-01.jpeg" width="300" height="250" /></a></center></div></aside> </div>
</div>
</div> 
</div> 
</article> 

<div class="tdc-footer-wrap ">

<div class="td-footer-wrapper td-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
</div>
<div class="td-footer-bottom-full">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://freepressokc.com/"><img src="https://freepressokc.com/wp-content/uploads/2016/11/FPLogo-Nov1-white-150x150.png" alt="Oklahoma City Free Press" title="Oklahoma City Free Press" /></a></aside></div><div class="td-pb-span9"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div><hr>
<p><strong>Sustain our journalism by becoming a supporter<br></strong></p>
<p>Oklahoma City Free Press is dedicated to providing high quality journalism that positively impacts our community. We give voice to those who aren’t heard and expose that which is hidden from the public. Click this <a href="https://pp-staging.presspatron.com/donations/new?frame=1&t=VuVQRxLy7UcJsBNvasA5tDAz">link</a> or the red button below to support our mission.</p>
<div class="pp-donate-button"> </div>
<hr>
Published by Oklahoma City Free Press LLC, Oklahoma City, Oklahoma -- Publisher and Editor - Brett Dickerson. All photography and content is under copyright. We adhere to the Society of Professional Journalists Code of Ethics.</aside></div> </div>
</div>
</div>
</div>

<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
</div>
<div class="td-pb-span td-sub-footer-copy">
&copy; Oklahoma City Free Press LLC, 2016, 2017, 2018, 2019, 2020, 2021. <a href="//www.dmca.com/Protection/Status.aspx?ID=64fb634b-962d-4e3b-93ec-bed7c5a4d8ec" title="DMCA.com Protection Status" class="dmca-badge"> <img src="//images.dmca.com/Badges/dmca-badge-w100-5x1-11.png?ID=64fb634b-962d-4e3b-93ec-bed7c5a4d8ec" alt="DMCA.com Protection Status"></a> <script src="//images.dmca.com/Badges/DMCABadgeHelper.min.js"> </script> </div>
</div>
</div>
</div>
</div>
</div>
<script type="text/javascript">
				var _paq = _paq || [];
					_paq.push(['setCustomDimension', 1, '{"ID":29,"name":"Marty Peercy","avatar":"9e9ca45327ac6d664a70536a3b1911f6"}']);
				_paq.push(['trackPageView']);
								(function () {
					var u = "https://stats1.wpmudev.com/";
					_paq.push(['setTrackerUrl', u + 'track/']);
					_paq.push(['setSiteId', '22896']);
					var d   = document, g = d.createElement('script'), s = d.getElementsByTagName('script')[0];
					g.type  = 'text/javascript';
					g.async = true;
					g.defer = true;
					g.src   = 'https://stats.wpmucdn.com/analytics.js';
					s.parentNode.insertBefore(g, s);
				})();
			</script>
<div class="td-more-articles-box">
<i class="td-icon-close td-close-more-articles-box"></i>
<span class="td-more-articles-box-title">MORE STORIES</span>
<div class="td-content-more-articles-box">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://freepressokc.com/loud-jail-trust-meeting-ice-motion-fails-court-video-upgrades-approved/" rel="bookmark" class="td-image-wrap " title="In loud Jail Trust meeting, ICE motion fails, court video upgrades approved"><img width="100" height="70" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2020/10/Jail-Trust-10-19-20-DSC00716-100x70.jpg" srcset="https://freepressokc.com/wp-content/uploads/2020/10/Jail-Trust-10-19-20-DSC00716-100x70.jpg 100w, https://freepressokc.com/wp-content/uploads/2020/10/Jail-Trust-10-19-20-DSC00716-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Jail Trust" title="In loud Jail Trust meeting, ICE motion fails, court video upgrades approved" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://freepressokc.com/loud-jail-trust-meeting-ice-motion-fails-court-video-upgrades-approved/" rel="bookmark" title="In loud Jail Trust meeting, ICE motion fails, court video upgrades approved">In loud Jail Trust meeting, ICE motion fails, court video upgrades...</a></h3> <div class="td-module-meta-info">
<a href="https://freepressokc.com/category/government/" class="td-post-category">Government</a> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-10-19T19:04:00-05:00">October 19, 2020</time></span> </div>
</div>
</div>
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://freepressokc.com/hes-not-a-killer-says-mother-of-teen-accomplice-in-robbery/" rel="bookmark" class="td-image-wrap " title="&#8220;He&#8217;s not a killer&#8221; says mother of teen accomplice in robbery"><img width="100" height="70" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2021/02/Amanda-Totsch-1-31-21-DSC05817-100x70.jpg" srcset="https://freepressokc.com/wp-content/uploads/2021/02/Amanda-Totsch-1-31-21-DSC05817-100x70.jpg 100w, https://freepressokc.com/wp-content/uploads/2021/02/Amanda-Totsch-1-31-21-DSC05817-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="not a killer" title="&#8220;He&#8217;s not a killer&#8221; says mother of teen accomplice in robbery" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://freepressokc.com/hes-not-a-killer-says-mother-of-teen-accomplice-in-robbery/" rel="bookmark" title="&#8220;He&#8217;s not a killer&#8221; says mother of teen accomplice in robbery">&#8220;He&#8217;s not a killer&#8221; says mother of teen accomplice in robbery</a></h3> <div class="td-module-meta-info">
<a href="https://freepressokc.com/category/crime/" class="td-post-category">Crime</a> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-02-01T07:59:56-06:00">February 1, 2021</time></span> </div>
</div>
</div>
</div>
</div>

<script type='text/javascript' id='adrotate-clicktracker-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/freepressokc.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js' id='adrotate-clicktracker-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/worth-the-read/js/wtr.js?ver=5.8.2' id='wtr-js-js'></script>
<script type='text/javascript' id='ppress-frontend-script-js-extra'>
/* <![CDATA[ */
var pp_ajax_form = {"ajaxurl":"https:\/\/freepressokc.com\/wp-admin\/admin-ajax.php","confirm_delete":"Are you sure?","deleting_text":"Deleting...","deleting_error":"An error occurred. Please try again.","nonce":"1ed6ca0028","disable_ajax_form":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/wp-user-avatar/assets/js/frontend.min.js?ver=3.2.4' id='ppress-frontend-script-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=2713a088559ff26084e8003394764364' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=11.3.2' id='td-site-min-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/comment-reply.min.js?ver=5.8.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=2713a088559ff26084e8003394764364' id='tdb_js_files_for_front-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/wp-embed.min.js?ver=5.8.2' id='wp-embed-js'></script>

<script>
    
</script>
</body>
</html>