<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>Commissioners hire lawyers - hear from angry public about OK County Jail</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://freepressokc.com/xmlrpc.php" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<meta property="fb:app_id" content="1249330068491776" />

<link rel="icon" type="image/png" href="https://freepressokc.com/wp-content/uploads/2016/09/cropped-FPlogo-single-png.png">

<meta name="description" content="The Oklahoma County Board of County Commissioners held special meetings, mainly to address pending litigation." />
<link rel="canonical" href="https://freepressokc.com/commissioners-hire-lawyers-hear-from-angry-public-about-ok-county-jail/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Commissioners hire lawyers - hear from angry public about OK County Jail" />
<meta property="og:description" content="The Oklahoma County Board of County Commissioners held special meetings, mainly to address pending litigation." />
<meta property="og:url" content="https://freepressokc.com/commissioners-hire-lawyers-hear-from-angry-public-about-ok-county-jail/" />
<meta property="og:site_name" content="Oklahoma City Free Press" />
<meta property="article:publisher" content="https://www.facebook.com/oklahomacityfreepress/" />
<meta property="article:published_time" content="2022-02-11T00:40:10+00:00" />
<meta property="article:modified_time" content="2022-02-11T00:40:11+00:00" />
<meta property="og:image" content="https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="720" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@OKC_SPAN" />
<meta name="twitter:site" content="@freepressokc" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Marty Peercy" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="7 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">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</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Oklahoma City Free Press &raquo; Feed" href="https://freepressokc.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Oklahoma City Free Press &raquo; Comments Feed" href="https://freepressokc.com/comments/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/freepressokc.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://freepressokc.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='wtr-css-css' href='https://freepressokc.com/wp-content/plugins/worth-the-read/css/wtr.css?ver=5.9' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-frontend-css' href='https://freepressokc.com/wp-content/plugins/wp-user-avatar/assets/css/frontend.min.css?ver=3.2.7' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-flatpickr-css' href='https://freepressokc.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.css?ver=3.2.7' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-select2-css' href='https://freepressokc.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.css?ver=5.9' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://freepressokc.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=23f7cf05c1213c4bc7a6753a64c58bf1' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Roboto+Slab%3A400%7CLato%3A400%7CRoboto%3A400%2C500%2C700%7COpen+Sans%3A400%2C600%2C700&#038;display=swap&#038;ver=11.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://freepressokc.com/wp-content/themes/childnewspaper7/style.css?ver=1.0' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='td-legacy-framework-front-style-css' href='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=23f7cf05c1213c4bc7a6753a64c58bf1' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css' href='https://freepressokc.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=4168705b165f7662fff7e5fdf2db6ef8' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css' href='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/includes/demos/politics/demo_style.css?ver=11.4.1' type='text/css' media='all' />
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.js?ver=5.9' id='ppress-flatpickr-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.js?ver=5.9' id='ppress-select2-js'></script>
<link rel="https://api.w.org/" href="https://freepressokc.com/wp-json/" /><link rel="alternate" type="application/json" href="https://freepressokc.com/wp-json/wp/v2/posts/17474" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://freepressokc.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://freepressokc.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.9" />
<link rel='shortlink' href='https://freepressokc.com/?p=17474' />
<link rel="alternate" type="application/json+oembed" href="https://freepressokc.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffreepressokc.com%2Fcommissioners-hire-lawyers-hear-from-angry-public-about-ok-county-jail%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://freepressokc.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffreepressokc.com%2Fcommissioners-hire-lawyers-hear-from-angry-public-about-ok-county-jail%2F&#038;format=xml" />


<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-3 { margin:0px 0px 0px 0px; width:100%; max-width:1280px; height:100%; max-height:182px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>

<style type="text/css">.wtr-time-wrap{ 
	/* wraps the entire label */
	margin: 0 10px;

}
.wtr-time-number{ 
	/* applies only to the number */
	
}</style><style id="wplmi-inline-css" type="text/css"> span.wplmi-user-avatar { width: 16px;display: inline-block !important;flex-shrink: 0; } img.wplmi-elementor-avatar { border-radius: 100%;margin-right: 3px; } 

</style>
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script>
        window.tdb_globals = {"wpRestNonce":"912cec95df","wpRestUrl":"https:\/\/freepressokc.com\/wp-json\/","permalinkStructure":"\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
<style id="tdb-global-colors">
        :root {--accent-color: #fff;}
    </style>
<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/freepressokc.com\/wp-admin\/","wpRestNonce":"912cec95df","wpRestUrl":"https:\/\/freepressokc.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>
<script>
        window.tdaGlobal = {"adminUrl":"https:\/\/freepressokc.com\/wp-admin\/","wpRestNonce":"912cec95df","wpRestUrl":"https:\/\/freepressokc.com\/wp-json\/","permalinkStructure":"\/%postname%\/","postId":17474};
    </script>

<script>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</script>

<style>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</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-89779313-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-89779313-1');
</script>
<script>
(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
el = d.createElement('script');
el.id = "js-pp-banner";
el.src = "//dashboard.presspatron.com/dev/banner?b=pMamyM1ZSttVyfgPpMYw2zgS";
fjs.parentNode.insertBefore(el, fjs);
}(document));
</script>
<div id="pp-banner"></div>
<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://freepressokc.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://freepressokc.com/category/government/",
                    "name": "Government"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://freepressokc.com/commissioners-hire-lawyers-hear-from-angry-public-about-ok-county-jail/",
                    "name": "Commissioners hire lawyers &#8211; hear from angry public about OK County Jail"                                
                }
            }    
        ]
    }
</script>
<link rel="icon" href="https://freepressokc.com/wp-content/uploads/2021/05/cropped-FPLogo-Nov1-black-32x32.png" sizes="32x32" />
<link rel="icon" href="https://freepressokc.com/wp-content/uploads/2021/05/cropped-FPLogo-Nov1-black-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://freepressokc.com/wp-content/uploads/2021/05/cropped-FPLogo-Nov1-black-180x180.png" />
<meta name="msapplication-TileImage" content="https://freepressokc.com/wp-content/uploads/2021/05/cropped-FPLogo-Nov1-black-270x270.png" />
<link rel="alternate" type="application/rss+xml" title="RSS" href="https://freepressokc.com/rsslatest.xml" /><style type="text/css" title="dynamic-css" class="options-output">.wtr-time-wrap{text-align:left;line-height:20px;font-weight:400;font-style:italic;color:#079603;font-size:14px;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading .wtr-time-wrap{opacity: 0;}.ie.wf-loading .wtr-time-wrap{visibility: hidden;}</style>

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                body .tdm-social-item i {
                    color: #dd3333;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #dd3333;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #dd3333;
                }
                .tdm-btn-style1 {
					background-color: #dd3333;
				}
				.tdm-btn-style2:before {
				    border-color: #dd3333;
				}
				.tdm-btn-style2 {
				    color: #dd3333;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #dd3333;
                    -moz-box-shadow: 0 2px 16px #dd3333;
                    box-shadow: 0 2px 16px #dd3333;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #dd3333;
                    -moz-box-shadow: 0 4px 26px #dd3333;
                    box-shadow: 0 4px 26px #dd3333;
				}
</style>
<style id="tdw-css-placeholder"></style></head>
<body class="post-template-default single single-post postid-17474 single-format-standard td-standard-pack commissioners-hire-lawyers-hear-from-angry-public-about-ok-county-jail global-block-template-1 td-politics single_template_3 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up  td-hide-scroll-up-on-mob" style="display:none;"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/oklahomacityfreepress/" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/freepressokc" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="/cdn-cgi/l/email-protection#2940474f46694f5b4c4c595b4c5a5a46424a074a4644" title="Mail">
<i class="td-icon-font td-icon-mail-1"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.reddit.com/user/OKC_Free_Press/" title="Reddit">
<i class="td-icon-font td-icon-reddit"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://freepressokc.com/feed/" title="RSS">
<i class="td-icon-font td-icon-rss"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/freepressokc" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/channel/UCKnwaGON2-YbuX9-smgCafw" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span> </div>

<div class="td-mobile-close">
<a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-8600" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-8600"><a href="https://freepressokc.com/category/health-and-covid-19/">Health and COVID-19</a></li>
<li id="menu-item-10452" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-10452"><a href="https://freepressokc.com/category/seen-heard/">Seen and Heard<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-46" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46"><a href="https://freepressokc.com/category/cultures/">Cultures</a></li>
<li id="menu-item-16178" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16178"><a href="https://freepressokc.com/category/seen-heard/fire-activity/">OKC Fire Department</a></li>
<li id="menu-item-45" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45"><a href="https://freepressokc.com/category/crime/">Crime</a></li>
<li id="menu-item-7689" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7689"><a href="https://freepressokc.com/category/neighborhood-news/">Neighborhood news</a></li>
</ul>
</li>
<li id="menu-item-231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-231"><a href="https://freepressokc.com/category/politics/">Politics<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-10122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10122"><a href="https://freepressokc.com/category/politics/protests/">Protests</a></li>
</ul>
</li>
<li id="menu-item-48" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-48"><a href="https://freepressokc.com/category/government/">Government</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47"><a href="https://freepressokc.com/category/education/">Education</a></li>
<li id="menu-item-4328" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-4328"><a href="https://freepressokc.com/category/the-arts/">The Arts<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-416" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-416"><a href="https://freepressokc.com/category/the-arts/cinema/">Cinema<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-9394" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9394"><a href="https://freepressokc.com/category/the-arts/cinema/deadcenter/">deadCenter Film Festival</a></li>
</ul>
</li>
<li id="menu-item-8423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8423"><a href="https://freepressokc.com/category/music/">Music</a></li>
<li id="menu-item-16680" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16680"><a href="https://freepressokc.com/category/the-arts/music-and-film-column/">Music and Film column</a></li>
</ul>
</li>
<li id="menu-item-1033" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1033"><a href="https://freepressokc.com/category/business/">Business</a></li>
<li id="menu-item-13878" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13878"><a href="https://freepressokc.com/category/real-estate/">Real Estate</a></li>
<li id="menu-item-50" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50"><a href="https://freepressokc.com/category/technology/">Science and Technology</a></li>
<li id="menu-item-7892" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-7892"><a href="https://freepressokc.com/category/opinion/">Opinion &#8211; Community voices<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-10451" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10451"><a href="https://freepressokc.com/category/opinion/open-letters/">Open Letters</a></li>
<li id="menu-item-7647" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7647"><a href="https://freepressokc.com/category/first-person/">First Person</a></li>
<li id="menu-item-14905" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14905"><a href="https://freepressokc.com/category/opinion/paula-sophia-manhood/">First Person &#8211; Paula Sophia &#8211; Manhood, from the inside out</a></li>
<li id="menu-item-10449" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10449"><a href="https://freepressokc.com/category/opinion/editor-notes/">Editor&#8217;s Notes</a></li>
</ul>
</li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search">
<form method="get" class="td-search-form" action="https://freepressokc.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="tdc-header-wrap ">

<div class="td-header-wrap td-header-style-10 ">
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="td_data_time">
<div>
Thursday, February 10, 2022
</div>
</div>
<div class="menu-top-container"><ul id="menu-about-mission-and-goals-ad-pol" class="top-header-menu"><li id="menu-item-5465" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-5465"><a href="https://freepressokc.com/about/">About</a></li>
<li id="menu-item-5466" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-5466"><a href="https://freepressokc.com/mission-goals/">Mission and Goals</a></li>
<li id="menu-item-8933" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-8933"><a href="https://freepressokc.com/political-advertising-policy/">Political Advertising Policy</a></li>
<li id="menu-item-15468" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-15468"><a href="https://freepressokc.com/corrections-policy/">Corrections Policy</a></li>
<li id="menu-item-16502" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-16502"><a href="https://freepressokc.com/eventscalendar/">Events Calendar</a></li>
</ul></div></div>
<div class="td-header-sp-top-widget">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://freepressokc.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/oklahomacityfreepress/" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/freepressokc" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="/cdn-cgi/l/email-protection#d9b0b7bfb699bfabbcbca9abbcaaaab6b2baf7bab6b4" title="Mail">
<i class="td-icon-font td-icon-mail-1"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.reddit.com/user/OKC_Free_Press/" title="Reddit">
<i class="td-icon-font td-icon-reddit"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://freepressokc.com/feed/" title="RSS">
<i class="td-icon-font td-icon-rss"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/freepressokc" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/channel/UCKnwaGON2-YbuX9-smgCafw" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span> </div> </div>

<div id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
<div class="td-login-wrap">
<a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-modal-back"></i></a>
<div id="td-login-div" class="td-login-form-div td-display-block">
<div class="td-login-panel-title">Sign in</div>
<div class="td-login-panel-descr">Welcome! Log into your account</div>
<div class="td_display_err"></div>
<form id="loginForm" action="#" method="post">
<div class="td-login-inputs"><input class="td-login-input" autocomplete="username" type="text" name="login_email" id="login_email" value="" required><label for="login_email">your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" autocomplete="current-password" type="password" name="login_pass" id="login_pass" value="" required><label for="login_pass">your password</label></div>
<input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
</form>
<div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
 <div class="td-login-info-text"><a class="privacy-policy-link" href="https://freepressokc.com/privacy-statement/">Privacy Statement</a></div>
</div>
<div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
<div class="td-login-panel-title">Password recovery</div>
<div class="td-login-panel-descr">Recover your password</div>
<div class="td_display_err"></div>
<form id="forgotpassForm" action="#" method="post">
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label for="forgot_email">your email</label></div>
<input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
</form>
<div class="td-login-info-text">A password will be e-mailed to you.</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-banner-wrap-full td-logo-wrap-full  td-container-wrap ">
<div class="td-header-sp-logo">
<div class="td-logo-text-wrap">
<span class="td-logo-text-container">
<a class="td-logo-wrap" href="https://freepressokc.com/">
<span class="td-logo-text">Oklahoma City Free Press</span>
<span class="td-tagline-text">Oklahoma City's award-winning independent news</span>
</a>
</span>
</div>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap td-header-gradient td-header-menu-no-search">
<div class="td-container td-header-row td-header-main-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
</div>
<div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-8600"><a href="https://freepressokc.com/category/health-and-covid-19/">Health and COVID-19</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-10452"><a href="https://freepressokc.com/category/seen-heard/">Seen and Heard</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-46"><a href="https://freepressokc.com/category/cultures/">Cultures</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-16178"><a href="https://freepressokc.com/category/seen-heard/fire-activity/">OKC Fire Department</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-45"><a href="https://freepressokc.com/category/crime/">Crime</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7689"><a href="https://freepressokc.com/category/neighborhood-news/">Neighborhood news</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-231"><a href="https://freepressokc.com/category/politics/">Politics</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10122"><a href="https://freepressokc.com/category/politics/protests/">Protests</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-48"><a href="https://freepressokc.com/category/government/">Government</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-47"><a href="https://freepressokc.com/category/education/">Education</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-4328"><a href="https://freepressokc.com/category/the-arts/">The Arts</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-416"><a href="https://freepressokc.com/category/the-arts/cinema/">Cinema</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-9394"><a href="https://freepressokc.com/category/the-arts/cinema/deadcenter/">deadCenter Film Festival</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-8423"><a href="https://freepressokc.com/category/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-16680"><a href="https://freepressokc.com/category/the-arts/music-and-film-column/">Music and Film column</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1033"><a href="https://freepressokc.com/category/business/">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-13878"><a href="https://freepressokc.com/category/real-estate/">Real Estate</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-50"><a href="https://freepressokc.com/category/technology/">Science and Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-7892"><a href="https://freepressokc.com/category/opinion/">Opinion &#8211; Community voices</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10451"><a href="https://freepressokc.com/category/opinion/open-letters/">Open Letters</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7647"><a href="https://freepressokc.com/category/first-person/">First Person</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14905"><a href="https://freepressokc.com/category/opinion/paula-sophia-manhood/">First Person &#8211; Paula Sophia &#8211; Manhood, from the inside out</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10449"><a href="https://freepressokc.com/category/opinion/editor-notes/">Editor&#8217;s Notes</a></li>
</ul>
</li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<article id="post-17474" class="td-post-template-3 post-17474 post type-post status-publish format-standard has-post-thumbnail category-government tag-jail tag-oklahoma-county-commissioners tag-oklahoma-county-jail td-container-wrap" itemscope itemtype="https://schema.org/Article">
<div class="td-post-header td-container">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://freepressokc.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Government" class="entry-crumb" href="https://freepressokc.com/category/government/">Government</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Commissioners hire lawyers &#8211; hear from angry public about OK County Jail</span></div></div>
<div class="td-post-header-holder td-image-gradient">
<div class="td-post-featured-image"><figure><a href="https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage.jpg" data-caption="Oklahoma County Jail during the hostage crisis March 27, 2021. (BRETT DICKERSON/Okla City Free Press)"><img width="1068" height="601" class="entry-thumb td-modal-image" src="https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-1068x601.jpg" srcset="https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-1068x601.jpg 1068w, https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-300x169.jpg 300w, https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-1024x576.jpg 1024w, https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-768x432.jpg 768w, https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-696x392.jpg 696w, https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-747x420.jpg 747w, https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage.jpg 1280w" sizes="(max-width: 1068px) 100vw, 1068px" alt="Oklahoma County Jail" title="OK County Jail - hostage" /></a><figcaption class="wp-caption-text">Oklahoma County Jail during the hostage crisis March 27, 2021. (BRETT DICKERSON/Okla City Free Press)</figcaption></figure></div>
<header class="td-post-title">
<ul class="td-category"><li class="entry-category"><a href="https://freepressokc.com/category/government/">Government</a></li></ul> <h1 class="entry-title">Commissioners hire lawyers &#8211; hear from angry public about OK County Jail</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://freepressokc.com/author/martypeercy/">Marty Peercy</a><div class="td-author-line"> - </div> </div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-02-10T18:40:10-06:00">February 10, 2022</time></span> </div>
</header>
</div>
</div>
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 ">
<style>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</style>
<div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
<div class="td-social-but-icon"><i class="td-icon-share"></i></div>
<div class="td-social-but-text">Share</div>
</div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffreepressokc.com%2Fcommissioners-hire-lawyers-hear-from-angry-public-about-ok-county-jail%2F" title="Facebook">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Commissioners+hire+lawyers+%E2%80%93+hear+from+angry+public+about+OK+County+Jail&url=https%3A%2F%2Ffreepressokc.com%2Fcommissioners-hire-lawyers-hear-from-angry-public-about-ok-county-jail%2F&via=freepressokc" title="Twitter">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://freepressokc.com/commissioners-hire-lawyers-hear-from-angry-public-about-ok-county-jail/&title=Commissioners+hire+lawyers+%E2%80%93+hear+from+angry+public+about+OK+County+Jail" title="ReddIt">
<div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
<div class="td-social-but-text">ReddIt</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#69561a1c0b030c0a1d542a060404001a1a0006070c1b1a4901001b0c4905081e100c1b1a494f4a515b58585249010c081b490f1b06044908070e1b1049191c0b05000a49080b061c1d492622492a061c071d1049230800054f0b060d1054011d1d191a5346460f1b0c0c191b0c1a1a06020a470a0604460a060404001a1a0006070c1b1a4401001b0c4405081e100c1b1a44010c081b440f1b06044408070e1b1044191c0b05000a44080b061c1d440602440a061c071d10440308000546" title="Email">
<div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
<div class="td-social-but-text">Email</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print">
<div class="td-social-but-icon"><i class="td-icon-print"></i></div>
<div class="td-social-but-text">Print</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top" title="More">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>
<div class="td-post-content tagdiv-type">
<div class="g g-1"><div class="g-single a-13"><center><a class="gofollow" data-track="MTMsMSwxLDE1" href="https://www.okcmoa.com/visit/events/chihulymagicandlight/" target="_blank" rel="nofollow"><img src="https://freepressokc.com/wp-content/banners/chihuly-mod-ad-1024x145.jpeg" width="1024" height="145" /></a></center></div></div><span class="wtr-time-wrap before-content"><span class="wtr-time-number">8</span> minute read</span><div id="wtr-content" data-bg="#FFFFFF" data-fg="#f44813" data-width="5" data-mute="" data-fgopacity="0.5" data-mutedopacity="0.5" data-placement="left" data-placement-offset="0" data-content-offset="0" data-placement-touch="left" data-placement-offset-touch="0" data-transparent="" data-shadow="1" data-touch="1" data-non-touch="1" data-comments="0" data-commentsbg="#ffcece" data-location="page" data-mutedfg="#f44813" data-endfg="#f44813" data-rtl="">
<p>OKLAHOMA CITY (<a href="https://freepressokc.com">Free Press</a>) &#8212; Over the course of two days this week, the Oklahoma County Board of County Commissioners held special meetings, mainly to address pending litigation.</p>
<p>At both meetings, the Board had to listen to the concerns of several Oklahoma County residents who were incensed by a damaging recording of Jail CEO Greg Williams that surfaced this week.&nbsp;</p>
<p>While neither meeting had any direct focus on the Jail, members of the public who spoke would hold the BoCC responsible for the actions of the Oklahoma County Criminal Justice Authority (Jail Trust), which the Board created.</p>
<div class="wp-block-media-text alignwide is-stacked-on-mobile"><figure class="wp-block-media-text__media"><img width="1024" height="576" src="https://freepressokc.com/wp-content/uploads/2021/05/Marty-Peercy-2020-DSC07876-1024x576.jpeg" alt="" class="wp-image-13831 size-full" srcset="https://freepressokc.com/wp-content/uploads/2021/05/Marty-Peercy-2020-DSC07876-1024x576.jpeg 1024w, https://freepressokc.com/wp-content/uploads/2021/05/Marty-Peercy-2020-DSC07876-300x169.jpeg 300w, https://freepressokc.com/wp-content/uploads/2021/05/Marty-Peercy-2020-DSC07876-768x432.jpeg 768w, https://freepressokc.com/wp-content/uploads/2021/05/Marty-Peercy-2020-DSC07876-696x392.jpeg 696w, https://freepressokc.com/wp-content/uploads/2021/05/Marty-Peercy-2020-DSC07876-1068x601.jpeg 1068w, https://freepressokc.com/wp-content/uploads/2021/05/Marty-Peercy-2020-DSC07876-747x420.jpeg 747w, https://freepressokc.com/wp-content/uploads/2021/05/Marty-Peercy-2020-DSC07876.jpeg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure><div class="wp-block-media-text__content">
<blockquote class="wp-block-quote"><p>Marty Peercy reports Local government</p></blockquote>
</div></div>
<p></p>
<h2 id="wrongful-death"><strong>Wrongful Death</strong></h2>
<p>Two items of business over the course of the two days involved spending County money for legal defense in two separate lawsuits.</p>
<p>On Wednesday, Assistant District Attorney Aaron Etherington brought to the Board a request to authorize the DA’s office to hire expert testimony in a case styled Spray v. BoCC.</p>
<p>The lawsuit, brought by family members of a person who died in custody of the Oklahoma County Detention Center (Jail). The Spray family alleges that their family member was booked into the Jail on December 13, 2018 with symptoms that should have triggered medical care. However, they claim their loved one was placed in a cell, where she was found dead on December 16. The autopsy revealed the cause of death was a perforated duodenal ulcer.</p>
<p>The DA’s office requested that $30,000 be allocated from the County’s Self-Insurance Fund to pay for “case consulting, analysis and testimony” from OSS Law Enforcement Advisors, a Texas-based company that offers training and consulting services to law enforcement agencies.</p>
<p>The Commissioners unanimously approved the allocation.</p>
<h2 id="baby-shark"><strong>Baby Shark</strong></h2>
<p>In another effort to defend the County against litigation, the BoCC had to choose a private law firm to represent them in a case styled Foreman et al. v. Oklahoma County Sheriff et al.</p>
<p>The suit was filed on behalf of four people who allege they were tortured in December and November 2019 by detention officers at the Jail while in custody.</p>
<p>The plaintiffs claim that two detention officers, Christian Charles Miles and Gregory Cornell Butler, Jr., effectively tortured the four plaintiffs while they were detained.</p>
<p>The petition in the case lists various forms of torture beyond physical violence, and including, as has been widely publicized, playing the children’s song “Baby Shark” on a continuous loop for a protracted amount of time. That action, allegedly, happened while a detainee was handcuffed behind his back, then secured while standing to a bar behind him. This position is described as a “standing stress position” used in “enhanced interrogation.”</p>
<p>The alleged events occurred in 2019, when the Jail was in the control of the Oklahoma County Sheriff’s Office, under the leadership of Sheriff P.D. Taylor. However, the lawsuit names the County, and the Criminal Justice Authority (aka Jail Trust) in addition to the Sheriff’s Office and the individual detention officers.</p>
<div class="wp-block-image"><figure class="aligncenter size-large"><img loading="lazy" width="1024" height="576" src="https://freepressokc.com/wp-content/uploads/2019/10/Taylor-Thumbnail-1-1024x576.jpg" alt="Sheriff P.D. Taylor" class="wp-image-7107" srcset="https://freepressokc.com/wp-content/uploads/2019/10/Taylor-Thumbnail-1-1024x576.jpg 1024w, https://freepressokc.com/wp-content/uploads/2019/10/Taylor-Thumbnail-1-300x169.jpg 300w, https://freepressokc.com/wp-content/uploads/2019/10/Taylor-Thumbnail-1-768x432.jpg 768w, https://freepressokc.com/wp-content/uploads/2019/10/Taylor-Thumbnail-1-696x392.jpg 696w, https://freepressokc.com/wp-content/uploads/2019/10/Taylor-Thumbnail-1-1068x601.jpg 1068w, https://freepressokc.com/wp-content/uploads/2019/10/Taylor-Thumbnail-1-747x420.jpg 747w, https://freepressokc.com/wp-content/uploads/2019/10/Taylor-Thumbnail-1.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption>Sheriff P.D. Taylor answers questions at a news conference Oct. 24, 2019 at the Oklahoma County Jail. (Brett Dickerson/Okla City Free Press)</figcaption></figure></div>
<p>Three firms were listed on the BoCC’s agenda. Fellers Snider Attorneys at Law, Pierce Couch Hendrickson, Baysinger &amp; Green LLP, and Riggs Abney Law Firm were each asked for a bid for defense services for the BoCC.</p>
<p>Attorneys from Riggs Abney are currently involved in different litigation against the County, and are therefore unable to represent the County in this case due to that conflict of interest.</p>
<p>Fellers Snider offered a quote of $60,000, whereas Pierce Couch etc. offered a bid of $50,000.</p>
<p>As Pierce Couch and company have already represented the BoCC in the past, the Board unanimously selected that firm for this contract.</p>
<h2 id="public-comment"><strong>Public Comment</strong></h2>
<p>A story was published Tuesday by NonDoc Media that included a four-minute audio clip of Jail CEO Greg Williams speaking with coworker Mark Opgrande about COVID. During that conversation, the two discussed COVID protocols being a convenient way to keep the press out of the Jail facility.</p>
<p>The two went on to say, shocking many, that COVID has been their “best friend” in many ways. In addition to keeping the press at bay, they bragged about the amount of money that has come to the Jail due to COVID.</p>
<div class="wp-block-image"><figure class="aligncenter size-large"><img loading="lazy" width="1024" height="577" src="https://freepressokc.com/wp-content/uploads/2022/02/Protests-agains-Williams-2-20-22-P2080341-1024x577.jpg" alt="protesters" class="wp-image-17465" srcset="https://freepressokc.com/wp-content/uploads/2022/02/Protests-agains-Williams-2-20-22-P2080341-1024x577.jpg 1024w, https://freepressokc.com/wp-content/uploads/2022/02/Protests-agains-Williams-2-20-22-P2080341-300x169.jpg 300w, https://freepressokc.com/wp-content/uploads/2022/02/Protests-agains-Williams-2-20-22-P2080341-768x433.jpg 768w, https://freepressokc.com/wp-content/uploads/2022/02/Protests-agains-Williams-2-20-22-P2080341-696x392.jpg 696w, https://freepressokc.com/wp-content/uploads/2022/02/Protests-agains-Williams-2-20-22-P2080341-1068x602.jpg 1068w, https://freepressokc.com/wp-content/uploads/2022/02/Protests-agains-Williams-2-20-22-P2080341-746x420.jpg 746w, https://freepressokc.com/wp-content/uploads/2022/02/Protests-agains-Williams-2-20-22-P2080341-scaled.jpg 1278w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption>A group of protesters held a news conference before the Oklahoma County Commissioners meeting Tuesday, Feb. 8, 2022 to criticize Jail administrator Greg Williams and called for his resignation or firing. (BRETT DICKERSON/Okla City Free Press)</figcaption></figure></div>
<p>At both BoCC meetings, angry members of the public came to address the Commissioners.</p>
<p>Sean Cummings, a local restaurant owner and The Village City Council candidate, attended both meetings of the Board.</p>
<p>In the first meeting on Wednesday, Cummings spoke before the Board and addressed most of his comments to District 1 Commissioner Carrie Blumert, who now represents the Village after recent redistricting.</p>
<p>Cummings said that since she was now his representative, even though he never got to vote for that, she was responsible to listen to constituents. Cummings demanded of Blumert that she call for Williams’s firing or resignation, and that she attempt to dissolve the Jail Trust.</p>
<p>He also asked if any of the Commissioners had even issued a statement about the fiasco. At that time, only Blumert had done so.</p>
<div class="wp-block-image"><figure class="aligncenter size-large"><img loading="lazy" width="1024" height="575" src="https://freepressokc.com/wp-content/uploads/2022/02/Cummings-Blumert-2-9-22-P2080417-1024x575.jpg" alt="Sean Cummings" class="wp-image-17464" srcset="https://freepressokc.com/wp-content/uploads/2022/02/Cummings-Blumert-2-9-22-P2080417-1024x575.jpg 1024w, https://freepressokc.com/wp-content/uploads/2022/02/Cummings-Blumert-2-9-22-P2080417-300x169.jpg 300w, https://freepressokc.com/wp-content/uploads/2022/02/Cummings-Blumert-2-9-22-P2080417-768x432.jpg 768w, https://freepressokc.com/wp-content/uploads/2022/02/Cummings-Blumert-2-9-22-P2080417-696x391.jpg 696w, https://freepressokc.com/wp-content/uploads/2022/02/Cummings-Blumert-2-9-22-P2080417-1068x600.jpg 1068w, https://freepressokc.com/wp-content/uploads/2022/02/Cummings-Blumert-2-9-22-P2080417-747x420.jpg 747w, https://freepressokc.com/wp-content/uploads/2022/02/Cummings-Blumert-2-9-22-P2080417-scaled.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption>Sean Cummings addresses Commissioner Carrie Blumert at the Tuesday meeting of the Board of County Commissioners, Feb. 8, 2022. (BRETT DICKERSON/Okla City Free Press)</figcaption></figure></div>
<p>At Thursday’s meeting Blumert was not in attendance, but again Cummings addressed her through her Chief Deputy Joe Blough, who sat in as Blumert’s proxy.</p>
<p>Blumert’s statement was insufficient, said Cummings. He called on all three Commissioners to do the right thing, but lamented that they wouldn’t because they consistently refuse to do the right thing.</p>
<p>Cummings referred to Blumert as a “doormat” that is constantly shut out by the “two abusive men” she shares the horseshoe with. He went on to call District 3 Commissioner Kevin Calvey a “political cockroach.”</p>
<p>“Humiliation doesn’t bother any of you!” Cummings concluded.</p>
<p>Local activist Mark Faulk was also in attendance and addressed the Board at both meetings.</p>
<p>Faulk underscored the horror of mass deaths around the world due to the deadly COVID pandemic that has plagued most of the planet since the end of 2019.</p>
<p>Throughout the comments from Faulk, Cummings, Councilperson-elect Sara Bana of Del City, and Cherisse Baker, Calvey showed his disdain for the activists by never acknowledging them. Calvey shifted in his chair to be mostly in profile to the speakers and spent the time looking down at what appeared to be his cellular phone.</p>
<p>Faulk asked Calvey to put his phone down and listen to the public for once. When Calvey didn’t respond, Faulk called him a “corrupt piece of shit,” getting no reaction from the Commissioner.</p>
<p>Faulk passionately talked about the suffering of the people in the Jail, and that any person who could joke about death from COVID in such a way was in no position to oversee the health and safety of people detained in the Jail.</p>
<h2 id="calvey-statement"><strong>Calvey Statement</strong></h2>
<p>At Thursday’s meeting, Calvey addressed the controversy during the part of the agenda set aside for “Commissioner Comments/General Remarks.”</p>
<div class="wp-block-image"><figure class="alignleft size-large is-resized"><img loading="lazy" src="https://freepressokc.com/wp-content/uploads/2021/11/Kevin-Calvey-PB140552-1024x1024.jpg" alt="Kevin Calvey" class="wp-image-16196" width="181" height="181" srcset="https://freepressokc.com/wp-content/uploads/2021/11/Kevin-Calvey-PB140552-1024x1024.jpg 1024w, https://freepressokc.com/wp-content/uploads/2021/11/Kevin-Calvey-PB140552-300x300.jpg 300w, https://freepressokc.com/wp-content/uploads/2021/11/Kevin-Calvey-PB140552-150x150.jpg 150w, https://freepressokc.com/wp-content/uploads/2021/11/Kevin-Calvey-PB140552-768x768.jpg 768w, https://freepressokc.com/wp-content/uploads/2021/11/Kevin-Calvey-PB140552-696x696.jpg 696w, https://freepressokc.com/wp-content/uploads/2021/11/Kevin-Calvey-PB140552-1068x1068.jpg 1068w, https://freepressokc.com/wp-content/uploads/2021/11/Kevin-Calvey-PB140552-420x420.jpg 420w, https://freepressokc.com/wp-content/uploads/2021/11/Kevin-Calvey-PB140552-scaled.jpg 720w" sizes="(max-width: 181px) 100vw, 181px" /><figcaption>Kevin Calvey, Oklahoma County Commissioner, Dist. 3. (BRETT DICKERSON/Okla City Free Press)</figcaption></figure></div>
<p>Calvey began in a folksy tone, and brought up the Paul Harvey radio program. He referenced Harvey’s oft-quoted catchphrase, “and that’s the rest of the story.”</p>
<p>He went on to say that the controversy over Williams’s comments lacked context. He said the “rest of the story” is that Williams’s own mother died of COVID. Williams was only able to say goodbye to his mother by holding up a sign at the window of his mother’s hospital room, according to Calvey.</p>
<p>Calvey then called the comments from Williams and Opgrande “innocuous,” and praised what he sees as the great work of Greg Williams as CEO of the Jail.</p>
<p>The Board of County Commissioners’ next scheduled meeting is on February 22 at 9:00 a.m. That meeting will be a rare Tuesday morning meeting in deference to the Federal holiday on February 21.</p>
<hr class="wp-block-separator" />
<p class="post-modified-info">Last Updated February 10, 2022, 6:40 PM by <a href="" target="_blank" class="last-modified-author">Brett Dickerson &#8211; Editor</a></p></div> </div>
<footer>
<div class="td-post-source-tags">
<ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://freepressokc.com/tag/jail/">jail</a></li><li><a href="https://freepressokc.com/tag/oklahoma-county-commissioners/">Oklahoma County Commissioners</a></li><li><a href="https://freepressokc.com/tag/oklahoma-county-jail/">Oklahoma County Jail</a></li></ul> </div>
<div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
<div class="td-social-but-icon"><i class="td-icon-share"></i></div>
<div class="td-social-but-text">Share</div>
</div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffreepressokc.com%2Fcommissioners-hire-lawyers-hear-from-angry-public-about-ok-county-jail%2F" title="Facebook">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Commissioners+hire+lawyers+%E2%80%93+hear+from+angry+public+about+OK+County+Jail&url=https%3A%2F%2Ffreepressokc.com%2Fcommissioners-hire-lawyers-hear-from-angry-public-about-ok-county-jail%2F&via=freepressokc" title="Twitter">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://freepressokc.com/commissioners-hire-lawyers-hear-from-angry-public-about-ok-county-jail/&title=Commissioners+hire+lawyers+%E2%80%93+hear+from+angry+public+about+OK+County+Jail" title="ReddIt">
<div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
<div class="td-social-but-text">ReddIt</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#57682422353d3234236a14383a3a3e24243e3839322524773f3e2532773b36202e3225247771746f6566666c773f323625773125383a77363930252e772722353b3e3477363538222377181c7714382239232e771d363e3b713538332e6a3f232327246d7878312532322725322424383c347934383a7834383a3a3e24243e38393225247a3f3e25327a3b36202e3225247a3f3236257a3125383a7a363930252e7a2722353b3e347a36353822237a383c7a34382239232e7a3d363e3b78" title="Email">
<div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
<div class="td-social-but-text">Email</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print">
<div class="td-social-but-icon"><i class="td-icon-print"></i></div>
<div class="td-social-but-text">Print</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom" title="More">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div> <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://freepressokc.com/five-alarm-fire-consumes-unfinished-northside-luxury-apartment-complex/">Five-alarm fire consumes unfinished northside luxury apartment complex</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://freepressokc.com/fires-still-burn-inside-massive-northside-apartment-complex-on-third-day/">Fires still burn inside massive northside apartment complex on third day</a></div></div></div> <div class="author-box-wrap"><a href="https://freepressokc.com/author/martypeercy/" aria-label="author-photo"><img data-del="avatar" src='https://freepressokc.com/wp-content/uploads/2020/01/Marty-avatar-150x150.jpg' class='avatar pp-user-avatar avatar-96 photo ' height='96' width='96' /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://freepressokc.com/author/martypeercy/">Marty Peercy</a></span></div><div class="td-author-description">Columnist covering local government in Oklahoma City and Oklahoma County. Editor's note: Marty Peercy is the spouse of Oklahoma City Council member JoBeth Hamon. He has a Twitter account independent of Free Press, @OKC_SPAN, where he live-tweets local Oklahoma County and Oklahoma City government meetings. He then writes up those meetings to the standards of Free Press as a freelance journalist.</div><div class="td-author-social">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/OKC_SPAN" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Marty Peercy"><meta itemprop="url" content="https://freepressokc.com/author/martypeercy/"></span><meta itemprop="datePublished" content="2022-02-10T18:40:10-06:00"><meta itemprop="dateModified" content="2022-02-10T18:40:11-06:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://freepressokc.com/commissioners-hire-lawyers-hear-from-angry-public-about-ok-county-jail/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://freepressokc.com/commissioners-hire-lawyers-hear-from-angry-public-about-ok-county-jail/"></span><meta itemprop="name" content="Oklahoma City Free Press"></span><meta itemprop="headline " content="Commissioners hire lawyers - hear from angry public about OK County Jail"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage.jpg"><meta itemprop="width" content="1280"><meta itemprop="height" content="720"></span> </footer>
<div class="td_block_wrap td_block_related_posts tdi_2 td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_2"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_2 = new tdBlock();
block_tdi_2.id = "tdi_2";
block_tdi_2.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_tags","td_ajax_filter_type":"td_custom_related","class":"tdi_2","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":17474,"live_filter_cur_post_author":"29","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_2","tdc_css_class_style":"tdi_2_rand_style"}';
block_tdi_2.td_column_number = "3";
block_tdi_2.block_type = "td_block_related_posts";
block_tdi_2.post_count = "3";
block_tdi_2.found_posts = "114";
block_tdi_2.header_color = "";
block_tdi_2.ajax_pagination_infinite_stop = "";
block_tdi_2.max_num_pages = "38";
tdBlocksArray.push(block_tdi_2);
</script><h4 class="td-related-title td-block-title"><a id="tdi_3" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_2" href="#">RELATED ARTICLES</a><a id="tdi_4" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_2" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_2 class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://freepressokc.com/jail-trust-takes-no-action-on-citizens-advisory-board-hears-jail-reports/" rel="bookmark" class="td-image-wrap " title="Jail Trust takes no action on Citizens&#8217; Advisory Board &#8211; hears jail reports"><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2021/03/County-Jail-Hostage-sit-3-27-21-DSC07819-218x150.jpeg" srcset="https://freepressokc.com/wp-content/uploads/2021/03/County-Jail-Hostage-sit-3-27-21-DSC07819-218x150.jpeg 218w, https://freepressokc.com/wp-content/uploads/2021/03/County-Jail-Hostage-sit-3-27-21-DSC07819-100x70.jpeg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="Jail" title="Jail Trust takes no action on Citizens&#8217; Advisory Board &#8211; hears jail reports" /></a></div> <a href="https://freepressokc.com/category/government/" class="td-post-category">Government</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://freepressokc.com/jail-trust-takes-no-action-on-citizens-advisory-board-hears-jail-reports/" rel="bookmark" title="Jail Trust takes no action on Citizens&#8217; Advisory Board &#8211; hears jail reports">Jail Trust takes no action on Citizens&#8217; Advisory Board &#8211; hears jail reports</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://freepressokc.com/commissioners-take-action-on-recovery-cares-act-and-odot-funds/" rel="bookmark" class="td-image-wrap " title="Commissioners take action on recovery, CARES Act, and ODOT funds"><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2021/11/BoCC-special-11-18-21-PB180118-2-218x150.jpg" srcset="https://freepressokc.com/wp-content/uploads/2021/11/BoCC-special-11-18-21-PB180118-2-218x150.jpg 218w, https://freepressokc.com/wp-content/uploads/2021/11/BoCC-special-11-18-21-PB180118-2-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="BoCC" title="Commissioners take action on recovery, CARES Act, and ODOT funds" /></a></div> <a href="https://freepressokc.com/category/government/" class="td-post-category">Government</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://freepressokc.com/commissioners-take-action-on-recovery-cares-act-and-odot-funds/" rel="bookmark" title="Commissioners take action on recovery, CARES Act, and ODOT funds">Commissioners take action on recovery, CARES Act, and ODOT funds</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://freepressokc.com/commissioners-move-forward-on-funding-requests-to-state-for-jail/" rel="bookmark" class="td-image-wrap " title="Commissioners move forward on funding requests to state for Jail"><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2021/11/BoCC-special-11-18-21-PB180118-2-218x150.jpg" srcset="https://freepressokc.com/wp-content/uploads/2021/11/BoCC-special-11-18-21-PB180118-2-218x150.jpg 218w, https://freepressokc.com/wp-content/uploads/2021/11/BoCC-special-11-18-21-PB180118-2-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="BoCC" title="Commissioners move forward on funding requests to state for Jail" /></a></div> <a href="https://freepressokc.com/category/government/" class="td-post-category">Government</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://freepressokc.com/commissioners-move-forward-on-funding-requests-to-state-for-jail/" rel="bookmark" title="Commissioners move forward on funding requests to state for Jail">Commissioners move forward on funding requests to state for Jail</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_2" data-td_block_id="tdi_2"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_2" data-td_block_id="tdi_2"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div></div> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside id="60b995e127a1b-3" class="td_block_template_1 widget 60b995e127a1b-3 60b995e127a1b"><div class="a-single a-4"><center><a class="gofollow" data-track="NCwwLDEsMTU=" href="https://trueskycu.org/747loan/" target="_blank" rel="nofollow"><img src="https://freepressokc.com/wp-content/banners/truesky-747-digital-ads-01.jpeg" width="300" height="250" /></a></center></div></aside><aside id="60b995e127a1b-9" class="td_block_template_1 widget 60b995e127a1b-9 60b995e127a1b"><div class="a-single a-12"><center><a class="gofollow" data-track="MTIsMCwxLDE1" href="https://www.okcmoa.com/visit/events/chihulymagicandlight/" target="_blank" rel="nofollow"><img src="https://freepressokc.com/wp-content/banners/okcmoa-feb-2022-medium-rectangle-300x250.jpeg" width="300" height="250" /></a></center></div></aside><aside id="60b995e127a1b-10" class="td_block_template_1 widget 60b995e127a1b-10 60b995e127a1b"><div class="a-single a-11"><center><a class="gofollow" data-track="MTEsMCwxLDE1" href="https://workflowokc.com" target="_blank" rel="nofollow"><img src="https://freepressokc.com/wp-content/banners/free-press-sidebar-01.jpeg" width="300" height="250" /></a></center></div></aside> </div>
</div>
</div> 
</div> 
</article> 

<div class="tdc-footer-wrap ">

<div class="td-footer-wrapper td-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
<div class="td-pb-row">
<div class="td-pb-span12">
<aside class="td_block_template_1 widget 60b995e127a1b"><div class="a-single a-13"><center><a class="gofollow" data-track="MTMsMCwxLDE1" href="https://www.okcmoa.com/visit/events/chihulymagicandlight/" target="_blank" rel="nofollow"><img src="https://freepressokc.com/wp-content/banners/chihuly-mod-ad-1024x145.jpeg" width="1024" height="145" /></a></center></div></aside> </div>
</div>
</div>
<div class="td-footer-bottom-full">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://freepressokc.com/"><img src="https://freepressokc.com/wp-content/uploads/2016/11/FPLogo-Nov1-white-150x150.png" alt="Oklahoma City Free Press" title="Oklahoma City Free Press" /></a></aside></div><div class="td-pb-span9"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div><hr>
<p><strong>Sustain our journalism by becoming a supporter<br></strong></p>
<p>Oklahoma City Free Press is dedicated to providing high quality journalism that positively impacts our community. We give voice to those who aren’t heard and expose that which is hidden from the public. Click this <a href="https://pp-staging.presspatron.com/donations/new?frame=1&t=VuVQRxLy7UcJsBNvasA5tDAz">link</a> or the red button below to support our mission.</p>
<div class="pp-donate-button"> </div>
<hr>
Published by Oklahoma City Free Press LLC, Oklahoma City, Oklahoma -- Publisher and Editor - Brett Dickerson. All photography and content is under copyright. We adhere to the Society of Professional Journalists Code of Ethics.</aside></div> </div>
</div>
</div>
</div>

<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
</div>
<div class="td-pb-span td-sub-footer-copy">
&copy; Oklahoma City Free Press LLC, 2016, 2017, 2018, 2019, 2020, 2021. <a href="//www.dmca.com/Protection/Status.aspx?ID=64fb634b-962d-4e3b-93ec-bed7c5a4d8ec" title="DMCA.com Protection Status" class="dmca-badge"> <img src="//images.dmca.com/Badges/dmca-badge-w100-5x1-11.png?ID=64fb634b-962d-4e3b-93ec-bed7c5a4d8ec" alt="DMCA.com Protection Status"></a> <script src="//images.dmca.com/Badges/DMCABadgeHelper.min.js"> </script> </div>
</div>
</div>
</div>
</div>
</div>
<script type="text/javascript">
				var _paq = _paq || [];
					_paq.push(['setCustomDimension', 1, '{"ID":29,"name":"Marty Peercy","avatar":"9e9ca45327ac6d664a70536a3b1911f6"}']);
				_paq.push(['trackPageView']);
								(function () {
					var u = "https://stats1.wpmudev.com/";
					_paq.push(['setTrackerUrl', u + 'track/']);
					_paq.push(['setSiteId', '22896']);
					var d   = document, g = d.createElement('script'), s = d.getElementsByTagName('script')[0];
					g.type  = 'text/javascript';
					g.async = true;
					g.defer = true;
					g.src   = 'https://stats.wpmucdn.com/analytics.js';
					s.parentNode.insertBefore(g, s);
				})();
			</script>
<div class="td-more-articles-box">
<i class="td-icon-close td-close-more-articles-box"></i>
<span class="td-more-articles-box-title">MORE STORIES</span>
<div class="td-content-more-articles-box">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://freepressokc.com/commissioners-meet-two-days-over-masks-pending-litigation-terrorism/" rel="bookmark" class="td-image-wrap " title="Commissioners meet two days over masks, pending litigation, terrorism"><img width="100" height="70" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2020/03/BoCC-3-19-20-2-100x70.jpg" srcset="https://freepressokc.com/wp-content/uploads/2020/03/BoCC-3-19-20-2-100x70.jpg 100w, https://freepressokc.com/wp-content/uploads/2020/03/BoCC-3-19-20-2-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Board of County Commissioners" title="Commissioners meet two days over masks, pending litigation, terrorism" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://freepressokc.com/commissioners-meet-two-days-over-masks-pending-litigation-terrorism/" rel="bookmark" title="Commissioners meet two days over masks, pending litigation, terrorism">Commissioners meet two days over masks, pending litigation, terrorism</a></h3> <div class="td-module-meta-info">
<a href="https://freepressokc.com/category/government/" class="td-post-category">Government</a> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-08T20:16:30-05:00">April 8, 2021</time></span> </div>
</div>
</div>
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://freepressokc.com/ok-county-jail-trust-to-hear-recommendations-for-new-jail-on-new-site/" rel="bookmark" class="td-image-wrap " title="OK County Jail Trust to hear recommendations for new jail on new site"><img width="100" height="70" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-100x70.jpg" srcset="https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-100x70.jpg 100w, https://freepressokc.com/wp-content/uploads/2021/04/OK-County-Jail-hostage-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="Oklahoma County Jail" title="OK County Jail Trust to hear recommendations for new jail on new site" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://freepressokc.com/ok-county-jail-trust-to-hear-recommendations-for-new-jail-on-new-site/" rel="bookmark" title="OK County Jail Trust to hear recommendations for new jail on new site">OK County Jail Trust to hear recommendations for new jail on...</a></h3> <div class="td-module-meta-info">
<a href="https://freepressokc.com/category/government/" class="td-post-category">Government</a> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-11-28T23:06:21-06:00">November 28, 2021</time></span> </div>
</div>
</div>
</div>
</div>

<script type='text/javascript' id='adrotate-dyngroup-js-extra'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"https:\/\/freepressokc.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.dyngroup.js' id='adrotate-dyngroup-js'></script>
<script type='text/javascript' id='adrotate-clicktracker-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/freepressokc.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js' id='adrotate-clicktracker-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/worth-the-read/js/wtr.js?ver=5.9' id='wtr-js-js'></script>
<script type='text/javascript' id='ppress-frontend-script-js-extra'>
/* <![CDATA[ */
var pp_ajax_form = {"ajaxurl":"https:\/\/freepressokc.com\/wp-admin\/admin-ajax.php","confirm_delete":"Are you sure?","deleting_text":"Deleting...","deleting_error":"An error occurred. Please try again.","nonce":"2819c4f14c","disable_ajax_form":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/wp-user-avatar/assets/js/frontend.min.js?ver=3.2.7' id='ppress-frontend-script-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=ecd3ae9d894693e4aa2a268d920aa306' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=11.4.1' id='td-site-min-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/comment-reply.min.js?ver=5.9' id='comment-reply-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=ecd3ae9d894693e4aa2a268d920aa306' id='tdb_js_files_for_front-js'></script>

<script>
    
</script>

<script type="text/javascript">
jQuery(document).ready(function(){if(jQuery.fn.gslider) {
	jQuery('.g-3').gslider({groupid:3,speed:6000,repeat_impressions:'Y'});
}});
</script>

</body>
</html>