<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>‘Promising Young Woman’ takes dead aim at misogyny</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://freepressokc.com/xmlrpc.php" />
    <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<link rel="icon" type="image/png" href="https://freepressokc.com/wp-content/uploads/2016/09/cropped-FPlogo-single-png.png">
	<!-- This site is optimized with the Yoast SEO plugin v16.1.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Promising Young Woman by writer-director Emerald Fennell excels as a pitch-black revenge comedy and as blunt-force social commentary." />
	<link rel="canonical" href="https://freepressokc.com/promising-young-woman-takes-dead-aim-at-misogyny/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="‘Promising Young Woman’ takes dead aim at misogyny" />
	<meta property="og:description" content="Promising Young Woman by writer-director Emerald Fennell excels as a pitch-black revenge comedy and as blunt-force social commentary." />
	<meta property="og:url" content="https://freepressokc.com/promising-young-woman-takes-dead-aim-at-misogyny/" />
	<meta property="og:site_name" content="Oklahoma City Free Press" />
	<meta property="article:publisher" content="https://www.facebook.com/oklahomacityfreepress/" />
	<meta property="article:published_time" content="2021-04-16T03:51:01+00:00" />
	<meta property="article:modified_time" content="2021-04-16T03:51:03+00:00" />
	<meta property="og:image" content="https://freepressokc.com/wp-content/uploads/2021/04/promising-young-woman.jpg" />
	<meta property="og:image:width" content="780" />
	<meta property="og:image:height" content="410" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@freepressokc" />
	<meta name="twitter:site" content="@freepressokc" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="George Lang">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="3 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://freepressokc.com/#organization","name":"Oklahoma City Free Press LLC","url":"https://freepressokc.com/","sameAs":["https://www.facebook.com/oklahomacityfreepress/","https://www.instagram.com/freepressokc/?hl=en","https://www.youtube.com/channel/UCKnwaGON2-YbuX9-smgCafw","https://www.pinterest.com/oklahomacityfre/","https://twitter.com/freepressokc"],"logo":{"@type":"ImageObject","@id":"https://freepressokc.com/#logo","inLanguage":"en-US","url":"https://freepressokc.com/wp-content/uploads/2016/09/FPLogo-Nov1-black.png","contentUrl":"https://freepressokc.com/wp-content/uploads/2016/09/FPLogo-Nov1-black.png","width":543,"height":543,"caption":"Oklahoma City Free Press LLC"},"image":{"@id":"https://freepressokc.com/#logo"}},{"@type":"WebSite","@id":"https://freepressokc.com/#website","url":"https://freepressokc.com/","name":"Oklahoma City Free Press","description":"Local, independent, online news","publisher":{"@id":"https://freepressokc.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://freepressokc.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://freepressokc.com/promising-young-woman-takes-dead-aim-at-misogyny/#primaryimage","inLanguage":"en-US","url":"https://freepressokc.com/wp-content/uploads/2021/04/promising-young-woman.jpg","contentUrl":"https://freepressokc.com/wp-content/uploads/2021/04/promising-young-woman.jpg","width":780,"height":410},{"@type":"WebPage","@id":"https://freepressokc.com/promising-young-woman-takes-dead-aim-at-misogyny/#webpage","url":"https://freepressokc.com/promising-young-woman-takes-dead-aim-at-misogyny/","name":"\u2018Promising Young Woman\u2019 takes dead aim at misogyny","isPartOf":{"@id":"https://freepressokc.com/#website"},"primaryImageOfPage":{"@id":"https://freepressokc.com/promising-young-woman-takes-dead-aim-at-misogyny/#primaryimage"},"datePublished":"2021-04-16T03:51:01+00:00","dateModified":"2021-04-16T03:51:03+00:00","description":"Promising Young Woman by writer-director Emerald Fennell excels as a pitch-black revenge comedy and as blunt-force social commentary.","breadcrumb":{"@id":"https://freepressokc.com/promising-young-woman-takes-dead-aim-at-misogyny/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://freepressokc.com/promising-young-woman-takes-dead-aim-at-misogyny/"]}]},{"@type":"BreadcrumbList","@id":"https://freepressokc.com/promising-young-woman-takes-dead-aim-at-misogyny/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://freepressokc.com/","url":"https://freepressokc.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://freepressokc.com/promising-young-woman-takes-dead-aim-at-misogyny/","url":"https://freepressokc.com/promising-young-woman-takes-dead-aim-at-misogyny/","name":"\u2018Promising Young Woman\u2019 takes dead aim at misogyny"}}]},{"@type":"Article","@id":"https://freepressokc.com/promising-young-woman-takes-dead-aim-at-misogyny/#article","isPartOf":{"@id":"https://freepressokc.com/promising-young-woman-takes-dead-aim-at-misogyny/#webpage"},"author":{"@id":"https://freepressokc.com/#/schema/person/6d3da654e3aac398a6e04d135ec5f1e9"},"headline":"\u2018Promising Young Woman\u2019 takes dead aim at misogyny","datePublished":"2021-04-16T03:51:01+00:00","dateModified":"2021-04-16T03:51:03+00:00","mainEntityOfPage":{"@id":"https://freepressokc.com/promising-young-woman-takes-dead-aim-at-misogyny/#webpage"},"publisher":{"@id":"https://freepressokc.com/#organization"},"image":{"@id":"https://freepressokc.com/promising-young-woman-takes-dead-aim-at-misogyny/#primaryimage"},"keywords":"Music and Film,Promising Young Woman","articleSection":"Cinema","inLanguage":"en-US"},{"@type":"Person","@id":"https://freepressokc.com/#/schema/person/6d3da654e3aac398a6e04d135ec5f1e9","name":"George Lang","image":{"@type":"ImageObject","@id":"https://freepressokc.com/#personlogo","inLanguage":"en-US","url":"https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1.jpg","contentUrl":"https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1.jpg","caption":"George Lang"},"description":"George Lang has worked as an award-winning professional journalist in Oklahoma City for over 25 years. His work has been published in The Oklahoman, Oklahoma Gazette, 405 Magazine and others, and covers a wide range of subjects including politics, media, entertainment and others. George lives in Oklahoma City with his wife and son."}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Oklahoma City Free Press &raquo; Feed" href="https://freepressokc.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Oklahoma City Free Press &raquo; Comments Feed" href="https://freepressokc.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/freepressokc.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='adsanity-default-css-css'  href='https://freepressokc.com/wp-content/plugins/adsanity/dist/css/widget-default.css?ver=1.8.1' type='text/css' media='screen' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://freepressokc.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='adsanity-cas-css'  href='https://freepressokc.com/cas-custom-sizes/?ver=1.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='adsanity-vii-css'  href='https://freepressokc.com/wp-content/plugins/adsanity-vi-video-ads/public/dist/bundle.css?ver=1.4' type='text/css' media='all' />
<link rel='stylesheet' id='wtr-css-css'  href='https://freepressokc.com/wp-content/plugins/worth-the-read/css/wtr.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://freepressokc.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=c784b8db3e66cd68082f3ff7aa2d70e6' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Roboto+Slab%3A400%7CLato%3A400%7CRoboto%3A400%2C500%2C700%7COpen+Sans%3A400%2C600%2C700&#038;display=swap&#038;ver=10.3.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://freepressokc.com/wp-content/themes/childnewspaper7/style.css?ver=1.0' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='td-legacy-framework-front-style-css'  href='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=c784b8db3e66cd68082f3ff7aa2d70e6' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css'  href='https://freepressokc.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=6b62588d33477b8e3dc5b8b3c9c8d86c' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/includes/demos/politics/demo_style.css?ver=10.3.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css'  href='https://freepressokc.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=a50385a2d79d6600973a7e697f735a0b' type='text/css' media='all, print' />
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://freepressokc.com/wp-json/" /><link rel="alternate" type="application/json" href="https://freepressokc.com/wp-json/wp/v2/posts/13321" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://freepressokc.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://freepressokc.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.1" />
<link rel='shortlink' href='https://freepressokc.com/?p=13321' />
<link rel="alternate" type="application/json+oembed" href="https://freepressokc.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffreepressokc.com%2Fpromising-young-woman-takes-dead-aim-at-misogyny%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://freepressokc.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffreepressokc.com%2Fpromising-young-woman-takes-dead-aim-at-misogyny%2F&#038;format=xml" />
<style type="text/css">.wtr-time-wrap{ 
	/* wraps the entire label */
	margin: 0 10px;

}
.wtr-time-number{ 
	/* applies only to the number */
	
}</style><style id="wplmi-inline-css" type="text/css"> span.wplmi-user-avatar { width: 16px;display: inline-block !important;flex-shrink: 0; } img.wplmi-elementor-avatar { border-radius: 100%;margin-right: 3px; } 

</style>
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
        <script>
        window.tdb_globals = {"wpRestNonce":"8d657711bc","wpRestUrl":"https:\/\/freepressokc.com\/wp-json\/","permalinkStructure":"\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
    			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/freepressokc.com\/wp-admin\/","wpRestNonce":"8d657711bc","wpRestUrl":"https:\/\/freepressokc.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>
			
<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-89779313-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-89779313-1');
</script>


<script>
(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
el = d.createElement('script');
el.id = "js-pp-banner";
el.src = "//dashboard.presspatron.com/dev/banner?b=pMamyM1ZSttVyfgPpMYw2zgS";
fjs.parentNode.insertBefore(el, fjs);
}(document));
</script>

<div id="pp-banner"></div>



<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://freepressokc.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://freepressokc.com/category/cinema/",
                    "name": "Cinema"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://freepressokc.com/promising-young-woman-takes-dead-aim-at-misogyny/",
                    "name": "‘Promising Young Woman’ takes dead aim at misogyny"                                
                }
            }    
        ]
    }
</script>
<link rel="icon" href="https://freepressokc.com/wp-content/uploads/2016/11/cropped-FPLogo-Nov1-white-32x32.png" sizes="32x32" />
<link rel="icon" href="https://freepressokc.com/wp-content/uploads/2016/11/cropped-FPLogo-Nov1-white-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://freepressokc.com/wp-content/uploads/2016/11/cropped-FPLogo-Nov1-white-180x180.png" />
<meta name="msapplication-TileImage" content="https://freepressokc.com/wp-content/uploads/2016/11/cropped-FPLogo-Nov1-white-270x270.png" />
<link rel="alternate" type="application/rss+xml" title="RSS" href="https://freepressokc.com/rsslatest.xml" /><style type="text/css" title="dynamic-css" class="options-output">.wtr-time-wrap{text-align:left;line-height:20px;font-weight:400;font-style:italic;color:#079603;font-size:14px;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading .wtr-time-wrap{opacity: 0;}.ie.wf-loading .wtr-time-wrap{visibility: hidden;}</style>
<!-- Button style compiled by theme -->

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #dd3333;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #dd3333;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #dd3333;
                }
                .tdm-btn-style1 {
					background-color: #dd3333;
				}
				.tdm-btn-style2:before {
				    border-color: #dd3333;
				}
				.tdm-btn-style2 {
				    color: #dd3333;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #dd3333;
                    -moz-box-shadow: 0 2px 16px #dd3333;
                    box-shadow: 0 2px 16px #dd3333;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #dd3333;
                    -moz-box-shadow: 0 4px 26px #dd3333;
                    box-shadow: 0 4px 26px #dd3333;
				}
</style>

	<style id="tdw-css-placeholder"></style></head>

<body class="post-template-default single single-post postid-13321 single-format-standard td-standard-pack promising-young-woman-takes-dead-aim-at-misogyny global-block-template-1 td-politics single_template_3 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/oklahomacityfreepress/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/freepressokc" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="/cdn-cgi/l/email-protection#335a5d555c735541565643415640405c58501d505c5e" title="Mail">
                <i class="td-icon-font td-icon-mail-1"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://freepressokc.com/feed/" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/freepressokc" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCKnwaGON2-YbuX9-smgCafw" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-8600" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-8600"><a href="https://freepressokc.com/category/health-and-covid-19/">Health and COVID-19</a></li>
<li id="menu-item-231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-231"><a href="https://freepressokc.com/category/politics/">Politics<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-10122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10122"><a href="https://freepressokc.com/category/protests/">Protests</a></li>
</ul>
</li>
<li id="menu-item-48" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48"><a href="https://freepressokc.com/category/government/">Government</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47"><a href="https://freepressokc.com/category/education/">Education</a></li>
<li id="menu-item-4328" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-4328"><a href="https://freepressokc.com/category/the-arts/">The Arts<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-416" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-416"><a href="https://freepressokc.com/category/cinema/">Cinema<i class="td-icon-menu-right td-element-after"></i></a>
	<ul class="sub-menu">
		<li id="menu-item-9394" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9394"><a href="https://freepressokc.com/category/cinema/deadcenter/">deadCenter Film Festival</a></li>
	</ul>
</li>
	<li id="menu-item-8423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8423"><a href="https://freepressokc.com/category/music/">Music</a></li>
</ul>
</li>
<li id="menu-item-46" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-46"><a href="https://freepressokc.com/category/cultures/">Cultures<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-7689" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7689"><a href="https://freepressokc.com/category/neighborhood-news/">Neighborhood news</a></li>
	<li id="menu-item-10452" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10452"><a href="https://freepressokc.com/category/seen-heard/">Seen and Heard</a></li>
</ul>
</li>
<li id="menu-item-45" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45"><a href="https://freepressokc.com/category/crime/">Crime</a></li>
<li id="menu-item-1033" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1033"><a href="https://freepressokc.com/category/business/">Business<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-50" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50"><a href="https://freepressokc.com/category/technology/">Technology</a></li>
</ul>
</li>
<li id="menu-item-7892" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-7892"><a href="https://freepressokc.com/category/opinion/">Opinion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-10451" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10451"><a href="https://freepressokc.com/category/open-letters/">Open Letters</a></li>
	<li id="menu-item-7647" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7647"><a href="https://freepressokc.com/category/first-person/">First Person</a></li>
	<li id="menu-item-10449" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10449"><a href="https://freepressokc.com/category/editor-notes/">Editor&#8217;s Notes</a></li>
</ul>
</li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text">
	                <a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
	                </div>
	                <div class="td-login-register-link">
	                
	                </div>
	                
	                <div class="td-login-info-text"><a class="privacy-policy-link" href="https://freepressokc.com/privacy-statement/">Privacy Statement</a></div>

                </div>
            </div>

            
            
            
            
            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://freepressokc.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style 10
-->

<div class="td-header-wrap td-header-style-10 ">
    
            <div class="td-header-top-menu-full td-container-wrap ">
            <div class="td-container td-header-row td-header-top-menu">
                
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Friday, April 16, 2021
            </div>
        </div>
    <div class="menu-top-container"><ul id="menu-about-mission-and-goals-ad-pol" class="top-header-menu"><li id="menu-item-5465" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-5465"><a href="https://freepressokc.com/about/">About</a></li>
<li id="menu-item-5466" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-5466"><a href="https://freepressokc.com/mission-goals/">Mission and Goals</a></li>
<li id="menu-item-8933" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-8933"><a href="https://freepressokc.com/political-advertising-policy/">Political Advertising Policy</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
            <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>


        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://freepressokc.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    
    
        
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/oklahomacityfreepress/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/freepressokc" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="/cdn-cgi/l/email-protection#4821262e27082e3a2d2d383a2d3b3b27232b662b2725" title="Mail">
                <i class="td-icon-font td-icon-mail-1"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://freepressokc.com/feed/" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/freepressokc" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCKnwaGON2-YbuX9-smgCafw" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>    </div>    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <div class="td-login-wrap">
                        <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
	                        <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            
                            
                            
                            <div class="td-login-info-text"><a class="privacy-policy-link" href="https://freepressokc.com/privacy-statement/">Privacy Statement</a></div>
                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                        
                        
                    </div>
                </div>
                            </div>
        </div>
    
    <div class="td-banner-wrap-full td-logo-wrap-full  td-container-wrap ">
        <div class="td-header-sp-logo">
            		<div class="td-logo-text-wrap">
			<span class="td-logo-text-container">
				<a class="td-logo-wrap" href="https://freepressokc.com/">
											<span class="td-logo-text">Oklahoma City Free Press</span>
										<span class="td-tagline-text">Oklahoma City's award-winning independent, online news</span>
				</a>
			</span>
		</div>
	        </div>
    </div>

	<div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient td-header-menu-no-search">
			<div class="td-container td-header-row td-header-main-menu">
				<div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
            </div>
    <div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-8600"><a href="https://freepressokc.com/category/health-and-covid-19/">Health and COVID-19</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-231"><a href="https://freepressokc.com/category/politics/">Politics</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10122"><a href="https://freepressokc.com/category/protests/">Protests</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-48"><a href="https://freepressokc.com/category/government/">Government</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-47"><a href="https://freepressokc.com/category/education/">Education</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-4328"><a href="https://freepressokc.com/category/the-arts/">The Arts</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children td-menu-item td-normal-menu menu-item-416"><a href="https://freepressokc.com/category/cinema/">Cinema</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-9394"><a href="https://freepressokc.com/category/cinema/deadcenter/">deadCenter Film Festival</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-8423"><a href="https://freepressokc.com/category/music/">Music</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-46"><a href="https://freepressokc.com/category/cultures/">Cultures</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7689"><a href="https://freepressokc.com/category/neighborhood-news/">Neighborhood news</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10452"><a href="https://freepressokc.com/category/seen-heard/">Seen and Heard</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-45"><a href="https://freepressokc.com/category/crime/">Crime</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-1033"><a href="https://freepressokc.com/category/business/">Business</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-50"><a href="https://freepressokc.com/category/technology/">Technology</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-7892"><a href="https://freepressokc.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10451"><a href="https://freepressokc.com/category/open-letters/">Open Letters</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7647"><a href="https://freepressokc.com/category/first-person/">First Person</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10449"><a href="https://freepressokc.com/category/editor-notes/">Editor&#8217;s Notes</a></li>
</ul>
</li>
</ul></div></div>


    <div class="td-search-wrapper">
        <div id="td-top-search">
            <!-- Search -->
            <div class="header-search-wrap">
                <div class="dropdown header-search">
                    <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                </div>
            </div>
        </div>
    </div>
			</div>
		</div>
	</div>

    
</div>
            </div>

            
<article id="post-13321" class="td-post-template-3 post-13321 post type-post status-publish format-standard has-post-thumbnail category-cinema tag-music-and-film tag-promising-young-woman td-container-wrap" itemscope itemtype="https://schema.org/Article">
    <div class="td-post-header td-container">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://freepressokc.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Cinema" class="entry-crumb" href="https://freepressokc.com/category/cinema/">Cinema</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">‘Promising Young Woman’ takes dead aim at misogyny</span></div></div>
        <div class="td-post-header-holder td-image-gradient">
            <div class="td-post-featured-image"><a href="https://freepressokc.com/wp-content/uploads/2021/04/promising-young-woman.jpg" data-caption=""><img width="780" height="410" class="entry-thumb td-modal-image" src="https://freepressokc.com/wp-content/uploads/2021/04/promising-young-woman.jpg" srcset="https://freepressokc.com/wp-content/uploads/2021/04/promising-young-woman.jpg 780w, https://freepressokc.com/wp-content/uploads/2021/04/promising-young-woman-300x158.jpg 300w, https://freepressokc.com/wp-content/uploads/2021/04/promising-young-woman-768x404.jpg 768w, https://freepressokc.com/wp-content/uploads/2021/04/promising-young-woman-696x366.jpg 696w" sizes="(max-width: 780px) 100vw, 780px" alt="" title="promising-young-woman"/></a></div>
            <header class="td-post-title">
                <ul class="td-category"><li class="entry-category"><a  href="https://freepressokc.com/category/cinema/">Cinema</a></li></ul>                <h1 class="entry-title">‘Promising Young Woman’ takes dead aim at misogyny</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://freepressokc.com/author/george-lang/">George Lang</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-15T22:51:01-05:00" >April 15, 2021</time></span>                                                        </div>

            </header>
        </div>
    </div>

    <div class="td-container">
        <div class="td-pb-row">
                                <div class="td-pb-span8 td-main-content" role="main">
                        <div class="td-ss-main-content">
                            
    <div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
                                        <div class="td-social-but-icon"><i class="td-icon-share"></i></div>
                                        <div class="td-social-but-text">Share</div>
                                    </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffreepressokc.com%2Fpromising-young-woman-takes-dead-aim-at-misogyny%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=%E2%80%98Promising+Young+Woman%E2%80%99+takes+dead+aim+at+misogyny&url=https%3A%2F%2Ffreepressokc.com%2Fpromising-young-woman-takes-dead-aim-at-misogyny%2F&via=freepressokc">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#c5fab6b0a7afa0a6b1f827455d95b7aaa8acb6acaba2e59caab0aba2e592aaa8a4ab27455ce5b1a4aea0b6e5a1a0a4a1e5a4aca8e5a4b1e5a8acb6aaa2bcabbce3a7aaa1bcf8adb1b1b5b6ffeaeaa3b7a0a0b5b7a0b6b6aaaea6eba6aaa8eab5b7aaa8acb6acaba2e8bcaab0aba2e8b2aaa8a4abe8b1a4aea0b6e8a1a0a4a1e8a4aca8e8a4b1e8a8acb6aaa2bcabbcea">
                                        <div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
                                        <div class="td-social-but-text">Email</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#">
                                        <div class="td-social-but-icon"><i class="td-icon-print"></i></div>
                                        <div class="td-social-but-text">Print</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>
    <div class="td-post-content tagdiv-type">
        <span class="wtr-time-wrap before-content"><span class="wtr-time-number">3</span> minute read</span><div id="wtr-content" 
	    	data-bg="#FFFFFF" 
	    	data-fg="#f44813" 
	    	data-width="5" 
	    	data-mute="" 
	    	data-fgopacity="0.5" 
	    	data-mutedopacity="0.5" 
	    	data-placement="left" 
	    	data-placement-offset="0" 
	    	data-content-offset="0" 
	    	data-placement-touch="left" 
		    data-placement-offset-touch="0" 
	    	data-transparent="" 
	    	data-shadow="1" 
	    	data-touch="1" 
	    	data-non-touch="1" 
	    	data-comments="0" 
	    	data-commentsbg="#ffcece" 
	    	data-location="page" 
	    	data-mutedfg="#f44813" 
	    	data-endfg="#f44813" 
	    	data-rtl="" 
	    	>
<div id="ad-12268" class="ad-728x90 adsanity-728x90 aligncenter adsanity-aligncenter"><div class="adsanity-inner">

	<a rel="nofollow" href="https://freepressokc.com/ads/true-sky-leaderboard/"  target="_blank"><img width="1281" height="181" src="https://freepressokc.com/wp-content/uploads/2021/02/TrueSky-747-Digital-Ads-02.jpg" class="no-lazy-load wp-post-image" alt="" loading="normal" srcset="https://freepressokc.com/wp-content/uploads/2021/02/TrueSky-747-Digital-Ads-02.jpg 1281w, https://freepressokc.com/wp-content/uploads/2021/02/TrueSky-747-Digital-Ads-02-300x42.jpg 300w, https://freepressokc.com/wp-content/uploads/2021/02/TrueSky-747-Digital-Ads-02-1024x145.jpg 1024w, https://freepressokc.com/wp-content/uploads/2021/02/TrueSky-747-Digital-Ads-02-768x109.jpg 768w, https://freepressokc.com/wp-content/uploads/2021/02/TrueSky-747-Digital-Ads-02-696x98.jpg 696w, https://freepressokc.com/wp-content/uploads/2021/02/TrueSky-747-Digital-Ads-02-1068x151.jpg 1068w" sizes="(max-width: 1281px) 100vw, 1281px" /></a>
</div></div>




<p><em>Promising Young Woman, </em>the assured feature debut by writer-director Emerald Fennell, excels as a pitch-black revenge comedy and as blunt-force social commentary. The film’s emotional brutality does not relent, nor should it: <em>Promising Young Woman </em>is a grand indictment of the male gaze, both in film and in life.</p>



<p>As part of its Academy Awards preview, <em>Promising Young Woman </em>will screen at 8 p.m. Friday and 5 p.m. Saturday at Tower Theatre, 425 NW 23rd St.&nbsp;</p>



<div class="wp-block-media-text alignwide has-media-on-the-right is-stacked-on-mobile" style="grid-template-columns:auto 20%"><figure class="wp-block-media-text__media"><img loading="lazy" width="1024" height="1024" src="https://freepressokc.com/wp-content/uploads/2020/01/DSC09075-1-1024x1024.jpg" alt="cinema film" class="wp-image-7917 size-full" srcset="https://freepressokc.com/wp-content/uploads/2020/01/DSC09075-1-1024x1024.jpg 1024w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09075-1-300x300.jpg 300w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09075-1-150x150.jpg 150w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09075-1-768x768.jpg 768w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09075-1-696x696.jpg 696w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09075-1-1068x1068.jpg 1068w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09075-1-420x420.jpg 420w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09075-1.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure><div class="wp-block-media-text__content">
<blockquote class="wp-block-quote"><p><em><strong><span class="has-inline-color has-vivid-red-color">Music and film</span></strong></em></p><cite>by George Lang</cite></blockquote>



<p class="has-text-align-center">Sponsored by <a href="https://trueskycu.org"><strong>True Sky Credit Union</strong></a></p>
</div></div>



<p>In an Oscar-nominated performance, Carey Mulligan plays Cassandra Thomas, a woman in her early 30s who is years removed from dropping out of medical school and currently lives at home with her parents (Jennifer Coolidge and Clancy Brown). Cassandra spends her days barely working at a coffee shop and most nights going to bars, where she pretends to be ripping drunk in order to attract predatory men and punish them for their actions.</p>



<p>Cassandra has good reasons for her behavior, and <em>Promising Young Woman</em> soon makes it clear that she is methodically working through a list of both women and men who played a role in a great disservice to a young woman in crisis. Whether it is the dean of the medical school (Connie Britton), former classmate Madison (Alison Brie) or the pediatric surgeon (Bo Burnham) who falls hard for her, Cassandra is on a merciless mission.&nbsp;</p>



<p>One of the great recurring themes in <em>Promising Young Woman</em> is the delusion of men, most of whom express some variation on the phrase “I’m a nice guy” when trying to justify their terrible behavior. They all act with casual, unthinking misogyny toward Cassandra and other bar scene prey, whether they are capable lotharios like Jerry (Adam Brody) or coked-up insecure nerds (Christopher Mintz-Plasse).</p>



<div id="ad-12265" class="ad-300x250 adsanity-300x250 aligncenter adsanity-aligncenter"><div class="adsanity-inner">

	<a rel="nofollow" href="https://freepressokc.com/ads/true-sky-post-body/"  target="_blank"><img width="300" height="250" src="https://freepressokc.com/wp-content/uploads/2021/02/TrueSky-747-Digital-Ads-01.jpg" class="no-lazy-load wp-post-image" alt="" loading="normal" /></a>
</div></div>




<p>Fennell, who is best known for writing most of <em>Killing Eve</em>’s second season and for playing Camilla Parker-Bowles in <em>The Crown</em>, maintains the mystery of Cassandra’s actions for most of the film, doling out just enough information when and where it is needed. But she also makes her thesis statement with the opening credits sequence, showing men with big bellies in ill-fitting khakis dancing with abundant overconfidence. It symbolizes how easily men can delude themselves into thinking they are worthy of the women in their sights.&nbsp;</p>



<p>At the center of all this is Mulligan, who projects faux vulnerability when it is needed for Cassandra to ensnare someone and then turns on a dime when going in for the kill. It is easily one of Mulligan’s best performances in a career that began with 2005’s <em>Pride &amp; Prejudice</em> and surged four years later in <em>An Education</em>.</p>



<p><em>An Education</em> was notable for the ways in which its central character, 1960s London teenager Jenny Mellor, was treated as an object to be acquired by a 30-something man (Peter Saarsgard). In Jenny’s case, she was a willing participant in an inappropriate seduction, and her overbearing father (Alfred Molina) acted as an accomplice.&nbsp;</p>



<p>In some ways, <em>Promising Young Woman</em> is a rejoinder to <em>An Education</em> — Molina even makes an appearance as an attorney who is incapacitated with guilt over the central crime in the story. While <em>An Education</em> was almost too subtle as an indictment of predatory sexual behavior, <em>Promising Young Woman</em> hits its targets repeatedly between the eyes.&nbsp;</p>



<p>Between Fennell’s caustic script and Mulligan’s precise performance, <em>Promising Young Woman </em>is a film for its time, going straight at a culture that has no excuses anymore.</p>



<p>Tickets are $10. Visit <a href="https://towertheatreokc.com">towertheatreokc.com</a>.</p>



<h2><strong>And, this!</strong></h2>



<p>Bread and Butter Band, a high-energy string band putting a new twist on the gypsy jazz created by Django Reinhardt and Stephane Grappelli, performs on the patio at 8 p.m. Saturday at 51st Street Speakeasy, 1114 NW 51st St. For more information, call (405) 463-0470.</p>



<hr>
<h3><strong>Sustain our journalism by becoming a supporter<br></strong></h3>
<p>Oklahoma City Free Press is dedicated to providing high quality journalism that positively impacts our community. Click this <a href="https://dashboard.presspatron.com/donations/new?frame=1&amp;t=pMamyM1ZSttVyfgPpMYw2zgS">link</a>to support our mission.</p>
<div class="pp-donate-button"></div>
<hr>



<p></p>
<p class="post-modified-info">Last Updated April 15, 2021, 10:51 PM by <a href="" target="_blank" class="last-modified-author">Brett Dickerson &#8211; Editor</a></p></div>    </div>


    <footer>
                
        <div class="td-post-source-tags">
                        <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://freepressokc.com/tag/music-and-film/">Music and Film</a></li><li><a href="https://freepressokc.com/tag/promising-young-woman/">Promising Young Woman</a></li></ul>        </div>

        <div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
                                        <div class="td-social-but-icon"><i class="td-icon-share"></i></div>
                                        <div class="td-social-but-text">Share</div>
                                    </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffreepressokc.com%2Fpromising-young-woman-takes-dead-aim-at-misogyny%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=%E2%80%98Promising+Young+Woman%E2%80%99+takes+dead+aim+at+misogyny&url=https%3A%2F%2Ffreepressokc.com%2Fpromising-young-woman-takes-dead-aim-at-misogyny%2F&via=freepressokc">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#90afe3e5f2faf5f3e4ad721008c0e2fffdf9e3f9fef7b0c9ffe5fef7b0c7fffdf1fe721009b0e4f1fbf5e3b0f4f5f1f4b0f1f9fdb0f1e4b0fdf9e3fff7e9fee9b6f2fff4e9adf8e4e4e0e3aabfbff6e2f5f5e0e2f5e3e3fffbf3bef3fffdbfe0e2fffdf9e3f9fef7bde9ffe5fef7bde7fffdf1febde4f1fbf5e3bdf4f5f1f4bdf1f9fdbdf1e4bdfdf9e3fff7e9fee9bf">
                                        <div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
                                        <div class="td-social-but-text">Email</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#">
                                        <div class="td-social-but-icon"><i class="td-icon-print"></i></div>
                                        <div class="td-social-but-text">Print</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>        <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://freepressokc.com/criminal-justice-advisory-council-continues-effort-to-address-jail-issues/">Criminal Justice Advisory Council continues effort to address Jail issues</a></div></div><div class="td-next-prev-separator"></div></div>        <div class="author-box-wrap"><a href="https://freepressokc.com/author/george-lang/"><img src="https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-150x150.jpg" width="96" height="96" alt="George Lang" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://freepressokc.com/author/george-lang/">George Lang</a></span></div><div class="td-author-description">George Lang has worked as an award-winning professional journalist in Oklahoma City for over 25 years. His work has been published in The Oklahoman, Oklahoma Gazette, 405 Magazine and others, and covers a wide range of subjects including politics, media, entertainment and others. George lives in Oklahoma City with his wife and son.</div><div class="td-author-social"></div><div class="clearfix"></div></div></div>        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="George Lang"></span><meta itemprop="datePublished" content="2021-04-15T22:51:01-05:00"><meta itemprop="dateModified" content="2021-04-15T22:51:03-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://freepressokc.com/promising-young-woman-takes-dead-aim-at-misogyny/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://freepressokc.com/promising-young-woman-takes-dead-aim-at-misogyny/"></span><meta itemprop="name" content="Oklahoma City Free Press"></span><meta itemprop="headline " content="‘Promising Young Woman’ takes dead aim at misogyny"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://freepressokc.com/wp-content/uploads/2021/04/promising-young-woman.jpg"><meta itemprop="width" content="780"><meta itemprop="height" content="410"></span>    </footer>

    <div class="td_block_wrap td_block_related_posts tdi_2_8cf td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_2_8cf" ><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_2_8cf = new tdBlock();
block_tdi_2_8cf.id = "tdi_2_8cf";
block_tdi_2_8cf.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_tags","td_ajax_filter_type":"td_custom_related","class":"tdi_2_8cf","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":13321,"live_filter_cur_post_author":"339","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_2_8cf","tdc_css_class_style":"tdi_2_8cf_rand_style"}';
block_tdi_2_8cf.td_column_number = "3";
block_tdi_2_8cf.block_type = "td_block_related_posts";
block_tdi_2_8cf.post_count = "2";
block_tdi_2_8cf.found_posts = "2";
block_tdi_2_8cf.header_color = "";
block_tdi_2_8cf.ajax_pagination_infinite_stop = "";
block_tdi_2_8cf.max_num_pages = "1";
tdBlocksArray.push(block_tdi_2_8cf);
</script><h4 class="td-related-title td-block-title"><a id="tdi_3_ab6" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_2_8cf" href="#">RELATED ARTICLES</a><a id="tdi_4_b19" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_2_8cf" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_2_8cf class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://freepressokc.com/cicada-applies-a-doc-aesthetic-to-its-fictionalized-same-sex-romance/" rel="bookmark" class="td-image-wrap " title="&#8216;Cicada&#8217; applies a doc aesthetic to its fictionalized same-sex romance" ><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2021/04/m-0sJNnw-218x150.jpeg"  srcset="https://freepressokc.com/wp-content/uploads/2021/04/m-0sJNnw-218x150.jpeg 218w, https://freepressokc.com/wp-content/uploads/2021/04/m-0sJNnw-100x70.jpeg 100w" sizes="(max-width: 218px) 100vw, 218px"  alt="Cicada" title="&#8216;Cicada&#8217; applies a doc aesthetic to its fictionalized same-sex romance" /></a></div>                <a href="https://freepressokc.com/category/cinema/" class="td-post-category">Cinema</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/cicada-applies-a-doc-aesthetic-to-its-fictionalized-same-sex-romance/" rel="bookmark" title="&#8216;Cicada&#8217; applies a doc aesthetic to its fictionalized same-sex romance">&#8216;Cicada&#8217; applies a doc aesthetic to its fictionalized same-sex romance</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://freepressokc.com/museum-town-shows-how-art-transformed-a-new-england-industrial-center/" rel="bookmark" class="td-image-wrap " title="Museum Town shows how art transformed a New England industrial center" ><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2021/03/museum_town_still-928x523-1-218x150.jpg"  srcset="https://freepressokc.com/wp-content/uploads/2021/03/museum_town_still-928x523-1-218x150.jpg 218w, https://freepressokc.com/wp-content/uploads/2021/03/museum_town_still-928x523-1-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px"  alt="Museum Town" title="Museum Town shows how art transformed a New England industrial center" /></a></div>                <a href="https://freepressokc.com/category/cinema/" class="td-post-category">Cinema</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/museum-town-shows-how-art-transformed-a-new-england-industrial-center/" rel="bookmark" title="Museum Town shows how art transformed a New England industrial center">Museum Town shows how art transformed a New England industrial center</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_2_8cf" data-td_block_id="tdi_2_8cf"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page ajax-page-disabled" id="next-page-tdi_2_8cf" data-td_block_id="tdi_2_8cf"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
                        </div>
                    </div>
                    <div class="td-pb-span4 td-main-sidebar" role="complementary">
                        <div class="td-ss-main-sidebar">
                            <aside class="td_block_template_1 widget widget adsanity-group"><div class="ad-aligncenter"><div class="ad-row">
<div id="ad-13052" class="ad-300x250 adsanity-300x250"><div class="adsanity-inner">

	<a rel="nofollow" href="https://freepressokc.com/ads/dc-ad-campaign-2021-april/"  target="_blank"><img width="300" height="250" src="https://freepressokc.com/wp-content/uploads/2021/04/DCFF21-OKCPress-V6-01.jpg" class="no-lazy-load wp-post-image" alt="" loading="normal" /></a>
</div></div>

</div></div></aside>                        </div>
                    </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</article> <!-- /.post -->

<!-- Instagram -->

	
	
            <div class="tdc-footer-wrap ">

                <!-- Footer -->
				<div class="td-footer-wrapper td-footer-container td-container-wrap ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span12">
                            </div>
        </div>
    </div>

    <div class="td-footer-bottom-full">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://freepressokc.com/"><img src="https://freepressokc.com/wp-content/uploads/2016/11/FPLogo-Nov1-white-150x150.png" alt="Oklahoma City Free Press" title="Oklahoma City Free Press"/></a></aside></div><div class="td-pb-span9"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div><hr>
<p><strong>Sustain our journalism by becoming a supporter<br></strong></p>
<p>Oklahoma City Free Press is dedicated to providing high quality journalism that positively impacts our community. We give voice to those who aren’t heard and expose that which is hidden from the public. Click this <a href="https://pp-staging.presspatron.com/donations/new?frame=1&t=VuVQRxLy7UcJsBNvasA5tDAz">link</a> or the red button below to support our mission.</p>
<div class="pp-donate-button"> </div>
<hr>

Published by Oklahoma City Free Press LLC, Oklahoma City, Oklahoma -- Publisher and Editor - Brett Dickerson. All photography and content is under copyright. We adhere to the Society of Professional Journalists Code of Ethics.</aside></div>            </div>
        </div>
    </div>
</div>
                <!-- Sub Footer -->
				    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-sub-footer-material-container"><ul id="menu-sub-footer-material" class="td-subfooter-menu"><li id="menu-item-28" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-28"><a href="https://freepressokc.com/terms-copyright-and-conditions/">Terms, copyright, and conditions</a></li>
<li id="menu-item-31" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy td-menu-item td-normal-menu menu-item-31"><a href="https://freepressokc.com/privacy-statement/">Privacy Statement</a></li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; Oklahoma City Free Press LLC, 2016, 2017, 2018, 2019, 2020, 2021.    <a href="//www.dmca.com/Protection/Status.aspx?ID=64fb634b-962d-4e3b-93ec-bed7c5a4d8ec" title="DMCA.com Protection Status" class="dmca-badge"> <img src="//images.dmca.com/Badges/dmca-badge-w100-5x1-11.png?ID=64fb634b-962d-4e3b-93ec-bed7c5a4d8ec" alt="DMCA.com Protection Status"></a> <script src="//images.dmca.com/Badges/DMCABadgeHelper.min.js"> </script>                </div>
            </div>
        </div>
    </div>
            </div><!--close td-footer-wrap-->
			
</div><!--close td-outer-wrap-->



			<script type="text/javascript">
				var _paq = _paq || [];
					_paq.push(['setCustomDimension', 1, '{"ID":339,"name":"George Lang","avatar":"98880de19d53fb7944f3dcaa708a875d"}']);
				_paq.push(['trackPageView']);
								(function () {
					var u = "https://stats1.wpmudev.com/";
					_paq.push(['setTrackerUrl', u + 'track/']);
					_paq.push(['setSiteId', '22896']);
					var d   = document, g = d.createElement('script'), s = d.getElementsByTagName('script')[0];
					g.type  = 'text/javascript';
					g.async = true;
					g.defer = true;
					g.src   = 'https://stats.wpmucdn.com/analytics.js';
					s.parentNode.insertBefore(g, s);
				})();
			</script>
			                <div class="td-more-articles-box">
                    <i class="td-icon-close td-close-more-articles-box"></i>
                    <span class="td-more-articles-box-title">MORE STORIES</span>
                    <div class="td-content-more-articles-box">

                    
        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://freepressokc.com/cicada-applies-a-doc-aesthetic-to-its-fictionalized-same-sex-romance/" rel="bookmark" class="td-image-wrap " title="&#8216;Cicada&#8217; applies a doc aesthetic to its fictionalized same-sex romance" ><img width="100" height="70" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2021/04/m-0sJNnw-100x70.jpeg"  srcset="https://freepressokc.com/wp-content/uploads/2021/04/m-0sJNnw-100x70.jpeg 100w, https://freepressokc.com/wp-content/uploads/2021/04/m-0sJNnw-218x150.jpeg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="Cicada" title="&#8216;Cicada&#8217; applies a doc aesthetic to its fictionalized same-sex romance" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/cicada-applies-a-doc-aesthetic-to-its-fictionalized-same-sex-romance/" rel="bookmark" title="&#8216;Cicada&#8217; applies a doc aesthetic to its fictionalized same-sex romance">&#8216;Cicada&#8217; applies a doc aesthetic to its fictionalized same-sex romance</a></h3>            <div class="td-module-meta-info">
                <a href="https://freepressokc.com/category/cinema/" class="td-post-category">Cinema</a>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-04-01T22:10:16-05:00" >April 1, 2021</time></span>                            </div>
        </div>

        </div>

        
        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://freepressokc.com/museum-town-shows-how-art-transformed-a-new-england-industrial-center/" rel="bookmark" class="td-image-wrap " title="Museum Town shows how art transformed a New England industrial center" ><img width="100" height="70" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2021/03/museum_town_still-928x523-1-100x70.jpg"  srcset="https://freepressokc.com/wp-content/uploads/2021/03/museum_town_still-928x523-1-100x70.jpg 100w, https://freepressokc.com/wp-content/uploads/2021/03/museum_town_still-928x523-1-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="Museum Town" title="Museum Town shows how art transformed a New England industrial center" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/museum-town-shows-how-art-transformed-a-new-england-industrial-center/" rel="bookmark" title="Museum Town shows how art transformed a New England industrial center">Museum Town shows how art transformed a New England industrial center</a></h3>            <div class="td-module-meta-info">
                <a href="https://freepressokc.com/category/cinema/" class="td-post-category">Cinema</a>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-03-12T10:03:54-06:00" >March 12, 2021</time></span>                            </div>
        </div>

        </div>

                            </div>
                </div>

    <!--

        Theme: Newspaper by tagDiv.com 2020
        Version: 10.3.9.1 (rara)
        Deploy mode: deploy
        
        uid: 60791bcedfb4a
    -->

    <script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/adsanity-adblock-detection/public/js/ads.js?ver=1.1' id='adsanity_abd-ad-js'></script>
<script type='text/javascript' id='adsanity_abd-detector-js-extra'>
/* <![CDATA[ */
var adsanity_ad_block_vars = {"post_type":["post"],"behavior":"modal","warning_message":"<h2><span style=\"background-color: #ffffff;\">Our ads help provide the news to you FREE TO READ.<\/span><\/h2>\r\n<h2><span style=\"background-color: #ffffff;\">Please whitelist freepressokc.com in your ad-blocker.\u00a0<\/span><span style=\"background-color: #ffffff;\">Thank you!<\/span><\/h2>","warning_refresh":"Refresh page","redirect_page":"https:\/\/freepressokc.com\/ad-block-detection-notice\/","link_back":"Go back","redirect_page_id":"12110","mandatory_warning":"warning","warning_days":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/adsanity-adblock-detection/public/js/detector.js?ver=1.1' id='adsanity_abd-detector-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/worth-the-read/js/wtr.js?ver=5.7.1' id='wtr-js-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=a50385a2d79d6600973a7e697f735a0b' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3.9.1' id='td-site-min-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/comment-reply.min.js?ver=5.7.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=a50385a2d79d6600973a7e697f735a0b' id='tdb_js_files_for_front-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/wp-embed.min.js?ver=5.7.1' id='wp-embed-js'></script>

<!-- JS generated by theme -->

<script>
    
</script>


</body>
</html>