<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Oklahoma-shot Minari depicts an immigrant family’s life acclimating</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://freepressokc.com/xmlrpc.php" />
    <link rel="icon" type="image/png" href="https://freepressokc.com/wp-content/uploads/2016/09/cropped-FPlogo-single-png.png">
	<!-- This site is optimized with the Yoast SEO plugin v15.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="George Lang reviews a new film shot in Oklahoma about an immigrant family&#039;s experiences adjusting to life in the Midwest." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://freepressokc.com/oklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Oklahoma-shot Minari depicts an immigrant family’s life acclimating" />
	<meta property="og:description" content="George Lang reviews a new film shot in Oklahoma about an immigrant family&#039;s experiences adjusting to life in the Midwest." />
	<meta property="og:url" content="https://freepressokc.com/oklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating/" />
	<meta property="og:site_name" content="Oklahoma City Free Press" />
	<meta property="article:publisher" content="https://www.facebook.com/oklahomacityfreepress/" />
	<meta property="article:published_time" content="2021-02-26T01:03:25+00:00" />
	<meta property="article:modified_time" content="2021-02-26T03:15:56+00:00" />
	<meta property="og:image" content="https://freepressokc.com/wp-content/uploads/2021/02/Minari.jpg" />
	<meta property="og:image:width" content="745" />
	<meta property="og:image:height" content="419" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@freepressokc" />
	<meta name="twitter:site" content="@freepressokc" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="George Lang">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="3 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://freepressokc.com/#organization","name":"Oklahoma City Free Press LLC","url":"https://freepressokc.com/","sameAs":["https://www.facebook.com/oklahomacityfreepress/","https://www.instagram.com/freepressokc/?hl=en","https://www.youtube.com/channel/UCKnwaGON2-YbuX9-smgCafw","https://www.pinterest.com/oklahomacityfre/","https://twitter.com/freepressokc"],"logo":{"@type":"ImageObject","@id":"https://freepressokc.com/#logo","inLanguage":"en-US","url":"https://freepressokc.com/wp-content/uploads/2016/09/FPLogo-Nov1-black.png","width":543,"height":543,"caption":"Oklahoma City Free Press LLC"},"image":{"@id":"https://freepressokc.com/#logo"}},{"@type":"WebSite","@id":"https://freepressokc.com/#website","url":"https://freepressokc.com/","name":"Oklahoma City Free Press","description":"Local, independent, online news","publisher":{"@id":"https://freepressokc.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://freepressokc.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://freepressokc.com/oklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating/#primaryimage","inLanguage":"en-US","url":"https://freepressokc.com/wp-content/uploads/2021/02/Minari.jpg","width":745,"height":419},{"@type":"WebPage","@id":"https://freepressokc.com/oklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating/#webpage","url":"https://freepressokc.com/oklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating/","name":"Oklahoma-shot Minari depicts an immigrant family\u2019s life acclimating","isPartOf":{"@id":"https://freepressokc.com/#website"},"primaryImageOfPage":{"@id":"https://freepressokc.com/oklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating/#primaryimage"},"datePublished":"2021-02-26T01:03:25+00:00","dateModified":"2021-02-26T03:15:56+00:00","description":"George Lang reviews a new film shot in Oklahoma about an immigrant family's experiences adjusting to life in the Midwest.","breadcrumb":{"@id":"https://freepressokc.com/oklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://freepressokc.com/oklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating/"]}]},{"@type":"BreadcrumbList","@id":"https://freepressokc.com/oklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://freepressokc.com/","url":"https://freepressokc.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://freepressokc.com/oklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating/","url":"https://freepressokc.com/oklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating/","name":"Oklahoma-shot Minari depicts an immigrant family\u2019s life acclimating"}}]},{"@type":"Article","@id":"https://freepressokc.com/oklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating/#article","isPartOf":{"@id":"https://freepressokc.com/oklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating/#webpage"},"author":{"@id":"https://freepressokc.com/#/schema/person/6d3da654e3aac398a6e04d135ec5f1e9"},"headline":"Oklahoma-shot Minari depicts an immigrant family\u2019s life acclimating","datePublished":"2021-02-26T01:03:25+00:00","dateModified":"2021-02-26T03:15:56+00:00","mainEntityOfPage":{"@id":"https://freepressokc.com/oklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating/#webpage"},"publisher":{"@id":"https://freepressokc.com/#organization"},"image":{"@id":"https://freepressokc.com/oklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating/#primaryimage"},"keywords":"George Lang,Minari","articleSection":"Cinema,The Arts","inLanguage":"en-US"},{"@type":"Person","@id":"https://freepressokc.com/#/schema/person/6d3da654e3aac398a6e04d135ec5f1e9","name":"George Lang","image":{"@type":"ImageObject","@id":"https://freepressokc.com/#personlogo","inLanguage":"en-US","url":"https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1.jpg","caption":"George Lang"},"description":"George Lang has worked as an award-winning professional journalist in Oklahoma City for over 25 years. His work has been published in The Oklahoman, Oklahoma Gazette, 405 Magazine and others, and covers a wide range of subjects including politics, media, entertainment and others. George lives in Oklahoma City with his wife and son."}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Oklahoma City Free Press &raquo; Feed" href="https://freepressokc.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Oklahoma City Free Press &raquo; Comments Feed" href="https://freepressokc.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/freepressokc.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='adsanity-default-css-css'  href='https://freepressokc.com/wp-content/plugins/adsanity/dist/css/widget-default.css?ver=1.8' type='text/css' media='screen' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://freepressokc.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='adsanity-cas-css'  href='https://freepressokc.com/cas-custom-sizes/?ver=1.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='adsanity-vii-css'  href='https://freepressokc.com/wp-content/plugins/adsanity-vi-video-ads/public/dist/bundle.css?ver=1.4' type='text/css' media='all' />
<link rel='stylesheet' id='wtr-css-css'  href='https://freepressokc.com/wp-content/plugins/worth-the-read/css/wtr.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://freepressokc.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=c784b8db3e66cd68082f3ff7aa2d70e6' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Roboto+Slab%3A400%7CLato%3A400%7CRoboto%3A400%2C500%2C700%7COpen+Sans%3A400%2C600%2C700&#038;display=swap&#038;ver=10.3.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://freepressokc.com/wp-content/themes/childnewspaper7/style.css?ver=1.0' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='td-legacy-framework-front-style-css'  href='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=c784b8db3e66cd68082f3ff7aa2d70e6' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css'  href='https://freepressokc.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=6b62588d33477b8e3dc5b8b3c9c8d86c' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/includes/demos/politics/demo_style.css?ver=10.3.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css'  href='https://freepressokc.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=a50385a2d79d6600973a7e697f735a0b' type='text/css' media='all, print' />
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://freepressokc.com/wp-json/" /><link rel="alternate" type="application/json" href="https://freepressokc.com/wp-json/wp/v2/posts/12523" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://freepressokc.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://freepressokc.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6.2" />
<link rel='shortlink' href='https://freepressokc.com/?p=12523' />
<link rel="alternate" type="application/json+oembed" href="https://freepressokc.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffreepressokc.com%2Foklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://freepressokc.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffreepressokc.com%2Foklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating%2F&#038;format=xml" />
<style type="text/css">.wtr-time-wrap{ 
	/* wraps the entire label */
	margin: 0 10px;

}
.wtr-time-number{ 
	/* applies only to the number */
	
}</style><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
        <script>
        window.tdb_globals = {"wpRestNonce":"2a82b91e39","wpRestUrl":"https:\/\/freepressokc.com\/wp-json\/","permalinkStructure":"\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
    			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/freepressokc.com\/wp-admin\/","wpRestNonce":"2a82b91e39","wpRestUrl":"https:\/\/freepressokc.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>
			
<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-89779313-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-89779313-1');
</script>


<script>
(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
el = d.createElement('script');
el.id = "js-pp-banner";
el.src = "//dashboard.presspatron.com/dev/banner?b=pMamyM1ZSttVyfgPpMYw2zgS";
fjs.parentNode.insertBefore(el, fjs);
}(document));
</script>

<div id="pp-banner"></div>



<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://freepressokc.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://freepressokc.com/category/cinema/",
                    "name": "Cinema"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://freepressokc.com/oklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating/",
                    "name": "Oklahoma-shot Minari depicts an immigrant family’s life acclimating"                                
                }
            }    
        ]
    }
</script>
<link rel="icon" href="https://freepressokc.com/wp-content/uploads/2016/11/cropped-FPLogo-Nov1-white-32x32.png" sizes="32x32" />
<link rel="icon" href="https://freepressokc.com/wp-content/uploads/2016/11/cropped-FPLogo-Nov1-white-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://freepressokc.com/wp-content/uploads/2016/11/cropped-FPLogo-Nov1-white-180x180.png" />
<meta name="msapplication-TileImage" content="https://freepressokc.com/wp-content/uploads/2016/11/cropped-FPLogo-Nov1-white-270x270.png" />
<link rel="alternate" type="application/rss+xml" title="RSS" href="https://freepressokc.com/rsslatest.xml" /><style type="text/css" title="dynamic-css" class="options-output">.wtr-time-wrap{text-align:left;line-height:20px;font-weight:400;font-style:italic;color:#079603;font-size:14px;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading .wtr-time-wrap{opacity: 0;}.ie.wf-loading .wtr-time-wrap{visibility: hidden;}</style>
<!-- Button style compiled by theme -->

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #dd3333;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #dd3333;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #dd3333;
                }
                .tdm-btn-style1 {
					background-color: #dd3333;
				}
				.tdm-btn-style2:before {
				    border-color: #dd3333;
				}
				.tdm-btn-style2 {
				    color: #dd3333;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #dd3333;
                    -moz-box-shadow: 0 2px 16px #dd3333;
                    box-shadow: 0 2px 16px #dd3333;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #dd3333;
                    -moz-box-shadow: 0 4px 26px #dd3333;
                    box-shadow: 0 4px 26px #dd3333;
				}
</style>

	<style id="tdw-css-placeholder"></style></head>

<body class="post-template-default single single-post postid-12523 single-format-standard td-standard-pack oklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating global-block-template-1 td-politics single_template_3 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/oklahomacityfreepress/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/freepressokc" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="/cdn-cgi/l/email-protection#b2dbdcd4ddf2d4c0d7d7c2c0d7c1c1ddd9d19cd1dddf" title="Mail">
                <i class="td-icon-font td-icon-mail-1"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://freepressokc.com/feed/" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/freepressokc" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCKnwaGON2-YbuX9-smgCafw" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-8600" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-8600"><a href="https://freepressokc.com/category/health-and-covid-19/">Health and COVID-19</a></li>
<li id="menu-item-231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-231"><a href="https://freepressokc.com/category/politics/">Politics<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-10122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10122"><a href="https://freepressokc.com/category/protests/">Protests</a></li>
</ul>
</li>
<li id="menu-item-48" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48"><a href="https://freepressokc.com/category/government/">Government</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47"><a href="https://freepressokc.com/category/education/">Education</a></li>
<li id="menu-item-4328" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-4328"><a href="https://freepressokc.com/category/the-arts/">The Arts<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-416" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-416"><a href="https://freepressokc.com/category/cinema/">Cinema<i class="td-icon-menu-right td-element-after"></i></a>
	<ul class="sub-menu">
		<li id="menu-item-9394" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9394"><a href="https://freepressokc.com/category/cinema/deadcenter/">deadCenter Film Festival</a></li>
	</ul>
</li>
	<li id="menu-item-8423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8423"><a href="https://freepressokc.com/category/music/">Music</a></li>
</ul>
</li>
<li id="menu-item-46" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-46"><a href="https://freepressokc.com/category/cultures/">Cultures<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-7689" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7689"><a href="https://freepressokc.com/category/neighborhood-news/">Neighborhood news</a></li>
	<li id="menu-item-10452" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10452"><a href="https://freepressokc.com/category/seen-heard/">Seen and Heard</a></li>
</ul>
</li>
<li id="menu-item-45" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45"><a href="https://freepressokc.com/category/crime/">Crime</a></li>
<li id="menu-item-1033" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1033"><a href="https://freepressokc.com/category/business/">Business<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-50" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50"><a href="https://freepressokc.com/category/technology/">Technology</a></li>
</ul>
</li>
<li id="menu-item-7892" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-7892"><a href="https://freepressokc.com/category/opinion/">Opinion<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-10451" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10451"><a href="https://freepressokc.com/category/open-letters/">Open Letters</a></li>
	<li id="menu-item-7647" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7647"><a href="https://freepressokc.com/category/first-person/">First Person</a></li>
	<li id="menu-item-10449" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10449"><a href="https://freepressokc.com/category/editor-notes/">Editor&#8217;s Notes</a></li>
</ul>
</li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text">
	                <a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
	                </div>
	                <div class="td-login-register-link">
	                
	                </div>
	                
	                <div class="td-login-info-text"><a class="privacy-policy-link" href="https://freepressokc.com/privacy-statement/">Privacy Statement</a></div>

                </div>
            </div>

            
            
            
            
            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://freepressokc.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style 10
-->

<div class="td-header-wrap td-header-style-10 ">
    
            <div class="td-header-top-menu-full td-container-wrap ">
            <div class="td-container td-header-row td-header-top-menu">
                
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Friday, February 26, 2021
            </div>
        </div>
    <div class="menu-top-container"><ul id="menu-about-mission-and-goals-ad-pol" class="top-header-menu"><li id="menu-item-5465" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-5465"><a href="https://freepressokc.com/about/">About</a></li>
<li id="menu-item-5466" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-5466"><a href="https://freepressokc.com/mission-goals/">Mission and Goals</a></li>
<li id="menu-item-8933" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-8933"><a href="https://freepressokc.com/political-advertising-policy/">Political Advertising Policy</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
            <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>


        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://freepressokc.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    
    
        
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/oklahomacityfreepress/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/freepressokc" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="/cdn-cgi/l/email-protection#a8c1c6cec7e8cedacdcdd8dacddbdbc7c3cb86cbc7c5" title="Mail">
                <i class="td-icon-font td-icon-mail-1"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://freepressokc.com/feed/" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/freepressokc" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCKnwaGON2-YbuX9-smgCafw" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>    </div>    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <div class="td-login-wrap">
                        <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
	                        <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            
                            
                            
                            <div class="td-login-info-text"><a class="privacy-policy-link" href="https://freepressokc.com/privacy-statement/">Privacy Statement</a></div>
                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                        
                        
                    </div>
                </div>
                            </div>
        </div>
    
    <div class="td-banner-wrap-full td-logo-wrap-full  td-container-wrap ">
        <div class="td-header-sp-logo">
            		<div class="td-logo-text-wrap">
			<span class="td-logo-text-container">
				<a class="td-logo-wrap" href="https://freepressokc.com/">
											<span class="td-logo-text">Oklahoma City Free Press</span>
										<span class="td-tagline-text">Oklahoma City's award-winning independent, online news</span>
				</a>
			</span>
		</div>
	        </div>
    </div>

	<div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient td-header-menu-no-search">
			<div class="td-container td-header-row td-header-main-menu">
				<div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
            </div>
    <div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-8600"><a href="https://freepressokc.com/category/health-and-covid-19/">Health and COVID-19</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-231"><a href="https://freepressokc.com/category/politics/">Politics</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10122"><a href="https://freepressokc.com/category/protests/">Protests</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-48"><a href="https://freepressokc.com/category/government/">Government</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-47"><a href="https://freepressokc.com/category/education/">Education</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children td-menu-item td-normal-menu menu-item-4328"><a href="https://freepressokc.com/category/the-arts/">The Arts</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children td-menu-item td-normal-menu menu-item-416"><a href="https://freepressokc.com/category/cinema/">Cinema</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-9394"><a href="https://freepressokc.com/category/cinema/deadcenter/">deadCenter Film Festival</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-8423"><a href="https://freepressokc.com/category/music/">Music</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-46"><a href="https://freepressokc.com/category/cultures/">Cultures</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7689"><a href="https://freepressokc.com/category/neighborhood-news/">Neighborhood news</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10452"><a href="https://freepressokc.com/category/seen-heard/">Seen and Heard</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-45"><a href="https://freepressokc.com/category/crime/">Crime</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-1033"><a href="https://freepressokc.com/category/business/">Business</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-50"><a href="https://freepressokc.com/category/technology/">Technology</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-7892"><a href="https://freepressokc.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10451"><a href="https://freepressokc.com/category/open-letters/">Open Letters</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7647"><a href="https://freepressokc.com/category/first-person/">First Person</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10449"><a href="https://freepressokc.com/category/editor-notes/">Editor&#8217;s Notes</a></li>
</ul>
</li>
</ul></div></div>


    <div class="td-search-wrapper">
        <div id="td-top-search">
            <!-- Search -->
            <div class="header-search-wrap">
                <div class="dropdown header-search">
                    <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                </div>
            </div>
        </div>
    </div>
			</div>
		</div>
	</div>

    
</div>
            </div>

            
<article id="post-12523" class="td-post-template-3 post-12523 post type-post status-publish format-standard has-post-thumbnail category-cinema category-the-arts tag-george-lang tag-minari td-container-wrap" itemscope itemtype="https://schema.org/Article">
    <div class="td-post-header td-container">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://freepressokc.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Cinema" class="entry-crumb" href="https://freepressokc.com/category/cinema/">Cinema</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Oklahoma-shot Minari depicts an immigrant family’s life acclimating</span></div></div>
        <div class="td-post-header-holder td-image-gradient">
            <div class="td-post-featured-image"><a href="https://freepressokc.com/wp-content/uploads/2021/02/Minari.jpg" data-caption=""><img width="745" height="419" class="entry-thumb td-modal-image" src="https://freepressokc.com/wp-content/uploads/2021/02/Minari.jpg" srcset="https://freepressokc.com/wp-content/uploads/2021/02/Minari.jpg 745w, https://freepressokc.com/wp-content/uploads/2021/02/Minari-300x169.jpg 300w, https://freepressokc.com/wp-content/uploads/2021/02/Minari-696x391.jpg 696w" sizes="(max-width: 745px) 100vw, 745px" alt="" title="Minari"/></a></div>
            <header class="td-post-title">
                <ul class="td-category"><li class="entry-category"><a  href="https://freepressokc.com/category/cinema/">Cinema</a></li><li class="entry-category"><a  href="https://freepressokc.com/category/the-arts/">The Arts</a></li></ul>                <h1 class="entry-title">Oklahoma-shot Minari depicts an immigrant family’s life acclimating</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://freepressokc.com/author/george-lang/">George Lang</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-02-25T19:03:25-06:00" >February 25, 2021</time></span>                                                        </div>

            </header>
        </div>
    </div>

    <div class="td-container">
        <div class="td-pb-row">
                                <div class="td-pb-span8 td-main-content" role="main">
                        <div class="td-ss-main-content">
                            
    <div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
                                        <div class="td-social-but-icon"><i class="td-icon-share"></i></div>
                                        <div class="td-social-but-text">Share</div>
                                    </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffreepressokc.com%2Foklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Oklahoma-shot+Minari+depicts+an+immigrant+family%E2%80%99s+life+acclimating&url=https%3A%2F%2Ffreepressokc.com%2Foklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating%2F&via=freepressokc">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#9ea1edebfcf4fbfdeaa3d1f5f2fff6f1f3ffb3edf6f1eabed3f7f0ffecf7befafbeef7fdeaedbefff0bef7f3f3f7f9ecfff0eabef8fff3f7f2e77c1e07edbef2f7f8fbbefffdfdf2f7f3ffeaf7f0f9b8fcf1fae7a3f6eaeaeeeda4b1b1f8ecfbfbeeecfbededf1f5fdb0fdf1f3b1f1f5f2fff6f1f3ffb3edf6f1eab3f3f7f0ffecf7b3fafbeef7fdeaedb3fff0b3f7f3f3f7f9ecfff0eab3f8fff3f7f2e7edb3f2f7f8fbb3fffdfdf2f7f3ffeaf7f0f9b1">
                                        <div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
                                        <div class="td-social-but-text">Email</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#">
                                        <div class="td-social-but-icon"><i class="td-icon-print"></i></div>
                                        <div class="td-social-but-text">Print</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>
    <div class="td-post-content tagdiv-type">
        <span class="wtr-time-wrap before-content"><span class="wtr-time-number">3</span> minute read</span><div id="wtr-content" 
	    	data-bg="#FFFFFF" 
	    	data-fg="#f44813" 
	    	data-width="5" 
	    	data-mute="" 
	    	data-fgopacity="0.5" 
	    	data-mutedopacity="0.5" 
	    	data-placement="left" 
	    	data-placement-offset="0" 
	    	data-content-offset="0" 
	    	data-placement-touch="left" 
		    data-placement-offset-touch="0" 
	    	data-transparent="" 
	    	data-shadow="1" 
	    	data-touch="1" 
	    	data-non-touch="1" 
	    	data-comments="0" 
	    	data-commentsbg="#ffcece" 
	    	data-location="page" 
	    	data-mutedfg="#f44813" 
	    	data-endfg="#f44813" 
	    	data-rtl="" 
	    	>
<div id="ad-12268" class="ad-728x90 adsanity-728x90 aligncenter adsanity-aligncenter"style="max-width:1280px"><div class="adsanity-inner">

	<a rel="nofollow" href="https://freepressokc.com/ads/true-sky-leaderboard/"  target="_blank"><img width="1281" height="181" src="https://freepressokc.com/wp-content/uploads/2021/02/TrueSky-747-Digital-Ads-02.jpg" class="no-lazy-load wp-post-image" alt="" loading="normal" srcset="https://freepressokc.com/wp-content/uploads/2021/02/TrueSky-747-Digital-Ads-02.jpg 1281w, https://freepressokc.com/wp-content/uploads/2021/02/TrueSky-747-Digital-Ads-02-300x42.jpg 300w, https://freepressokc.com/wp-content/uploads/2021/02/TrueSky-747-Digital-Ads-02-1024x145.jpg 1024w, https://freepressokc.com/wp-content/uploads/2021/02/TrueSky-747-Digital-Ads-02-768x109.jpg 768w, https://freepressokc.com/wp-content/uploads/2021/02/TrueSky-747-Digital-Ads-02-696x98.jpg 696w, https://freepressokc.com/wp-content/uploads/2021/02/TrueSky-747-Digital-Ads-02-1068x151.jpg 1068w" sizes="(max-width: 1281px) 100vw, 1281px" /></a>
</div></div>




<p>With its pastoral imagery, beautifully nuanced performances and specific emotional details about the Korean immigrant experience in rural America, Lee Isaac Chung’s semi-autobiographical <em>Minari</em> depicts one family coming to terms with compounded culture shock as it attempts to build a life in western Arkansas.&nbsp;</p>



<p>Jacob and Monica Yi (Steven Yeun and Yeri Han) are a few years into their American experiment, having spent time working on California chicken farms. In search of opportunity outside of factory farms, they take their young children Anne and David (Noel Cho and Alan Kim) to a sun-soaked meadow in the middle of nowhere.</p>



<div class="wp-block-media-text alignwide has-media-on-the-right is-stacked-on-mobile" style="grid-template-columns:auto 20%"><figure class="wp-block-media-text__media"><img loading="lazy" width="1024" height="1024" src="https://freepressokc.com/wp-content/uploads/2020/01/DSC09075-1-1024x1024.jpg" alt="cinema film" class="wp-image-7917 size-full" srcset="https://freepressokc.com/wp-content/uploads/2020/01/DSC09075-1-1024x1024.jpg 1024w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09075-1-300x300.jpg 300w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09075-1-150x150.jpg 150w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09075-1-768x768.jpg 768w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09075-1-696x696.jpg 696w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09075-1-1068x1068.jpg 1068w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09075-1-420x420.jpg 420w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09075-1.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure><div class="wp-block-media-text__content">
<blockquote class="wp-block-quote"><p><em><strong><span class="has-inline-color has-vivid-red-color">Music and film</span></strong></em></p><cite>by George Lang</cite></blockquote>



<p class="has-text-align-center">Sponsored by <a href="https://trueskycu.org"><strong>True Sky Credit Union</strong></a></p>
</div></div>



<p>Both Monica and Jacob go to work “sexing” baby chickens — separating the genders — but Jacob’s heart is not in such tedious work. He wants to grow crops in the dry dirt of his property, and his efforts to find a reliable water source are coming up short. In the way he carries himself with a western amble yet wants to farm the “Korean way,” Jacob is between two worlds, trying to tell how much he wants to keep from each culture. Monica is far less sure of this entire venture and acts as though this new life in America is not going to plan.&nbsp;</p>



<p>Shot near Tulsa and featuring performances by strong Oklahoma actors like Ben Hall, Darryl Cox and Eric Starkey, <em>Minari</em> exhibits all the visual and tonal earmarks of an early Terrence Malick film, with Chung soaking in the rural sunlight that illuminates everything while drying the land. As Malick did in early films like <em>Badlands</em>, Chung proves adept at balancing the family’s struggle with both humor and humanity.&nbsp;</p>



<p>Much of that humor comes from Grandmother Soonja (Yuh-jung Youn), who arrives at the family’s mobile home to help with the children. She comes directly from Korea, and Anne and David are never sure what to think of this boisterously profane old lady who brings unusual foods and smells into the household, but also a chaotic combination of strength and burdens. If Soonja represents the tug of the familiar, the family’s new environment and newfound relationships are exerting just as much pull, perhaps more.&nbsp;</p>



<div id="ad-12265" class="ad-300x250 adsanity-300x250 aligncenter adsanity-aligncenter"><div class="adsanity-inner">

	<a rel="nofollow" href="https://freepressokc.com/ads/true-sky-post-body/"  target="_blank"><img width="300" height="250" src="https://freepressokc.com/wp-content/uploads/2021/02/TrueSky-747-Digital-Ads-01.jpg" class="no-lazy-load wp-post-image" alt="" loading="normal" /></a>
</div></div>




<p>There are plenty of reasons why the Yis might not make it, including a medical condition that could draw them into a semi-forced life in the city, but then they have more support from their new neighbors than they could have imagined at first. This is especially true of Paul, played by veteran character actor Will Patton. Paul, a Pentecostal prone to speaking in tongues as part of his conversations with God, insinuates himself into the Yis’ life as a farmworker and becomes something of a caretaker for the family.&nbsp;</p>



<p>Ultimately, <em>Minari </em>works because the actors are beautifully on point, especially Yeun and Hari. While Yeun is likely to be the most familiar face on screen after spending years on AMC’s <em>The Walking Dead</em> as Glenn, one of the most beloved characters in the series, both actors succeed in maintaining tension throughout the story. There’s no question of the couple’s love, but the family’s situation is fragile, and it comes through in the actors’ palpable depiction of ever-present stress.</p>



<p><em>Minari</em> is a fine example of a small-budget Oklahoma production ticking all the artistic boxes, and the critical raves will hopefully attract more productions of its type. Chung, who grew up under similar circumstances as young David in the film, has yet to land on a specific style and is currently remaking the 2016 <em>anime</em> film <em>Your Name</em>, but <em>Minari</em> is a true breakout film for this gifted director, and Oklahoma’s supporting role in this quiet wonder hopefully bodes well for films of equal artistry.&nbsp;</p>



<p><em>Minari </em>is currently showing at <a href="https://www.towertheatreokc.com">Tower Theatre</a>, <a href="https://www.rodeocinema.org">Rodeo Cinema</a>, and <a href="https://www.okcmoa.com\">Oklahoma City Museum of Art</a>, with virtual screenings available through all three. For more information, go to <a href="https://tickets.minari.movie">tickets.minari.movie</a>.</p>



<p><strong>Next week: </strong>For next Friday’s Film and Music column, I will be introducing a weekly five-point list of recommendations for your weekend entertainment, showcasing live shows, album debuts, and films worth seeing on opening night.&nbsp;</p>



<hr>
<h3><strong>Sustain our journalism by becoming a supporter<br></strong></h3>
<p>Oklahoma City Free Press is dedicated to providing high quality journalism that positively impacts our community. Click this <a href="https://dashboard.presspatron.com/donations/new?frame=1&amp;t=pMamyM1ZSttVyfgPpMYw2zgS">link</a>to support our mission.</p>
<div class="pp-donate-button"></div>
<hr>
</div>    </div>


    <footer>
                
        <div class="td-post-source-tags">
                        <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://freepressokc.com/tag/george-lang/">George Lang</a></li><li><a href="https://freepressokc.com/tag/minari/">Minari</a></li></ul>        </div>

        <div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
                                        <div class="td-social-but-icon"><i class="td-icon-share"></i></div>
                                        <div class="td-social-but-text">Share</div>
                                    </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffreepressokc.com%2Foklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Oklahoma-shot+Minari+depicts+an+immigrant+family%E2%80%99s+life+acclimating&url=https%3A%2F%2Ffreepressokc.com%2Foklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating%2F&via=freepressokc">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#19266a6c7b737c7a6d245672757871767478346a71766d39547077786b70397d7c69707a6d6a39787739707474707e6b78776d397f7874707560fb99806a3975707f7c39787a7a757074786d70777e3f7b767d6024716d6d696a2336367f6b7c7c696b7c6a6a76727a377a7674367672757871767478346a71766d34747077786b70347d7c69707a6d6a34787734707474707e6b78776d347f78747075606a3475707f7c34787a7a757074786d70777e36">
                                        <div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
                                        <div class="td-social-but-text">Email</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#">
                                        <div class="td-social-but-icon"><i class="td-icon-print"></i></div>
                                        <div class="td-social-but-text">Print</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>        <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://freepressokc.com/lankford-is-purposely-sowing-disinformation-about-the-january-6-attacks/">Lankford is purposely sowing disinformation about the January 6 attacks</a></div></div><div class="td-next-prev-separator"></div></div>        <div class="author-box-wrap"><a href="https://freepressokc.com/author/george-lang/"><img src="https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-150x150.jpg" width="96" height="96" alt="George Lang" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://freepressokc.com/author/george-lang/">George Lang</a></span></div><div class="td-author-description">George Lang has worked as an award-winning professional journalist in Oklahoma City for over 25 years. His work has been published in The Oklahoman, Oklahoma Gazette, 405 Magazine and others, and covers a wide range of subjects including politics, media, entertainment and others. George lives in Oklahoma City with his wife and son.</div><div class="td-author-social"></div><div class="clearfix"></div></div></div>        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="George Lang"></span><meta itemprop="datePublished" content="2021-02-25T19:03:25-06:00"><meta itemprop="dateModified" content="2021-02-25T21:15:56-06:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://freepressokc.com/oklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://freepressokc.com/oklahoma-shot-minari-depicts-an-immigrant-familys-life-acclimating/"></span><meta itemprop="name" content="Oklahoma City Free Press"></span><meta itemprop="headline " content="Oklahoma-shot Minari depicts an immigrant family’s life acclimating"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://freepressokc.com/wp-content/uploads/2021/02/Minari.jpg"><meta itemprop="width" content="745"><meta itemprop="height" content="419"></span>    </footer>

    <div class="td_block_wrap td_block_related_posts tdi_2_850 td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_2_850" ><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_2_850 = new tdBlock();
block_tdi_2_850.id = "tdi_2_850";
block_tdi_2_850.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_tags","td_ajax_filter_type":"td_custom_related","class":"tdi_2_850","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":12523,"live_filter_cur_post_author":"339","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_2_850","tdc_css_class_style":"tdi_2_850_rand_style"}';
block_tdi_2_850.td_column_number = "3";
block_tdi_2_850.block_type = "td_block_related_posts";
block_tdi_2_850.post_count = "3";
block_tdi_2_850.found_posts = "3";
block_tdi_2_850.header_color = "";
block_tdi_2_850.ajax_pagination_infinite_stop = "";
block_tdi_2_850.max_num_pages = "1";
tdBlocksArray.push(block_tdi_2_850);
</script><h4 class="td-related-title td-block-title"><a id="tdi_3_6a3" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_2_850" href="#">RELATED ARTICLES</a><a id="tdi_4_666" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_2_850" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_2_850 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://freepressokc.com/our-top-ten-opinion-posts-of-2020-exposed-bad-thinking-in-government/" rel="bookmark" class="td-image-wrap " title="Our top ten OPINION posts of 2020 exposed bad thinking in government" ><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2020/01/DSC09080-218x150.jpg"  srcset="https://freepressokc.com/wp-content/uploads/2020/01/DSC09080-218x150.jpg 218w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09080-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px"  alt="George Lang opinion" title="Our top ten OPINION posts of 2020 exposed bad thinking in government" /></a></div>                <a href="https://freepressokc.com/category/editor-notes/" class="td-post-category">Editor's Notes</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/our-top-ten-opinion-posts-of-2020-exposed-bad-thinking-in-government/" rel="bookmark" title="Our top ten OPINION posts of 2020 exposed bad thinking in government">Our top ten OPINION posts of 2020 exposed bad thinking in government</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://freepressokc.com/break-out-of-your-algorithm-with-fresh-views-on-major-streaming-services/" rel="bookmark" class="td-image-wrap " title="Break out of your algorithm with fresh views on major streaming services" ><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2020/04/devs_031-h_2020-218x150.jpg"  srcset="https://freepressokc.com/wp-content/uploads/2020/04/devs_031-h_2020-218x150.jpg 218w, https://freepressokc.com/wp-content/uploads/2020/04/devs_031-h_2020-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px"  alt="" title="Break out of your algorithm with fresh views on major streaming services" /></a></div>                <a href="https://freepressokc.com/category/cinema/" class="td-post-category">Cinema</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/break-out-of-your-algorithm-with-fresh-views-on-major-streaming-services/" rel="bookmark" title="Break out of your algorithm with fresh views on major streaming services">Break out of your algorithm with fresh views on major streaming services</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://freepressokc.com/what-if-we-expanded-our-cinema-coverage-youre-about-to-find-out/" rel="bookmark" class="td-image-wrap " title="What if we expanded our cinema coverage? You&#8217;re about to find out!" ><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2019/12/Computer-coffee-218x150-1.jpg"  srcset="https://freepressokc.com/wp-content/uploads/2019/12/Computer-coffee-218x150-1.jpg 218w, https://freepressokc.com/wp-content/uploads/2019/12/Computer-coffee-100x70-1.jpg 100w" sizes="(max-width: 218px) 100vw, 218px"  alt="" title="What if we expanded our cinema coverage? You&#8217;re about to find out!" /></a></div>                <a href="https://freepressokc.com/category/editor-notes/" class="td-post-category">Editor's Notes</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/what-if-we-expanded-our-cinema-coverage-youre-about-to-find-out/" rel="bookmark" title="What if we expanded our cinema coverage? You&#8217;re about to find out!">What if we expanded our cinema coverage? You&#8217;re about to find out!</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_2_850" data-td_block_id="tdi_2_850"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page ajax-page-disabled" id="next-page-tdi_2_850" data-td_block_id="tdi_2_850"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
                        </div>
                    </div>
                    <div class="td-pb-span4 td-main-sidebar" role="complementary">
                        <div class="td-ss-main-sidebar">
                                                    </div>
                    </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</article> <!-- /.post -->

<!-- Instagram -->

	
	
            <div class="tdc-footer-wrap ">

                <!-- Footer -->
				<div class="td-footer-wrapper td-footer-container td-container-wrap ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span12">
                            </div>
        </div>
    </div>

    <div class="td-footer-bottom-full">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://freepressokc.com/"><img src="https://freepressokc.com/wp-content/uploads/2016/11/FPLogo-Nov1-white-150x150.png" alt="Oklahoma City Free Press" title="Oklahoma City Free Press"/></a></aside></div><div class="td-pb-span9"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div><hr>
<p><strong>Sustain our journalism by becoming a supporter<br></strong></p>
<p>Oklahoma City Free Press is dedicated to providing high quality journalism that positively impacts our community. We give voice to those who aren’t heard and expose that which is hidden from the public. Click this <a href="https://pp-staging.presspatron.com/donations/new?frame=1&t=VuVQRxLy7UcJsBNvasA5tDAz">link</a> or the red button below to support our mission.</p>
<div class="pp-donate-button"> </div>
<hr>

Published by Oklahoma City Free Press LLC, Oklahoma City, Oklahoma -- Publisher and Editor - Brett Dickerson. All photography and content is under copyright. We adhere to the Society of Professional Journalists Code of Ethics.</aside></div>            </div>
        </div>
    </div>
</div>
                <!-- Sub Footer -->
				    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-sub-footer-material-container"><ul id="menu-sub-footer-material" class="td-subfooter-menu"><li id="menu-item-28" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-28"><a href="https://freepressokc.com/terms-copyright-and-conditions/">Terms, copyright, and conditions</a></li>
<li id="menu-item-31" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy td-menu-item td-normal-menu menu-item-31"><a href="https://freepressokc.com/privacy-statement/">Privacy Statement</a></li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; Oklahoma City Free Press LLC, 2016, 2017, 2018, 2019, 2020.    <a href="//www.dmca.com/Protection/Status.aspx?ID=64fb634b-962d-4e3b-93ec-bed7c5a4d8ec" title="DMCA.com Protection Status" class="dmca-badge"> <img src="//images.dmca.com/Badges/dmca-badge-w100-5x1-11.png?ID=64fb634b-962d-4e3b-93ec-bed7c5a4d8ec" alt="DMCA.com Protection Status"></a> <script src="//images.dmca.com/Badges/DMCABadgeHelper.min.js"> </script>                </div>
            </div>
        </div>
    </div>
            </div><!--close td-footer-wrap-->
			
</div><!--close td-outer-wrap-->



			<script type="text/javascript">
				var _paq = _paq || [];
					_paq.push(['setCustomDimension', 1, '{"ID":339,"name":"George Lang","avatar":"98880de19d53fb7944f3dcaa708a875d"}']);
				_paq.push(['trackPageView']);
								(function () {
					var u = "https://stats1.wpmudev.com/";
					_paq.push(['setTrackerUrl', u + 'track/']);
					_paq.push(['setSiteId', '22896']);
					var d   = document, g = d.createElement('script'), s = d.getElementsByTagName('script')[0];
					g.type  = 'text/javascript';
					g.async = true;
					g.defer = true;
					g.src   = 'https://stats.wpmucdn.com/analytics.js';
					s.parentNode.insertBefore(g, s);
				})();
			</script>
			                <div class="td-more-articles-box">
                    <i class="td-icon-close td-close-more-articles-box"></i>
                    <span class="td-more-articles-box-title">MORE STORIES</span>
                    <div class="td-content-more-articles-box">

                    
        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://freepressokc.com/our-top-ten-opinion-posts-of-2020-exposed-bad-thinking-in-government/" rel="bookmark" class="td-image-wrap " title="Our top ten OPINION posts of 2020 exposed bad thinking in government" ><img width="100" height="70" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2020/01/DSC09080-100x70.jpg"  srcset="https://freepressokc.com/wp-content/uploads/2020/01/DSC09080-100x70.jpg 100w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09080-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="George Lang opinion" title="Our top ten OPINION posts of 2020 exposed bad thinking in government" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/our-top-ten-opinion-posts-of-2020-exposed-bad-thinking-in-government/" rel="bookmark" title="Our top ten OPINION posts of 2020 exposed bad thinking in government">Our top ten OPINION posts of 2020 exposed bad thinking in...</a></h3>            <div class="td-module-meta-info">
                <a href="https://freepressokc.com/category/editor-notes/" class="td-post-category">Editor's Notes</a>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-12-31T14:05:08-06:00" >December 31, 2020</time></span>                            </div>
        </div>

        </div>

        
        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://freepressokc.com/break-out-of-your-algorithm-with-fresh-views-on-major-streaming-services/" rel="bookmark" class="td-image-wrap " title="Break out of your algorithm with fresh views on major streaming services" ><img width="100" height="70" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2020/04/devs_031-h_2020-100x70.jpg"  srcset="https://freepressokc.com/wp-content/uploads/2020/04/devs_031-h_2020-100x70.jpg 100w, https://freepressokc.com/wp-content/uploads/2020/04/devs_031-h_2020-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Break out of your algorithm with fresh views on major streaming services" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/break-out-of-your-algorithm-with-fresh-views-on-major-streaming-services/" rel="bookmark" title="Break out of your algorithm with fresh views on major streaming services">Break out of your algorithm with fresh views on major streaming...</a></h3>            <div class="td-module-meta-info">
                <a href="https://freepressokc.com/category/cinema/" class="td-post-category">Cinema</a>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-04-03T08:51:02-05:00" >April 3, 2020</time></span>                            </div>
        </div>

        </div>

                            </div>
                </div>

    <!--

        Theme: Newspaper by tagDiv.com 2020
        Version: 10.3.9.1 (rara)
        Deploy mode: deploy
        
        uid: 6038a5a6f2f8a
    -->

    <script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/adsanity-adblock-detection/public/js/ads.js?ver=1.1' id='adsanity_abd-ad-js'></script>
<script type='text/javascript' id='adsanity_abd-detector-js-extra'>
/* <![CDATA[ */
var adsanity_ad_block_vars = {"post_type":["post"],"behavior":"modal","warning_message":"<h2><span style=\"background-color: #ffffff;\">Our ads help provide the news to you FREE TO READ.<\/span><\/h2>\r\n<h2><span style=\"background-color: #ffffff;\">Please whitelist freepressokc.com in your ad-blocker.\u00a0<\/span><span style=\"background-color: #ffffff;\">Thank you!<\/span><\/h2>","warning_refresh":"Refresh page","redirect_page":"https:\/\/freepressokc.com\/ad-block-detection-notice\/","link_back":"Go back","redirect_page_id":"12110","mandatory_warning":"warning","warning_days":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/adsanity-adblock-detection/public/js/detector.js?ver=1.1' id='adsanity_abd-detector-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/worth-the-read/js/wtr.js?ver=5.6.2' id='wtr-js-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=a50385a2d79d6600973a7e697f735a0b' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3.9.1' id='td-site-min-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/comment-reply.min.js?ver=5.6.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=a50385a2d79d6600973a7e697f735a0b' id='tdb_js_files_for_front-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/wp-embed.min.js?ver=5.6.2' id='wp-embed-js'></script>

<!-- JS generated by theme -->

<script>
    
</script>


</body>
</html>