<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>I am sorry for the times I have been silent</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://freepressokc.com/xmlrpc.php" />
    <style>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</style>
<link rel="icon" type="image/png" href="https://freepressokc.com/wp-content/uploads/2016/09/cropped-FPlogo-single-png.png">
	<!-- This site is optimized with the Yoast SEO plugin v14.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Silence is acceptance. I am sorry for the times I have been silent. Silence is acceptance. I am sorry for the times I have been silent." />
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="First Person: &quot;I am sorry for the times I have been silent&quot;" />
	<meta property="og:description" content="Silence is acceptance. I am sorry for the times I have been silent. Silence is acceptance. I am sorry for the times I have been silent." />
	<meta property="og:url" content="https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/" />
	<meta property="og:site_name" content="Oklahoma City Free Press" />
	<meta property="article:publisher" content="https://www.facebook.com/oklahomacityfreepress/" />
	<meta property="article:published_time" content="2020-05-30T22:30:31+00:00" />
	<meta property="article:modified_time" content="2020-05-30T22:54:42+00:00" />
	<meta property="og:image" content="https://freepressokc.com/wp-content/uploads/2020/02/DSC_0229.jpg" />
	<meta property="og:image:width" content="800" />
	<meta property="og:image:height" content="450" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@freepressokc" />
	<meta name="twitter:site" content="@freepressokc" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://freepressokc.com/#organization","name":"Oklahoma City Free Press LLC","url":"https://freepressokc.com/","sameAs":["https://www.facebook.com/oklahomacityfreepress/","https://www.instagram.com/freepressokc/?hl=en","https://www.youtube.com/channel/UCKnwaGON2-YbuX9-smgCafw","https://www.pinterest.com/oklahomacityfre/","https://twitter.com/freepressokc"],"logo":{"@type":"ImageObject","@id":"https://freepressokc.com/#logo","inLanguage":"en-US","url":"https://freepressokc.com/wp-content/uploads/2016/09/FPLogo-Nov1-black.png","width":543,"height":543,"caption":"Oklahoma City Free Press LLC"},"image":{"@id":"https://freepressokc.com/#logo"}},{"@type":"WebSite","@id":"https://freepressokc.com/#website","url":"https://freepressokc.com/","name":"Oklahoma City Free Press","description":"Local, independent, online news","publisher":{"@id":"https://freepressokc.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://freepressokc.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/#primaryimage","inLanguage":"en-US","url":"https://freepressokc.com/wp-content/uploads/2020/02/DSC_0229.jpg","width":800,"height":450,"caption":"Students at NW Classen High School listen to student speakers at a protest against a beloved teacher being disciplined. (file, Brett Dickerson/Okla City Free Press)"},{"@type":"WebPage","@id":"https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/#webpage","url":"https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/","name":"I am sorry for the times I have been silent","isPartOf":{"@id":"https://freepressokc.com/#website"},"primaryImageOfPage":{"@id":"https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/#primaryimage"},"datePublished":"2020-05-30T22:30:31+00:00","dateModified":"2020-05-30T22:54:42+00:00","description":"Silence is acceptance. I am sorry for the times I have been silent. Silence is acceptance. I am sorry for the times I have been silent.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/"]}]},{"@type":"Article","@id":"https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/#article","isPartOf":{"@id":"https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/#webpage"},"author":{"@id":"https://freepressokc.com/#/schema/person/0ca332c52740b6627b28ef41cec31477"},"headline":"I am sorry for the times I have been silent","datePublished":"2020-05-30T22:30:31+00:00","dateModified":"2020-05-30T22:54:42+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/#webpage"},"publisher":{"@id":"https://freepressokc.com/#organization"},"image":{"@id":"https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/#primaryimage"},"keywords":"Black Lives Matter,Black Lives Matter OKC,Silence","articleSection":"First Person","inLanguage":"en-US"},{"@type":["Person"],"@id":"https://freepressokc.com/#/schema/person/0ca332c52740b6627b28ef41cec31477","name":"Free Press Guest Contributor","image":{"@type":"ImageObject","@id":"https://freepressokc.com/#personlogo","inLanguage":"en-US","url":"https://freepressokc.com/wp-content/uploads/2016/09/FPLogo-Nov1-black.png","caption":"Free Press Guest Contributor"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Oklahoma City Free Press &raquo; Feed" href="https://freepressokc.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Oklahoma City Free Press &raquo; Comments Feed" href="https://freepressokc.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/freepressokc.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://freepressokc.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='wtr-css-css'  href='https://freepressokc.com/wp-content/plugins/worth-the-read/css/wtr.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://freepressokc.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=28832a33217c23aa6f76cdf3fc3c1388' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Roboto+Slab%3A400%7CLato%3A400%7CRoboto%3A400%2C500%2C700%7COpen+Sans%3A400%2C600%2C700&#038;display=swap&#038;ver=10.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://freepressokc.com/wp-content/themes/childnewspaper7/style.css?ver=1.0' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='js_composer_front-css'  href='https://freepressokc.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=4.12.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-legacy-framework-front-style-css'  href='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=28832a33217c23aa6f76cdf3fc3c1388' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css'  href='https://freepressokc.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=e06dc97a9cdcc3f12ae1599dfcd5b98f' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/includes/demos/politics/demo_style.css?ver=10.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css'  href='https://freepressokc.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=243b277d395aac11337949f2c0b8e89c' type='text/css' media='all' />
<link rel='stylesheet' id='stbCoreCSS-css'  href='https://freepressokc.com/wp-content/plugins/wp-special-textboxes/css/stb-core.css?ver=5.9.109' type='text/css' media='all' />
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://freepressokc.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://freepressokc.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://freepressokc.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.1" />
<link rel='shortlink' href='https://freepressokc.com/?p=9245' />
<link rel="alternate" type="application/json+oembed" href="https://freepressokc.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffreepressokc.com%2Fi-am-sorry-for-the-times-i-have-been-silent%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://freepressokc.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffreepressokc.com%2Fi-am-sorry-for-the-times-i-have-been-silent%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.8.2 Professional to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<style type="text/css">.wtr-time-wrap{ 
	/* wraps the entire label */
	margin: 0 10px;

}
.wtr-time-number{ 
	/* applies only to the number */
	
}</style>		<script>
			document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );
		</script>
				<style>
			.no-js img.lazyload { display: none; }
			figure.wp-block-image img.lazyloading { min-width: 150px; }
							.lazyload, .lazyloading { opacity: 0; }
				.lazyloaded {
					opacity: 1;
					transition: opacity 400ms;
					transition-delay: 0ms;
				}
					</style>
		<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
        <script>
        window.tdb_globals = {"wpRestNonce":"f7f3ec4554","wpRestUrl":"https:\/\/freepressokc.com\/wp-json\/","permalinkStructure":"\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
    			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/freepressokc.com\/wp-admin\/","wpRestNonce":"f7f3ec4554","wpRestUrl":"https:\/\/freepressokc.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>
			<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://freepressokc.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://freepressokc.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-89779313-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-89779313-1');
</script>

<script>
(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
	el = d.createElement('script');
	el.id = "js-pp-banner";
	el.src = "//dashboard.presspatron.com/dev/banner?b=pMamyM1ZSttVyfgPpMYw2zgS";
	fjs.parentNode.insertBefore(el, fjs);
}(document));
</script>

<script data-ad-client="ca-pub-9036516646200639" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<div id="pp-banner"></div>


<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://freepressokc.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://freepressokc.com/category/first-person/",
                    "name": "First Person"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/",
                    "name": "I am sorry for the times I have been silent"                                
                }
            }    
        ]
    }
</script>
<link rel="icon" href="https://freepressokc.com/wp-content/uploads/2016/11/cropped-FPLogo-Nov1-white-32x32.png" sizes="32x32" />
<link rel="icon" href="https://freepressokc.com/wp-content/uploads/2016/11/cropped-FPLogo-Nov1-white-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://freepressokc.com/wp-content/uploads/2016/11/cropped-FPLogo-Nov1-white-180x180.png" />
<meta name="msapplication-TileImage" content="https://freepressokc.com/wp-content/uploads/2016/11/cropped-FPLogo-Nov1-white-270x270.png" />
<link rel="alternate" type="application/rss+xml" title="RSS" href="https://freepressokc.com/rsslatest.xml" /><style type="text/css" title="dynamic-css" class="options-output">.wtr-time-wrap{text-align:left;line-height:20px;font-weight:400;font-style:italic;color:#079603;font-size:14px;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading .wtr-time-wrap,{opacity: 0;}.ie.wf-loading .wtr-time-wrap,{visibility: hidden;}</style>
<!-- Button style compiled by theme -->

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #dd3333;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #dd3333;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #dd3333;
                }
                .tdm-btn-style1 {
					background-color: #dd3333;
				}
				.tdm-btn-style2:before {
				    border-color: #dd3333;
				}
				.tdm-btn-style2 {
				    color: #dd3333;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #dd3333;
                    -moz-box-shadow: 0 2px 16px #dd3333;
                    box-shadow: 0 2px 16px #dd3333;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #dd3333;
                    -moz-box-shadow: 0 4px 26px #dd3333;
                    box-shadow: 0 4px 26px #dd3333;
				}
</style>

<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>	<style id="tdw-css-placeholder"></style></head>

<body class="post-template-default single single-post postid-9245 single-format-standard td-standard-pack i-am-sorry-for-the-times-i-have-been-silent global-block-template-1 td-politics single_template_3 wpb-js-composer js-comp-ver-4.12.1 vc_responsive td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/oklahomacityfreepress/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/freepressokc/?hl=en" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="mailto:info@freepressokc.com" title="Mail">
                <i class="td-icon-font td-icon-mail-1"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://freepressokc.com/feed/" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/freepressokc" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCKnwaGON2-YbuX9-smgCafw" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-8600" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-8600"><a href="https://freepressokc.com/category/health-and-covid-19/">Health and COVID-19</a></li>
<li id="menu-item-231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-231"><a href="https://freepressokc.com/category/politics/">Politics</a></li>
<li id="menu-item-48" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48"><a href="https://freepressokc.com/category/government/">Government</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47"><a href="https://freepressokc.com/category/education/">Education</a></li>
<li id="menu-item-416" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-416"><a href="https://freepressokc.com/category/cinema/">Cinema</a></li>
<li id="menu-item-8423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8423"><a href="https://freepressokc.com/category/music/">Music</a></li>
<li id="menu-item-4328" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4328"><a href="https://freepressokc.com/category/the-arts/">The Arts</a></li>
<li id="menu-item-46" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46"><a href="https://freepressokc.com/category/cultures/">Cultures</a></li>
<li id="menu-item-7689" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7689"><a href="https://freepressokc.com/category/neighborhood-news/">Neighborhood news</a></li>
<li id="menu-item-50" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50"><a href="https://freepressokc.com/category/technology/">Technology</a></li>
<li id="menu-item-45" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45"><a href="https://freepressokc.com/category/crime/">Crime</a></li>
<li id="menu-item-1033" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1033"><a href="https://freepressokc.com/category/business/">Business</a></li>
<li id="menu-item-7647" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-7647"><a href="https://freepressokc.com/category/first-person/">First Person</a></li>
<li id="menu-item-7892" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7892"><a href="https://freepressokc.com/category/opinion/">Opinion</a></li>
<li id="menu-item-551" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-551"><a href="https://freepressokc.com/category/editors-blog/">Editor&#8217;s Blog</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text">
	                <a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
	                </div>
	                <div class="td-login-register-link">
	                
	                </div>
	                
	                

                </div>
            </div>

            
            
            
            
            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://freepressokc.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style 10
-->

<div class="td-header-wrap td-header-style-10 ">
    
            <div class="td-header-top-menu-full td-container-wrap ">
            <div class="td-container td-header-row td-header-top-menu">
                
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Sunday, May 31, 2020
            </div>
        </div>
    <div class="menu-top-container"><ul id="menu-about-mission-and-goals-ad-pol" class="top-header-menu"><li id="menu-item-5465" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-5465"><a href="https://freepressokc.com/about/">About</a></li>
<li id="menu-item-5466" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-5466"><a href="https://freepressokc.com/mission-goals/">Mission and Goals</a></li>
<li id="menu-item-8933" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-8933"><a href="https://freepressokc.com/political-advertising-policy/">Political Advertising Policy</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
            <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>


        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://freepressokc.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    
    
        
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/oklahomacityfreepress/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/freepressokc/?hl=en" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="mailto:info@freepressokc.com" title="Mail">
                <i class="td-icon-font td-icon-mail-1"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://freepressokc.com/feed/" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/freepressokc" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCKnwaGON2-YbuX9-smgCafw" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>    </div>    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <div class="td-login-wrap">
                        <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
	                        <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            
                            
                            
                            
                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                        
                        
                    </div>
                </div>
                            </div>
        </div>
    
    <div class="td-banner-wrap-full td-logo-wrap-full  td-container-wrap ">
        <div class="td-header-sp-logo">
            		<div class="td-logo-text-wrap">
			<span class="td-logo-text-container">
				<a class="td-logo-wrap" href="https://freepressokc.com/">
											<span class="td-logo-text">Oklahoma City Free Press</span>
										<span class="td-tagline-text">Oklahoma City's local, independent, online news</span>
				</a>
			</span>
		</div>
	        </div>
    </div>

	<div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient td-header-menu-no-search">
			<div class="td-container td-header-row td-header-main-menu">
				<div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
            </div>
    <div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-8600"><a href="https://freepressokc.com/category/health-and-covid-19/">Health and COVID-19</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-231"><a href="https://freepressokc.com/category/politics/">Politics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-48"><a href="https://freepressokc.com/category/government/">Government</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-47"><a href="https://freepressokc.com/category/education/">Education</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-416"><a href="https://freepressokc.com/category/cinema/">Cinema</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-8423"><a href="https://freepressokc.com/category/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-4328"><a href="https://freepressokc.com/category/the-arts/">The Arts</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-46"><a href="https://freepressokc.com/category/cultures/">Cultures</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7689"><a href="https://freepressokc.com/category/neighborhood-news/">Neighborhood news</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-50"><a href="https://freepressokc.com/category/technology/">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-45"><a href="https://freepressokc.com/category/crime/">Crime</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1033"><a href="https://freepressokc.com/category/business/">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-7647"><a href="https://freepressokc.com/category/first-person/">First Person</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7892"><a href="https://freepressokc.com/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-551"><a href="https://freepressokc.com/category/editors-blog/">Editor&#8217;s Blog</a></li>
</ul></div></div>


    <div class="td-search-wrapper">
        <div id="td-top-search">
            <!-- Search -->
            <div class="header-search-wrap">
                <div class="dropdown header-search">
                    <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                </div>
            </div>
        </div>
    </div>
			</div>
		</div>
	</div>

    
</div>
            </div>

            
<article id="post-9245" class="td-post-template-3 post-9245 post type-post status-publish format-standard has-post-thumbnail category-first-person tag-black-lives-matter tag-black-lives-matter-okc tag-silence td-container-wrap" itemscope itemtype="https://schema.org/Article">
    <div class="td-post-header td-container">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://freepressokc.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in First Person" class="entry-crumb" href="https://freepressokc.com/category/first-person/">First Person</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">I am sorry for the times I have been silent</span></div></div>
        <div class="td-post-header-holder td-image-gradient">
            <div class="td-post-featured-image"><figure><a href="https://freepressokc.com/wp-content/uploads/2020/02/DSC_0229.jpg" data-caption="Students at NW Classen High School listen to student speakers at a protest against a beloved teacher being disciplined. (file, Brett Dickerson/Okla City Free Press)"><img width="800" height="450"   data-srcset="https://freepressokc.com/wp-content/uploads/2020/02/DSC_0229.jpg 800w, https://freepressokc.com/wp-content/uploads/2020/02/DSC_0229-300x169.jpg 300w, https://freepressokc.com/wp-content/uploads/2020/02/DSC_0229-768x432.jpg 768w, https://freepressokc.com/wp-content/uploads/2020/02/DSC_0229-696x392.jpg 696w, https://freepressokc.com/wp-content/uploads/2020/02/DSC_0229-747x420.jpg 747w"  alt="Students protest" title="DSC_0229" data-src="https://freepressokc.com/wp-content/uploads/2020/02/DSC_0229.jpg" data-sizes="(max-width: 800px) 100vw, 800px" class="entry-thumb td-modal-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="800" height="450" class="entry-thumb td-modal-image" src="https://freepressokc.com/wp-content/uploads/2020/02/DSC_0229.jpg" srcset="https://freepressokc.com/wp-content/uploads/2020/02/DSC_0229.jpg 800w, https://freepressokc.com/wp-content/uploads/2020/02/DSC_0229-300x169.jpg 300w, https://freepressokc.com/wp-content/uploads/2020/02/DSC_0229-768x432.jpg 768w, https://freepressokc.com/wp-content/uploads/2020/02/DSC_0229-696x392.jpg 696w, https://freepressokc.com/wp-content/uploads/2020/02/DSC_0229-747x420.jpg 747w" sizes="(max-width: 800px) 100vw, 800px" alt="Students protest" title="DSC_0229"/></noscript></a><figcaption class="wp-caption-text">Students at NW Classen High School listen to student speakers at a protest against a beloved teacher being disciplined. (file, Brett Dickerson/Okla City Free Press)</figcaption></figure></div>
            <header class="td-post-title">
                <ul class="td-category"><li class="entry-category"><a  href="https://freepressokc.com/category/first-person/">First Person</a></li></ul>                <h1 class="entry-title">I am sorry for the times I have been silent</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://freepressokc.com/author/free-press-guest/">Free Press Guest Contributor</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-05-30T17:30:31-05:00" >May 30, 2020</time></span>                                                        </div>

            </header>
        </div>
    </div>

    <div class="td-container">
        <div class="td-pb-row">
                                <div class="td-pb-span8 td-main-content" role="main">
                        <div class="td-ss-main-content">
                            
    <div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
                                        <div class="td-social-but-icon"><i class="td-icon-share"></i></div>
                                        <div class="td-social-but-text">Share</div>
                                    </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffreepressokc.com%2Fi-am-sorry-for-the-times-i-have-been-silent%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=I+am+sorry+for+the+times+I+have+been+silent&url=https%3A%2F%2Ffreepressokc.com%2Fi-am-sorry-for-the-times-i-have-been-silent%2F&via=freepressokc">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/&title=I+am+sorry+for+the+times+I+have+been+silent">
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="mailto:?subject=I am sorry for the times I have been silent&body=https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/">
                                        <div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
                                        <div class="td-social-but-text">Email</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/&amp;media=https://freepressokc.com/wp-content/uploads/2020/02/DSC_0229.jpg&description=Silence is acceptance. I am sorry for the times I have been silent. Silence is acceptance. I am sorry for the times I have been silent.">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>
    <div class="td-post-content tagdiv-type">
        <div class="g g-1"><div class="g-single a-7"><a href="https://workflowokc.com/" target="_blank" rel="nofollow"><img  width="1280" height="180" data-src="https://freepressokc.com/wp-content/banners/free-press_workflow-feb21.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://freepressokc.com/wp-content/banners/free-press_workflow-feb21.jpg" width="1280" height="180" /></noscript></a></div></div><span class="wtr-time-wrap before-content"><span class="wtr-time-number">4</span> minute read</span><div id="wtr-content" 
	    	data-bg="#FFFFFF" 
	    	data-fg="#f44813" 
	    	data-width="5" 
	    	data-mute="" 
	    	data-fgopacity="0.5" 
	    	data-mutedopacity="0.5" 
	    	data-placement="left" 
	    	data-placement-offset="0" 
	    	data-content-offset="0" 
	    	data-placement-touch="left" 
		    data-placement-offset-touch="0" 
	    	data-transparent="" 
	    	data-touch="1" 
	    	data-non-touch="1" 
	    	data-comments="0" 
	    	data-commentsbg="#ffcece" 
	    	data-location="page" 
	    	data-mutedfg="#f44813" 
	    	data-rtl="" 
	    	>
<p><em>Jace Kirk is the Dean of Students at Santa Fe South High School, a charter school on the south side of Oklahoma City. </em> <em>We saw an earlier version of this posted in social media in response to the police killing of George Floyd in Minneapolis and the protests that followed</em>. <em>He graciously agreed to allow us to post this lightly-edited version here.</em></p>



<blockquote class="wp-block-quote"><p>First Person</p><cite>Where <em>we ask members of the community to write their first-person account of a particular aspect of our City.</em></cite></blockquote>



<hr class="wp-block-separator"/>



<p>I have been part of the problem.</p>



<p>It must have been 10 years ago. I was volunteering at a local middle school three days a week. This school was primarily comprised of brown and black students. I was working with a student in the office when another student entered the office followed by an administrator. The student had been removed from class and it was obvious by his use of profanity what he thought of each of us.</p>



<p>The administrator told him to sit down. What looked like defiance was actually this young man’s last grasp at any semblance of control in his life. “I’ll stand,” he smirked. The administrator engaged in a power struggle. It was completely unnecessary for this young man to sit down to continue the conversation but for some reason they demanded compliance. The standoff ended with, “I’ll give you one more chance to sit down or I will have to call the school resource officer.”</p>



<p>Moments later the SRO threw the door open. The young man was on the ground in a split second and the knee of the 300 pound+ officer was in the back of the flailing middle schooler. The barrage of expletives that were hurled at the officer by this young man would make a sailor blush with shame. The one that stood out was, “I can’t breathe, you f**king fatass!”</p>



<div class="wp-block-image"><figure class="alignright size-large is-resized"><img  alt="race"  width="235" height="235" data-srcset="https://freepressokc.com/wp-content/uploads/2020/05/Jace.Kirk-sq.jpg 500w, https://freepressokc.com/wp-content/uploads/2020/05/Jace.Kirk-sq-300x300.jpg 300w, https://freepressokc.com/wp-content/uploads/2020/05/Jace.Kirk-sq-150x150.jpg 150w, https://freepressokc.com/wp-content/uploads/2020/05/Jace.Kirk-sq-420x420.jpg 420w"  data-src="https://freepressokc.com/wp-content/uploads/2020/05/Jace.Kirk-sq.jpg" data-sizes="(max-width: 235px) 100vw, 235px" class="wp-image-9244 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://freepressokc.com/wp-content/uploads/2020/05/Jace.Kirk-sq.jpg" alt="race" class="wp-image-9244" width="235" height="235" srcset="https://freepressokc.com/wp-content/uploads/2020/05/Jace.Kirk-sq.jpg 500w, https://freepressokc.com/wp-content/uploads/2020/05/Jace.Kirk-sq-300x300.jpg 300w, https://freepressokc.com/wp-content/uploads/2020/05/Jace.Kirk-sq-150x150.jpg 150w, https://freepressokc.com/wp-content/uploads/2020/05/Jace.Kirk-sq-420x420.jpg 420w" sizes="(max-width: 235px) 100vw, 235px" /></noscript><figcaption>Jace Kirk at an Oklahoma City Public Schools Board of Education meeting September, 2019. (Brett Dickerson/Okla City Free Press)</figcaption></figure></div>



<p>“If you’re talking you’re breathing,” came the officer&#8217;s casual reply. I wanted so much to tackle this man, to push him off. He had a gun and a badge. I did not. I went into the hall and, as a grown man, I cried tears of helplessness.</p>



<p>The next day I filed a written complaint with the building principal and was told, “If you don’t want his kind of help, don’t ask for it.” I never did.</p>



<p>This week, as I first saw the horrific images of George Floyd’s murder, my mind superimposed the face of this young man on the body of Mr. Floyd. A flood of emotion returned. I realized I was part of the problem.</p>



<p>22-year-old me thought things like, “It’s 2005. Racism doesn’t really exist anymore. I mean sure, there are crazy people but, for the most part, racism just doesn’t exist.”</p>



<p>That way of thinking was shattered when 23-year-old me became a foster parent. Of the more than 20 kids I fostered, only two were white.</p>



<p>I have walked into a barbershop in Moore, Oklahoma, with my brown and black kids only to be told that they were closed. The sign showed they were open for four more hours and there were other customers coming in but they were “closed.”</p>



<p>As I advocated for a pathway to citizenship for my son, I have been told if I didn’t like the way things are I should “go with my son, in a body bag, back to where he came from.” Got to love the Bible Belt!</p>



<p>I have been to Bricktown in downtown OKC with my foster children after curfew. When I stepped away to pay for something, I have come back to find officers rounding my children up while a group of white children who were unsupervised walked nearby.</p>



<p>Some of these examples are subtle. They are easier to stomach, to shake your head and walk away silently. I have been silently outraged, and thus part of the problem.</p>



<p>Silence is acceptance. I am sorry for the times I have been silent.</p>



<p><em>&#8212; Jace</em></p>



<hr>
<h3><strong>Sustain our journalism by becoming a supporter<br></strong></h3>
<p>Oklahoma City Free Press is dedicated to providing high quality journalism that positively impacts our community. Click this <a href="https://pp-staging.presspatron.com/donations/new?frame=1&amp;t=VuVQRxLy7UcJsBNvasA5tDAz">link</a> or the red button below to support our mission.</p>
<div class="pp-donate-button">&nbsp;</div>
<hr>



<p></p>
</div>    </div>


    <footer>
                
        <div class="td-post-source-tags">
                        <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://freepressokc.com/tag/black-lives-matter/">Black Lives Matter</a></li><li><a href="https://freepressokc.com/tag/black-lives-matter-okc/">Black Lives Matter OKC</a></li><li><a href="https://freepressokc.com/tag/silence/">Silence</a></li></ul>        </div>

        <div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
                                        <div class="td-social-but-icon"><i class="td-icon-share"></i></div>
                                        <div class="td-social-but-text">Share</div>
                                    </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffreepressokc.com%2Fi-am-sorry-for-the-times-i-have-been-silent%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=I+am+sorry+for+the+times+I+have+been+silent&url=https%3A%2F%2Ffreepressokc.com%2Fi-am-sorry-for-the-times-i-have-been-silent%2F&via=freepressokc">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/&title=I+am+sorry+for+the+times+I+have+been+silent">
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="mailto:?subject=I am sorry for the times I have been silent&body=https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/">
                                        <div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
                                        <div class="td-social-but-text">Email</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/&amp;media=https://freepressokc.com/wp-content/uploads/2020/02/DSC_0229.jpg&description=Silence is acceptance. I am sorry for the times I have been silent. Silence is acceptance. I am sorry for the times I have been silent.">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>        <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://freepressokc.com/five-features-worth-focusing-on-at-this-years-deadcenter-film-festival/">Five features worth focusing on at this year’s deadCenter Film Festival</a></div></div><div class="td-next-prev-separator"></div></div>        <div class="author-box-wrap"><a href="https://freepressokc.com/author/free-press-guest/"><img  width="96" height="96" alt="Free Press Guest Contributor"  data-src="https://freepressokc.com/wp-content/uploads/2016/09/FPLogo-Nov1-black-150x150.png" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://freepressokc.com/wp-content/uploads/2016/09/FPLogo-Nov1-black-150x150.png" width="96" height="96" alt="Free Press Guest Contributor" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" /></noscript></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://freepressokc.com/author/free-press-guest/">Free Press Guest Contributor</a></span></div><div class="td-author-description"></div><div class="td-author-social"></div><div class="clearfix"></div></div></div>        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Free Press Guest Contributor"></span><meta itemprop="datePublished" content="2020-05-30T17:30:31-05:00"><meta itemprop="dateModified" content="2020-05-30T17:54:42-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://freepressokc.com/i-am-sorry-for-the-times-i-have-been-silent/"></span><meta itemprop="name" content="Oklahoma City Free Press"></span><meta itemprop="headline " content="I am sorry for the times I have been silent"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://freepressokc.com/wp-content/uploads/2020/02/DSC_0229.jpg"><meta itemprop="width" content="800"><meta itemprop="height" content="450"></span>    </footer>

    <div class="td_block_wrap td_block_related_posts tdi_2_def td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_2_def" ><script>var block_tdi_2_def = new tdBlock();
block_tdi_2_def.id = "tdi_2_def";
block_tdi_2_def.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_2_def","td_column_number":3,"live_filter_cur_post_id":9245,"live_filter_cur_post_author":"342","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_2_def","tdc_css_class_style":"tdi_2_def_rand_style"}';
block_tdi_2_def.td_column_number = "3";
block_tdi_2_def.block_type = "td_block_related_posts";
block_tdi_2_def.post_count = "3";
block_tdi_2_def.found_posts = "3";
block_tdi_2_def.header_color = "";
block_tdi_2_def.ajax_pagination_infinite_stop = "";
block_tdi_2_def.max_num_pages = "1";
tdBlocksArray.push(block_tdi_2_def);
</script><h4 class="td-related-title td-block-title"><a id="tdi_3_bbb" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_2_def" href="#">RELATED ARTICLES</a><a id="tdi_4_006" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_2_def" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_2_def class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://freepressokc.com/mothers-day-musings-one-time-at-childhood-wtf-band-camp/" rel="bookmark" class="td-image-wrap " title="Mother&#8217;s Day musings: One time at childhood WTF band camp&#8230;" ><img width="218" height="150"    data-srcset="https://freepressokc.com/wp-content/uploads/2020/05/DSC04720-218x150.jpg 218w, https://freepressokc.com/wp-content/uploads/2020/05/DSC04720-100x70.jpg 100w"   alt="flowers" title="Mother&#8217;s Day musings: One time at childhood WTF band camp&#8230;" data-src="https://freepressokc.com/wp-content/uploads/2020/05/DSC04720-218x150.jpg" data-sizes="(max-width: 218px) 100vw, 218px" class="entry-thumb lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2020/05/DSC04720-218x150.jpg"  srcset="https://freepressokc.com/wp-content/uploads/2020/05/DSC04720-218x150.jpg 218w, https://freepressokc.com/wp-content/uploads/2020/05/DSC04720-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px"  alt="flowers" title="Mother&#8217;s Day musings: One time at childhood WTF band camp&#8230;" /></noscript></a></div>                <a href="https://freepressokc.com/category/first-person/" class="td-post-category">First Person</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/mothers-day-musings-one-time-at-childhood-wtf-band-camp/" rel="bookmark" title="Mother&#8217;s Day musings: One time at childhood WTF band camp&#8230;">Mother&#8217;s Day musings: One time at childhood WTF band camp&#8230;</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://freepressokc.com/journalism-students-still-learn-from-okc-bombing-even-after-25-years/" rel="bookmark" class="td-image-wrap " title="Journalism students still learn from OKC bombing even after 25 years" ><img width="218" height="150"    data-srcset="https://freepressokc.com/wp-content/uploads/2020/04/OKC-Nat-Mem-4-2020-DSC04023-218x150.jpg 218w, https://freepressokc.com/wp-content/uploads/2020/04/OKC-Nat-Mem-4-2020-DSC04023-100x70.jpg 100w"   alt="okc bombing" title="Journalism students still learn from OKC bombing even after 25 years" data-src="https://freepressokc.com/wp-content/uploads/2020/04/OKC-Nat-Mem-4-2020-DSC04023-218x150.jpg" data-sizes="(max-width: 218px) 100vw, 218px" class="entry-thumb lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2020/04/OKC-Nat-Mem-4-2020-DSC04023-218x150.jpg"  srcset="https://freepressokc.com/wp-content/uploads/2020/04/OKC-Nat-Mem-4-2020-DSC04023-218x150.jpg 218w, https://freepressokc.com/wp-content/uploads/2020/04/OKC-Nat-Mem-4-2020-DSC04023-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px"  alt="okc bombing" title="Journalism students still learn from OKC bombing even after 25 years" /></noscript></a></div>                <a href="https://freepressokc.com/category/first-person/" class="td-post-category">First Person</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/journalism-students-still-learn-from-okc-bombing-even-after-25-years/" rel="bookmark" title="Journalism students still learn from OKC bombing even after 25 years">Journalism students still learn from OKC bombing even after 25 years</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://freepressokc.com/first-person-march-11-1958/" rel="bookmark" class="td-image-wrap " title="&#8220;March 11, 1958&#8221;" ><img width="218" height="150"    data-srcset="https://freepressokc.com/wp-content/uploads/2019/12/Marty-Peercy-at-Curbside-218x150.jpg 218w, https://freepressokc.com/wp-content/uploads/2019/12/Marty-Peercy-at-Curbside-100x70.jpg 100w"   alt="Marty Peercy" title="&#8220;March 11, 1958&#8221;" data-src="https://freepressokc.com/wp-content/uploads/2019/12/Marty-Peercy-at-Curbside-218x150.jpg" data-sizes="(max-width: 218px) 100vw, 218px" class="entry-thumb lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2019/12/Marty-Peercy-at-Curbside-218x150.jpg"  srcset="https://freepressokc.com/wp-content/uploads/2019/12/Marty-Peercy-at-Curbside-218x150.jpg 218w, https://freepressokc.com/wp-content/uploads/2019/12/Marty-Peercy-at-Curbside-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px"  alt="Marty Peercy" title="&#8220;March 11, 1958&#8221;" /></noscript></a></div>                <a href="https://freepressokc.com/category/first-person/" class="td-post-category">First Person</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/first-person-march-11-1958/" rel="bookmark" title="&#8220;March 11, 1958&#8221;">&#8220;March 11, 1958&#8221;</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_2_def" data-td_block_id="tdi_2_def"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page ajax-page-disabled" id="next-page-tdi_2_def" data-td_block_id="tdi_2_def"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
                        </div>
                    </div>
                    <div class="td-pb-span4 td-main-sidebar" role="complementary">
                        <div class="td-ss-main-sidebar">
                                            <!-- .no sidebar -->
                                        </div>
                    </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</article> <!-- /.post -->

<!-- Instagram -->

	
	
            <div class="tdc-footer-wrap ">

                <!-- Footer -->
				<div class="td-footer-wrapper td-footer-container td-container-wrap ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span12">
                <aside class="td_block_template_1 widget 5eb1c64b03b51"><div class="g g-1"><div class="g-single a-4"><a class="gofollow" data-track="NCwxLDEsNjA=" href="https://www.starspace46.com/" target="_blank" rel="nofollow"><img  width="1280" height="180" data-srcset="https://freepressokc.com/wp-content/banners/ss46.gif 1280w, https://freepressokc.com/wp-content/banners/ss46.gif 1280w, https://freepressokc.com/wp-content/banners/ss46.gif 1280w, https://freepressokc.com/wp-content/banners/ss46.gif 1280w"  data-src="https://freepressokc.com/wp-content/banners/ss46.gif" data-sizes="(max-width: 480px) 1280px, (max-width: 960px) 1280px, (max-width: 1280px) 1280px, 1281px" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://freepressokc.com/wp-content/banners/ss46.gif" width="1280" height="180" srcset="https://freepressokc.com/wp-content/banners/ss46.gif 1280w, https://freepressokc.com/wp-content/banners/ss46.gif 1280w, https://freepressokc.com/wp-content/banners/ss46.gif 1280w, https://freepressokc.com/wp-content/banners/ss46.gif 1280w" sizes="(max-width: 480px) 1280px, (max-width: 960px) 1280px, (max-width: 1280px) 1280px, 1281px" /></noscript></a></div></div></aside>            </div>
        </div>
    </div>

    <div class="td-footer-bottom-full">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://freepressokc.com/"><img  alt="Oklahoma City Free Press" title="Oklahoma City Free Press" data-src="https://freepressokc.com/wp-content/uploads/2016/11/FPLogo-Nov1-white-150x150.png" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://freepressokc.com/wp-content/uploads/2016/11/FPLogo-Nov1-white-150x150.png" alt="Oklahoma City Free Press" title="Oklahoma City Free Press"/></noscript></a></aside></div><div class="td-pb-span9"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div><hr>
<p><strong>Sustain our journalism by becoming a supporter<br></strong></p>
<p>Oklahoma City Free Press is dedicated to providing high quality journalism that positively impacts our community. We give voice to those who aren’t heard and expose that which is hidden from the public. Click this <a href="https://pp-staging.presspatron.com/donations/new?frame=1&t=VuVQRxLy7UcJsBNvasA5tDAz">link</a> or the red button below to support our mission.</p>
<div class="pp-donate-button"> </div>
<hr>

Published by Oklahoma City Free Press LLC, Oklahoma City, Oklahoma -- Publisher and Editor - Brett Dickerson. All photography and content is under copyright. We adhere to the Society of Professional Journalists Code of Ethics.</aside></div>            </div>
        </div>
    </div>
</div>
                <!-- Sub Footer -->
				    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-sub-footer-material-container"><ul id="menu-sub-footer-material" class="td-subfooter-menu"><li id="menu-item-28" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-28"><a href="https://freepressokc.com/terms-copyright-and-conditions/">Terms, copyright, and conditions</a></li>
<li id="menu-item-31" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-31"><a href="https://freepressokc.com/privacy-statement/">Privacy Statement</a></li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; Oklahoma City Free Press LLC, 2016, 2017, 2018, 2019, 2020.    <a href="//www.dmca.com/Protection/Status.aspx?ID=64fb634b-962d-4e3b-93ec-bed7c5a4d8ec" title="DMCA.com Protection Status" class="dmca-badge"> <img src="//images.dmca.com/Badges/dmca-badge-w100-5x1-11.png?ID=64fb634b-962d-4e3b-93ec-bed7c5a4d8ec" alt="DMCA.com Protection Status"></a> <script src="//images.dmca.com/Badges/DMCABadgeHelper.min.js"> </script>                </div>
            </div>
        </div>
    </div>
            </div><!--close td-footer-wrap-->
			
</div><!--close td-outer-wrap-->



			<script type="text/javascript">
				var _paq = _paq || [];
					_paq.push(['setCustomDimension', 1, '{"ID":342,"name":"Free Press Guest Contributor","avatar":"1848217e6627c2320619cfebd81ed2a9"}']);
				_paq.push(['trackPageView']);
								(function () {
					var u = "https://stats1.wpmudev.com/";
					_paq.push(['setTrackerUrl', u + 'track/']);
					_paq.push(['setSiteId', '22896']);
					var d   = document, g = d.createElement('script'), s = d.getElementsByTagName('script')[0];
					g.type  = 'text/javascript';
					g.async = true;
					g.defer = true;
					g.src   = 'https://stats.wpmucdn.com/analytics.js';
					s.parentNode.insertBefore(g, s);
				})();
			</script>
			                <div class="td-more-articles-box">
                    <i class="td-icon-close td-close-more-articles-box"></i>
                    <span class="td-more-articles-box-title">MORE STORIES</span>
                    <div class="td-content-more-articles-box">

                    
        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://freepressokc.com/five-features-worth-focusing-on-at-this-years-deadcenter-film-festival/" rel="bookmark" class="td-image-wrap " title="Five features worth focusing on at this year’s deadCenter Film Festival" ><img width="100" height="70"    data-srcset="https://freepressokc.com/wp-content/uploads/2020/05/deadCenter-Film-Festival-100x70.jpg 100w, https://freepressokc.com/wp-content/uploads/2020/05/deadCenter-Film-Festival-218x150.jpg 218w"   alt="" title="Five features worth focusing on at this year’s deadCenter Film Festival" data-src="https://freepressokc.com/wp-content/uploads/2020/05/deadCenter-Film-Festival-100x70.jpg" data-sizes="(max-width: 100px) 100vw, 100px" class="entry-thumb lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="100" height="70" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2020/05/deadCenter-Film-Festival-100x70.jpg"  srcset="https://freepressokc.com/wp-content/uploads/2020/05/deadCenter-Film-Festival-100x70.jpg 100w, https://freepressokc.com/wp-content/uploads/2020/05/deadCenter-Film-Festival-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Five features worth focusing on at this year’s deadCenter Film Festival" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/five-features-worth-focusing-on-at-this-years-deadcenter-film-festival/" rel="bookmark" title="Five features worth focusing on at this year’s deadCenter Film Festival">Five features worth focusing on at this year’s deadCenter Film Festival</a></h3>            <div class="td-module-meta-info">
                <a href="https://freepressokc.com/category/cinema/" class="td-post-category">Cinema</a>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-05-29T17:08:46-05:00" >May 29, 2020</time></span>                            </div>
        </div>

        </div>

        
        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://freepressokc.com/black-lives-matter-plans-demand-justice-protest-rally-in-okc-sunday/" rel="bookmark" class="td-image-wrap " title="Black Lives Matter plans &#8220;Demand Justice Protest Rally&#8221; in OKC Sunday" ><img width="100" height="70"    data-srcset="https://freepressokc.com/wp-content/uploads/2020/05/DSC04795-100x70.jpg 100w, https://freepressokc.com/wp-content/uploads/2020/05/DSC04795-218x150.jpg 218w"   alt="Stop Killing Us Rally" title="Black Lives Matter plans &#8220;Demand Justice Protest Rally&#8221; in OKC Sunday" data-src="https://freepressokc.com/wp-content/uploads/2020/05/DSC04795-100x70.jpg" data-sizes="(max-width: 100px) 100vw, 100px" class="entry-thumb lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="100" height="70" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2020/05/DSC04795-100x70.jpg"  srcset="https://freepressokc.com/wp-content/uploads/2020/05/DSC04795-100x70.jpg 100w, https://freepressokc.com/wp-content/uploads/2020/05/DSC04795-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="Stop Killing Us Rally" title="Black Lives Matter plans &#8220;Demand Justice Protest Rally&#8221; in OKC Sunday" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/black-lives-matter-plans-demand-justice-protest-rally-in-okc-sunday/" rel="bookmark" title="Black Lives Matter plans &#8220;Demand Justice Protest Rally&#8221; in OKC Sunday">Black Lives Matter plans &#8220;Demand Justice Protest Rally&#8221; in OKC Sunday</a></h3>            <div class="td-module-meta-info">
                <a href="https://freepressokc.com/category/cultures/" class="td-post-category">Cultures</a>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-05-29T12:07:28-05:00" >May 29, 2020</time></span>                            </div>
        </div>

        </div>

        
        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://freepressokc.com/trump-and-his-republican-party-leaders-own-100000-deaths/" rel="bookmark" class="td-image-wrap " title="Trump and his Republican Party leaders own 100,000 deaths" ><img width="100" height="70"    data-srcset="https://freepressokc.com/wp-content/uploads/2020/05/49498772556_3c3736ca53_c-1-100x70.jpg 100w, https://freepressokc.com/wp-content/uploads/2020/05/49498772556_3c3736ca53_c-1-218x150.jpg 218w"   alt="Trump" title="Trump and his Republican Party leaders own 100,000 deaths" data-src="https://freepressokc.com/wp-content/uploads/2020/05/49498772556_3c3736ca53_c-1-100x70.jpg" data-sizes="(max-width: 100px) 100vw, 100px" class="entry-thumb lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="100" height="70" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2020/05/49498772556_3c3736ca53_c-1-100x70.jpg"  srcset="https://freepressokc.com/wp-content/uploads/2020/05/49498772556_3c3736ca53_c-1-100x70.jpg 100w, https://freepressokc.com/wp-content/uploads/2020/05/49498772556_3c3736ca53_c-1-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="Trump" title="Trump and his Republican Party leaders own 100,000 deaths" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/trump-and-his-republican-party-leaders-own-100000-deaths/" rel="bookmark" title="Trump and his Republican Party leaders own 100,000 deaths">Trump and his Republican Party leaders own 100,000 deaths</a></h3>            <div class="td-module-meta-info">
                <a href="https://freepressokc.com/category/opinion/" class="td-post-category">Opinion</a>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-05-27T08:04:43-05:00" >May 27, 2020</time></span>                            </div>
        </div>

        </div>

                            </div>
                </div>

    <!--

        Theme: Newspaper by tagDiv.com 2019
        Version: 10.3.4 (rara)
        Deploy mode: deploy
        
        uid: 5ed380a9bc86f
    -->

    <script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/freepressokc.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/worth-the-read/js/wtr.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/wp-smush-pro/app/assets/js/smush-lazy-load.min.js?ver=3.6.3'></script>
<script type='text/javascript'>
lazySizes.cfg.nativeLoading={setLoadingAttribute:false,disableListeners:{scroll:true}};lazySizes.init();
</script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=243b277d395aac11337949f2c0b8e89c'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3.4'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/comment-reply.min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=243b277d395aac11337949f2c0b8e89c'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/jquery/ui/effect-blind.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var stbUserOptions = {"mode":"css","cssOptions":{"roundedCorners":true,"mbottom":10,"imgHide":"https:\/\/freepressokc.com\/wp-content\/plugins\/wp-special-textboxes\/themes\/stb-dark\/minus.png","imgShow":"https:\/\/freepressokc.com\/wp-content\/plugins\/wp-special-textboxes\/themes\/stb-dark\/plus.png","strHide":"Hide","strShow":"Show"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/wp-special-textboxes/js/wstb.min.js?ver=5.9.109'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/wp-embed.min.js?ver=5.4.1'></script>

<!-- JS generated by theme -->

<script>
    
</script>


</body>
</html>