<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Bennie Edwards was a victim of OKC police gunfight mentality</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://freepressokc.com/xmlrpc.php" />
    <link rel="icon" type="image/png" href="https://freepressokc.com/wp-content/uploads/2016/09/cropped-FPlogo-single-png.png">
	<!-- This site is optimized with the Yoast SEO plugin v15.5 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Bennie Edwards is dead. If OKCPD officers who shot him had mental illness intervention training it might have turned out differently." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://freepressokc.com/bennie-edwards-was-a-victim-of-okc-police-gunfight-mentality/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Bennie Edwards was a victim of OKC police gunfight mentality" />
	<meta property="og:description" content="Bennie Edwards is dead. If OKCPD officers who shot him had mental illness intervention training it might have turned out differently." />
	<meta property="og:url" content="https://freepressokc.com/bennie-edwards-was-a-victim-of-okc-police-gunfight-mentality/" />
	<meta property="og:site_name" content="Oklahoma City Free Press" />
	<meta property="article:publisher" content="https://www.facebook.com/oklahomacityfreepress/" />
	<meta property="article:published_time" content="2020-12-16T03:49:12+00:00" />
	<meta property="article:modified_time" content="2020-12-16T03:49:13+00:00" />
	<meta property="og:image" content="https://freepressokc.com/wp-content/uploads/2020/12/DSC03754.jpg" />
	<meta property="og:image:width" content="1280" />
	<meta property="og:image:height" content="720" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@freepressokc" />
	<meta name="twitter:site" content="@freepressokc" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="George Lang">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="4 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://freepressokc.com/#organization","name":"Oklahoma City Free Press LLC","url":"https://freepressokc.com/","sameAs":["https://www.facebook.com/oklahomacityfreepress/","https://www.instagram.com/freepressokc/?hl=en","https://www.youtube.com/channel/UCKnwaGON2-YbuX9-smgCafw","https://www.pinterest.com/oklahomacityfre/","https://twitter.com/freepressokc"],"logo":{"@type":"ImageObject","@id":"https://freepressokc.com/#logo","inLanguage":"en-US","url":"https://freepressokc.com/wp-content/uploads/2016/09/FPLogo-Nov1-black.png","width":543,"height":543,"caption":"Oklahoma City Free Press LLC"},"image":{"@id":"https://freepressokc.com/#logo"}},{"@type":"WebSite","@id":"https://freepressokc.com/#website","url":"https://freepressokc.com/","name":"Oklahoma City Free Press","description":"Local, independent, online news","publisher":{"@id":"https://freepressokc.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://freepressokc.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://freepressokc.com/bennie-edwards-was-a-victim-of-okc-police-gunfight-mentality/#primaryimage","inLanguage":"en-US","url":"https://freepressokc.com/wp-content/uploads/2020/12/DSC03754.jpg","width":1280,"height":720,"caption":"Oklahoma City Police patrol cars sit at the scene of where officers shot and killed Bennie Edwards Dec. 11, 2020. (BRETT DICKERSON/Okla City Free Press)"},{"@type":"WebPage","@id":"https://freepressokc.com/bennie-edwards-was-a-victim-of-okc-police-gunfight-mentality/#webpage","url":"https://freepressokc.com/bennie-edwards-was-a-victim-of-okc-police-gunfight-mentality/","name":"Bennie Edwards was a victim of OKC police gunfight mentality","isPartOf":{"@id":"https://freepressokc.com/#website"},"primaryImageOfPage":{"@id":"https://freepressokc.com/bennie-edwards-was-a-victim-of-okc-police-gunfight-mentality/#primaryimage"},"datePublished":"2020-12-16T03:49:12+00:00","dateModified":"2020-12-16T03:49:13+00:00","description":"Bennie Edwards is dead. If OKCPD officers who shot him had mental illness intervention training it might have turned out differently.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://freepressokc.com/bennie-edwards-was-a-victim-of-okc-police-gunfight-mentality/"]}]},{"@type":"Article","@id":"https://freepressokc.com/bennie-edwards-was-a-victim-of-okc-police-gunfight-mentality/#article","isPartOf":{"@id":"https://freepressokc.com/bennie-edwards-was-a-victim-of-okc-police-gunfight-mentality/#webpage"},"author":{"@id":"https://freepressokc.com/#/schema/person/6d3da654e3aac398a6e04d135ec5f1e9"},"headline":"Bennie Edwards was a victim of OKC police gunfight mentality","datePublished":"2020-12-16T03:49:12+00:00","dateModified":"2020-12-16T03:49:13+00:00","mainEntityOfPage":{"@id":"https://freepressokc.com/bennie-edwards-was-a-victim-of-okc-police-gunfight-mentality/#webpage"},"publisher":{"@id":"https://freepressokc.com/#organization"},"image":{"@id":"https://freepressokc.com/bennie-edwards-was-a-victim-of-okc-police-gunfight-mentality/#primaryimage"},"keywords":"Bennie Edwards,Oklahoma City Police Department,police","articleSection":"Opinion","inLanguage":"en-US"},{"@type":"Person","@id":"https://freepressokc.com/#/schema/person/6d3da654e3aac398a6e04d135ec5f1e9","name":"George Lang","image":{"@type":"ImageObject","@id":"https://freepressokc.com/#personlogo","inLanguage":"en-US","url":"https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1.jpg","caption":"George Lang"},"description":"George Lang has worked as an award-winning professional journalist in Oklahoma City for over 25 years. His work has been published in The Oklahoman, Oklahoma Gazette, 405 Magazine and others, and covers a wide range of subjects including politics, media, entertainment and others. George lives in Oklahoma City with his wife and son."}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Oklahoma City Free Press &raquo; Feed" href="https://freepressokc.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Oklahoma City Free Press &raquo; Comments Feed" href="https://freepressokc.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/freepressokc.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://freepressokc.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='wtr-css-css'  href='https://freepressokc.com/wp-content/plugins/worth-the-read/css/wtr.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://freepressokc.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=c784b8db3e66cd68082f3ff7aa2d70e6' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Roboto+Slab%3A400%7CLato%3A400%7CRoboto%3A400%2C500%2C700%7COpen+Sans%3A400%2C600%2C700&#038;display=swap&#038;ver=10.3.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://freepressokc.com/wp-content/themes/Newspaper/style.css?ver=10.3.9.1' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='td-legacy-framework-front-style-css'  href='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=c784b8db3e66cd68082f3ff7aa2d70e6' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css'  href='https://freepressokc.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=6b62588d33477b8e3dc5b8b3c9c8d86c' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/includes/demos/politics/demo_style.css?ver=10.3.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css'  href='https://freepressokc.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=a50385a2d79d6600973a7e697f735a0b' type='text/css' media='all, print' />
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<link rel="https://api.w.org/" href="https://freepressokc.com/wp-json/" /><link rel="alternate" type="application/json" href="https://freepressokc.com/wp-json/wp/v2/posts/11517" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://freepressokc.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://freepressokc.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.3" />
<link rel='shortlink' href='https://freepressokc.com/?p=11517' />
<link rel="alternate" type="application/json+oembed" href="https://freepressokc.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffreepressokc.com%2Fbennie-edwards-was-a-victim-of-okc-police-gunfight-mentality%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://freepressokc.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffreepressokc.com%2Fbennie-edwards-was-a-victim-of-okc-police-gunfight-mentality%2F&#038;format=xml" />
<style type="text/css">.wtr-time-wrap{ 
	/* wraps the entire label */
	margin: 0 10px;

}
.wtr-time-number{ 
	/* applies only to the number */
	
}</style>		<script>
			document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );
		</script>
				<style>
			.no-js img.lazyload { display: none; }
			figure.wp-block-image img.lazyloading { min-width: 150px; }
							.lazyload, .lazyloading { opacity: 0; }
				.lazyloaded {
					opacity: 1;
					transition: opacity 400ms;
					transition-delay: 0ms;
				}
					</style>
		<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
        <script>
        window.tdb_globals = {"wpRestNonce":"7de9542a7b","wpRestUrl":"https:\/\/freepressokc.com\/wp-json\/","permalinkStructure":"\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
    			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/freepressokc.com\/wp-admin\/","wpRestNonce":"7de9542a7b","wpRestUrl":"https:\/\/freepressokc.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>
			
<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-89779313-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-89779313-1');
</script>

<script>
(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
el = d.createElement('script');
el.id = "js-pp-banner";
el.src = "//dashboard.presspatron.com/dev/banner?b=pMamyM1ZSttVyfgPpMYw2zgS";
fjs.parentNode.insertBefore(el, fjs);
}(document));
</script>

<div id="pp-banner"></div>


<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://freepressokc.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://freepressokc.com/category/opinion/",
                    "name": "Opinion"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://freepressokc.com/bennie-edwards-was-a-victim-of-okc-police-gunfight-mentality/",
                    "name": "Bennie Edwards was a victim of OKC police gunfight mentality"                                
                }
            }    
        ]
    }
</script>
<link rel="icon" href="https://freepressokc.com/wp-content/uploads/2016/11/cropped-FPLogo-Nov1-white-32x32.png" sizes="32x32" />
<link rel="icon" href="https://freepressokc.com/wp-content/uploads/2016/11/cropped-FPLogo-Nov1-white-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://freepressokc.com/wp-content/uploads/2016/11/cropped-FPLogo-Nov1-white-180x180.png" />
<meta name="msapplication-TileImage" content="https://freepressokc.com/wp-content/uploads/2016/11/cropped-FPLogo-Nov1-white-270x270.png" />
<link rel="alternate" type="application/rss+xml" title="RSS" href="https://freepressokc.com/rsslatest.xml" /><style type="text/css" title="dynamic-css" class="options-output">.wtr-time-wrap{text-align:left;line-height:20px;font-weight:400;font-style:italic;color:#079603;font-size:14px;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading .wtr-time-wrap{opacity: 0;}.ie.wf-loading .wtr-time-wrap{visibility: hidden;}</style>
<!-- Button style compiled by theme -->

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #dd3333;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #dd3333;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #dd3333;
                }
                .tdm-btn-style1 {
					background-color: #dd3333;
				}
				.tdm-btn-style2:before {
				    border-color: #dd3333;
				}
				.tdm-btn-style2 {
				    color: #dd3333;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #dd3333;
                    -moz-box-shadow: 0 2px 16px #dd3333;
                    box-shadow: 0 2px 16px #dd3333;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #dd3333;
                    -moz-box-shadow: 0 4px 26px #dd3333;
                    box-shadow: 0 4px 26px #dd3333;
				}
</style>

	<style id="tdw-css-placeholder"></style></head>

<body class="post-template-default single single-post postid-11517 single-format-standard td-standard-pack bennie-edwards-was-a-victim-of-okc-police-gunfight-mentality global-block-template-1 td-politics single_template_3 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/oklahomacityfreepress/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/freepressokc" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="mailto:info@freepressokc.com" title="Mail">
                <i class="td-icon-font td-icon-mail-1"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://freepressokc.com/feed/" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/freepressokc" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCKnwaGON2-YbuX9-smgCafw" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-8600" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-8600"><a href="https://freepressokc.com/category/health-and-covid-19/">Health and COVID-19</a></li>
<li id="menu-item-231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-231"><a href="https://freepressokc.com/category/politics/">Politics<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-10122" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10122"><a href="https://freepressokc.com/category/protests/">Protests</a></li>
</ul>
</li>
<li id="menu-item-48" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48"><a href="https://freepressokc.com/category/government/">Government</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47"><a href="https://freepressokc.com/category/education/">Education</a></li>
<li id="menu-item-4328" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-4328"><a href="https://freepressokc.com/category/the-arts/">The Arts<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-416" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-416"><a href="https://freepressokc.com/category/cinema/">Cinema<i class="td-icon-menu-right td-element-after"></i></a>
	<ul class="sub-menu">
		<li id="menu-item-9394" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9394"><a href="https://freepressokc.com/category/cinema/deadcenter/">deadCenter Film Festival</a></li>
	</ul>
</li>
	<li id="menu-item-8423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8423"><a href="https://freepressokc.com/category/music/">Music</a></li>
</ul>
</li>
<li id="menu-item-46" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46"><a href="https://freepressokc.com/category/cultures/">Cultures</a></li>
<li id="menu-item-7689" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-7689"><a href="https://freepressokc.com/category/neighborhood-news/">Neighborhood news<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
	<li id="menu-item-10452" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10452"><a href="https://freepressokc.com/category/seen-heard/">Seen and Heard</a></li>
</ul>
</li>
<li id="menu-item-50" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50"><a href="https://freepressokc.com/category/technology/">Technology</a></li>
<li id="menu-item-45" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45"><a href="https://freepressokc.com/category/crime/">Crime</a></li>
<li id="menu-item-1033" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1033"><a href="https://freepressokc.com/category/business/">Business</a></li>
<li id="menu-item-7892" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-7892"><a href="https://freepressokc.com/category/opinion/">Opinion</a></li>
<li id="menu-item-10449" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10449"><a href="https://freepressokc.com/category/editor-notes/">Editor&#8217;s Notes</a></li>
<li id="menu-item-10451" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10451"><a href="https://freepressokc.com/category/open-letters/">Open Letters</a></li>
<li id="menu-item-7647" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7647"><a href="https://freepressokc.com/category/first-person/">First Person</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text">
	                <a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
	                </div>
	                <div class="td-login-register-link">
	                
	                </div>
	                
	                

                </div>
            </div>

            
            
            
            
            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://freepressokc.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style 10
-->

<div class="td-header-wrap td-header-style-10 ">
    
            <div class="td-header-top-menu-full td-container-wrap ">
            <div class="td-container td-header-row td-header-top-menu">
                
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Wednesday, December 16, 2020
            </div>
        </div>
    </div>
        <div class="td-header-sp-top-widget">
            <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>


        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://freepressokc.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    
    
        
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/oklahomacityfreepress/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/freepressokc" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="mailto:info@freepressokc.com" title="Mail">
                <i class="td-icon-font td-icon-mail-1"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://freepressokc.com/feed/" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/freepressokc" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCKnwaGON2-YbuX9-smgCafw" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>    </div>    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <div class="td-login-wrap">
                        <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
	                        <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            
                            
                            
                            
                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                        
                        
                    </div>
                </div>
                            </div>
        </div>
    
    <div class="td-banner-wrap-full td-logo-wrap-full  td-container-wrap ">
        <div class="td-header-sp-logo">
            		<div class="td-logo-text-wrap">
			<span class="td-logo-text-container">
				<a class="td-logo-wrap" href="https://freepressokc.com/">
											<span class="td-logo-text">Oklahoma City Free Press</span>
										<span class="td-tagline-text">Oklahoma City's award-winning independent, online news</span>
				</a>
			</span>
		</div>
	        </div>
    </div>

	<div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient td-header-menu-no-search">
			<div class="td-container td-header-row td-header-main-menu">
				<div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
            </div>
    <div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-8600"><a href="https://freepressokc.com/category/health-and-covid-19/">Health and COVID-19</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-231"><a href="https://freepressokc.com/category/politics/">Politics</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10122"><a href="https://freepressokc.com/category/protests/">Protests</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-48"><a href="https://freepressokc.com/category/government/">Government</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-47"><a href="https://freepressokc.com/category/education/">Education</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-4328"><a href="https://freepressokc.com/category/the-arts/">The Arts</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-416"><a href="https://freepressokc.com/category/cinema/">Cinema</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-9394"><a href="https://freepressokc.com/category/cinema/deadcenter/">deadCenter Film Festival</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-8423"><a href="https://freepressokc.com/category/music/">Music</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-46"><a href="https://freepressokc.com/category/cultures/">Cultures</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-7689"><a href="https://freepressokc.com/category/neighborhood-news/">Neighborhood news</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10452"><a href="https://freepressokc.com/category/seen-heard/">Seen and Heard</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-50"><a href="https://freepressokc.com/category/technology/">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-45"><a href="https://freepressokc.com/category/crime/">Crime</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1033"><a href="https://freepressokc.com/category/business/">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-7892"><a href="https://freepressokc.com/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10449"><a href="https://freepressokc.com/category/editor-notes/">Editor&#8217;s Notes</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-10451"><a href="https://freepressokc.com/category/open-letters/">Open Letters</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-7647"><a href="https://freepressokc.com/category/first-person/">First Person</a></li>
</ul></div></div>


    <div class="td-search-wrapper">
        <div id="td-top-search">
            <!-- Search -->
            <div class="header-search-wrap">
                <div class="dropdown header-search">
                    <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                </div>
            </div>
        </div>
    </div>
			</div>
		</div>
	</div>

    
</div>
            </div>

            
<article id="post-11517" class="td-post-template-3 post-11517 post type-post status-publish format-standard has-post-thumbnail category-opinion tag-bennie-edwards tag-oklahoma-city-police-department tag-police td-container-wrap" itemscope itemtype="https://schema.org/Article">
    <div class="td-post-header td-container">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://freepressokc.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Opinion" class="entry-crumb" href="https://freepressokc.com/category/opinion/">Opinion</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Bennie Edwards was a victim of OKC police gunfight mentality</span></div></div>
        <div class="td-post-header-holder td-image-gradient">
            <div class="td-post-featured-image"><figure><a href="https://freepressokc.com/wp-content/uploads/2020/12/DSC03754.jpg" data-caption="Oklahoma City Police patrol cars sit at the scene of where officers shot and killed Bennie Edwards Dec. 11, 2020. (BRETT DICKERSON/Okla City Free Press)"><img width="1068" height="601"   data-srcset="https://freepressokc.com/wp-content/uploads/2020/12/DSC03754-1068x601.jpg 1068w, https://freepressokc.com/wp-content/uploads/2020/12/DSC03754-300x169.jpg 300w, https://freepressokc.com/wp-content/uploads/2020/12/DSC03754-1024x576.jpg 1024w, https://freepressokc.com/wp-content/uploads/2020/12/DSC03754-768x432.jpg 768w, https://freepressokc.com/wp-content/uploads/2020/12/DSC03754-696x392.jpg 696w, https://freepressokc.com/wp-content/uploads/2020/12/DSC03754-747x420.jpg 747w, https://freepressokc.com/wp-content/uploads/2020/12/DSC03754.jpg 1280w"  alt="police cars" title="OKCPD patrol cars at Hefner and Penn" data-src="https://freepressokc.com/wp-content/uploads/2020/12/DSC03754-1068x601.jpg" data-sizes="(max-width: 1068px) 100vw, 1068px" class="entry-thumb td-modal-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="1068" height="601" class="entry-thumb td-modal-image" src="https://freepressokc.com/wp-content/uploads/2020/12/DSC03754-1068x601.jpg" srcset="https://freepressokc.com/wp-content/uploads/2020/12/DSC03754-1068x601.jpg 1068w, https://freepressokc.com/wp-content/uploads/2020/12/DSC03754-300x169.jpg 300w, https://freepressokc.com/wp-content/uploads/2020/12/DSC03754-1024x576.jpg 1024w, https://freepressokc.com/wp-content/uploads/2020/12/DSC03754-768x432.jpg 768w, https://freepressokc.com/wp-content/uploads/2020/12/DSC03754-696x392.jpg 696w, https://freepressokc.com/wp-content/uploads/2020/12/DSC03754-747x420.jpg 747w, https://freepressokc.com/wp-content/uploads/2020/12/DSC03754.jpg 1280w" sizes="(max-width: 1068px) 100vw, 1068px" alt="police cars" title="OKCPD patrol cars at Hefner and Penn"/></noscript></a><figcaption class="wp-caption-text">Oklahoma City Police patrol cars sit at the scene of where officers shot and killed Bennie Edwards Dec. 11, 2020. (BRETT DICKERSON/Okla City Free Press)</figcaption></figure></div>
            <header class="td-post-title">
                <ul class="td-category"><li class="entry-category"><a  href="https://freepressokc.com/category/opinion/">Opinion</a></li></ul>                <h1 class="entry-title">Bennie Edwards was a victim of OKC police gunfight mentality</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://freepressokc.com/author/george-lang/">George Lang</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-12-15T21:49:12-06:00" >December 15, 2020</time></span>                                                        </div>

            </header>
        </div>
    </div>

    <div class="td-container">
        <div class="td-pb-row">
                                <div class="td-pb-span8 td-main-content" role="main">
                        <div class="td-ss-main-content">
                            
    <div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
                                        <div class="td-social-but-icon"><i class="td-icon-share"></i></div>
                                        <div class="td-social-but-text">Share</div>
                                    </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffreepressokc.com%2Fbennie-edwards-was-a-victim-of-okc-police-gunfight-mentality%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Bennie+Edwards+was+a+victim+of+OKC+police+gunfight+mentality&url=https%3A%2F%2Ffreepressokc.com%2Fbennie-edwards-was-a-victim-of-okc-police-gunfight-mentality%2F&via=freepressokc">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="mailto:?subject=Bennie Edwards was a victim of OKC police gunfight mentality&body=https://freepressokc.com/bennie-edwards-was-a-victim-of-okc-police-gunfight-mentality/">
                                        <div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
                                        <div class="td-social-but-text">Email</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#">
                                        <div class="td-social-but-icon"><i class="td-icon-print"></i></div>
                                        <div class="td-social-but-text">Print</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>
    <div class="td-post-content tagdiv-type">
        <span class="wtr-time-wrap before-content"><span class="wtr-time-number">5</span> minute read</span><div id="wtr-content" 
	    	data-bg="#FFFFFF" 
	    	data-fg="#f44813" 
	    	data-width="5" 
	    	data-mute="" 
	    	data-fgopacity="0.5" 
	    	data-mutedopacity="0.5" 
	    	data-placement="left" 
	    	data-placement-offset="0" 
	    	data-content-offset="0" 
	    	data-placement-touch="left" 
		    data-placement-offset-touch="0" 
	    	data-transparent="" 
	    	data-shadow="1" 
	    	data-touch="1" 
	    	data-non-touch="1" 
	    	data-comments="0" 
	    	data-commentsbg="#ffcece" 
	    	data-location="page" 
	    	data-mutedfg="#f44813" 
	    	data-endfg="#f44813" 
	    	data-rtl="" 
	    	>
<p>When a video of Bennie Edwards being shot by Oklahoma City Police Department officers hit social media on Friday, people who live or work in Oklahoma City’s central districts knew who he was immediately. They recalled buying flowers from Edwards near the Clara Luper Post Office Building and found themselves fondly remembering his smiles and kind words.&nbsp;</p>



<p>And then they got justifiably angry, because yet another Black man had been shot and killed by police. </p>



<p>Edwards, who was 60 years old, lived with bipolar schizophrenia. While family members said he had a place to stay with an aunt, his mental illness drove him outside, where he spent most of his time.</p>



<p>Police had responded to a report of a Black man bothering customers, according to a departmental statement after the incident. Later, officers said Edwards had a knife.</p>



<div class="wp-block-media-text alignwide has-media-on-the-right is-stacked-on-mobile" style="grid-template-columns:auto 21%"><figure class="wp-block-media-text__media"><img loading="lazy" width="1024" height="1024"  alt="Opinion"  data-srcset="https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-1024x1024.jpg 1024w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-300x300.jpg 300w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-150x150.jpg 150w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-768x768.jpg 768w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-696x696.jpg 696w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-1068x1068.jpg 1068w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-420x420.jpg 420w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1.jpg 1280w"  data-src="https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-1024x1024.jpg" data-sizes="(max-width: 1024px) 100vw, 1024px" class="wp-image-7901 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img loading="lazy" width="1024" height="1024" src="https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-1024x1024.jpg" alt="Opinion" class="wp-image-7901" srcset="https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-1024x1024.jpg 1024w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-300x300.jpg 300w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-150x150.jpg 150w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-768x768.jpg 768w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-696x696.jpg 696w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-1068x1068.jpg 1068w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-420x420.jpg 420w, https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></figure><div class="wp-block-media-text__content">
<blockquote class="wp-block-quote"><p><strong><em>Opinion</em></strong></p></blockquote>



<p class="has-text-align-center">by George Lang, opinion writer for Free Press</p>
</div></div>



<p>If it weren’t for phone cameras and social media, Edwards’ killing by Master Sgt. Keith Duroy and Sgt. Clifford Holman of OKCPD might have gone largely unreported.&nbsp;</p>



<p>Instead, we learned from the ever-vigilant Black Times that a group of protesters assembled quickly at the El Patron Super Market, 2121 N. Hefner, and several of them, including my friend Jabee Williams, got pepper sprayed for exercising their rights to free speech.&nbsp;</p>



<p>That evening, as <a href="https://freepressokc.com/he-died-scared-says-niece-of-man-shot-and-killed-by-okc-police/">Free Press reported</a>, anger and sorrow spilled out from one speaker after another at a peaceful protest in front of OKCPD Headquarters.</p>



<p>“He was in the streets because he loved it,” said Edwards&#8217; niece Ameerah Gaines through tears and crying. “He liked to meet new people. He loves people. He likes selling his flowers.”</p>



<p>If you are mentally ill, poorly clothed and a person of color, that can be a capital offense, especially if the responding officers do not receive the entirely voluntary Crisis Intervention Training (CIT).&nbsp;</p>



<p>Only 14 percent of OKCPD officers have taken the voluntary training and Duroy and Holman are part of the 86 percent who have not according to an email response by OKCPD Captain Dan Stewart to an Oklahoma Watch request.</p>



<p>Because OKCPD makes CIT a voluntary part of training, it appears to be the responsibility of everyone experiencing mental illness in Oklahoma City to keep their unquiet minds in check or possibly be shot.&nbsp;</p>



<p>According to a joint report by StateImpact Oklahoma and Oklahoma Watch in October, the number of mental health calls to which OKCPD responded climbed 95 percent between 2013 and 2019. Why is this not a priority?&nbsp;</p>



<p>The lack of training in response to a growing crisis is unconscionable and possibly criminal.&nbsp;</p>



<p>One year ago, city residents voted for increased mental health care and intervention as part of the Metropolitan Area Projects 4 (MAPS 4), and OKCPD is not keeping up with the needs and the will of the people they serve, and they certainly failed Edwards.</p>



<p>It was not worth the death of a single person for us to have yet another learning experience, but since Oklahoma City did not learn quickly enough to save Bennie Edwards, here we are again.&nbsp;</p>



<p><strong>First</strong>, CIT should be mandatory, full-stop. This should not merely be career advancement or post-incident training for officers who fail to take it like Duroy and Holman. It should take place before rookies go on their first patrols. If they cannot pass this important training, they do not receive badges.&nbsp;</p>



<p>And if OKCPD does not go forward with this desperately needed reform in its training practices? Well, we could always defund them. This is what that whole debate is about — making necessary, life-and-death improvements to police work.&nbsp;</p>



<p>Duroy has 28 years on the force and Holman has seven, and the training lasts 40 hours. That’s one week of training that might have saved Edwards’ life.</p>



<p><strong>Second</strong>, reporters need to discern what is valid information from police sources and what is opposition research designed to provide retroactive justification for police actions.&nbsp;</p>



<p>When The Oklahoman tweeted a story link on Monday that Edwards was arrested six years ago for attacking a postal worker with a knife, social media protest was loud and righteous over what appeared to be a carefully placed “Well, but…” article in the ongoing conversation over police shootings.&nbsp;</p>



<p>The latest in-house version of the story has been edited to emphasize the lack of training among OKCPS cops, but an Associated Press version on the site emphasizes Edwards’ past record in the lede. The AP version is the one that will be used by every racist uncle in his spittle-flecked “Blue Lives Matter” rant during an unmasked Christmas dinner this year.&nbsp;</p>



<p>In 1963, When Edwards was a three-year-old boy, President John F. Kennedy signed the Community Mental Health Act, which would have established a network of community mental health centers. Unfortunately, the plan was never fully funded following Kennedy’s assassination.&nbsp;</p>



<p>While President Jimmy Carter tried to realize Kennedy’s dream with the Mental Health Systems Act in 1980, President Ronald Reagan rolled it back with the Omnibus Budget Reconciliation Act, one of his first acts of Thatcherian austerity, which pushed responsibility for the mentally ill back to the states.&nbsp;</p>



<p>So, the system failed Edwards and millions of other people living with mental illness. He was carrying a knife because he was mentally ill and spending most of his life on the streets, where he was invisible to all but the kindest of our citizens.&nbsp;</p>



<p>By contrast, in April 2019, Oklahoma Second Amendment activist Tim Harper was arrested in Edmond for carrying an AR-15 at Hafer Park as part of a “second amendment audit.” He then did the same thing at a Twin Peaks restaurant in north OKC seven months later. Less than two weeks ago, Harper’s case was dismissed.&nbsp;</p>



<p>OKCPD leadership must ask themselves if there is equal justice. Edwards never had a chance to have his case heard. He brought a knife to the neverending gunfight of life in Oklahoma while being Black.</p>



<hr>
<h3><strong>Sustain our journalism by becoming a supporter<br></strong></h3>
<p>Oklahoma City Free Press is dedicated to providing high quality journalism that positively impacts our community. Click this <a href="https://dashboard.presspatron.com/donations/new?frame=1&amp;t=pMamyM1ZSttVyfgPpMYw2zgS">link</a>to support our mission.</p>
<div class="pp-donate-button"></div>
<hr>
</div>    </div>


    <footer>
                
        <div class="td-post-source-tags">
                        <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://freepressokc.com/tag/bennie-edwards/">Bennie Edwards</a></li><li><a href="https://freepressokc.com/tag/oklahoma-city-police-department/">Oklahoma City Police Department</a></li><li><a href="https://freepressokc.com/tag/police/">police</a></li></ul>        </div>

        <div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
                                        <div class="td-social-but-icon"><i class="td-icon-share"></i></div>
                                        <div class="td-social-but-text">Share</div>
                                    </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Ffreepressokc.com%2Fbennie-edwards-was-a-victim-of-okc-police-gunfight-mentality%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Bennie+Edwards+was+a+victim+of+OKC+police+gunfight+mentality&url=https%3A%2F%2Ffreepressokc.com%2Fbennie-edwards-was-a-victim-of-okc-police-gunfight-mentality%2F&via=freepressokc">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="mailto:?subject=Bennie Edwards was a victim of OKC police gunfight mentality&body=https://freepressokc.com/bennie-edwards-was-a-victim-of-okc-police-gunfight-mentality/">
                                        <div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
                                        <div class="td-social-but-text">Email</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#">
                                        <div class="td-social-but-icon"><i class="td-icon-print"></i></div>
                                        <div class="td-social-but-text">Print</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>        <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://freepressokc.com/mother-of-stavian-rodriguez-launching-lawsuit-against-oklahoma-city/">Mother of Stavian Rodriguez launching lawsuit against Oklahoma City</a></div></div><div class="td-next-prev-separator"></div></div>        <div class="author-box-wrap"><a href="https://freepressokc.com/author/george-lang/"><img  width="96" height="96" alt="George Lang"  data-src="https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-150x150.jpg" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://freepressokc.com/wp-content/uploads/2020/01/DSC09086-1-150x150.jpg" width="96" height="96" alt="George Lang" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" /></noscript></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://freepressokc.com/author/george-lang/">George Lang</a></span></div><div class="td-author-description">George Lang has worked as an award-winning professional journalist in Oklahoma City for over 25 years. His work has been published in The Oklahoman, Oklahoma Gazette, 405 Magazine and others, and covers a wide range of subjects including politics, media, entertainment and others. George lives in Oklahoma City with his wife and son.</div><div class="td-author-social"></div><div class="clearfix"></div></div></div>        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="George Lang"></span><meta itemprop="datePublished" content="2020-12-15T21:49:12-06:00"><meta itemprop="dateModified" content="2020-12-15T21:49:13-06:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://freepressokc.com/bennie-edwards-was-a-victim-of-okc-police-gunfight-mentality/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://freepressokc.com/bennie-edwards-was-a-victim-of-okc-police-gunfight-mentality/"></span><meta itemprop="name" content="Oklahoma City Free Press"></span><meta itemprop="headline " content="Bennie Edwards was a victim of OKC police gunfight mentality"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://freepressokc.com/wp-content/uploads/2020/12/DSC03754.jpg"><meta itemprop="width" content="1280"><meta itemprop="height" content="720"></span>    </footer>

    <div class="td_block_wrap td_block_related_posts tdi_2_df5 td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_2_df5" ><script>var block_tdi_2_df5 = new tdBlock();
block_tdi_2_df5.id = "tdi_2_df5";
block_tdi_2_df5.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_tags","td_ajax_filter_type":"td_custom_related","class":"tdi_2_df5","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":11517,"live_filter_cur_post_author":"339","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_2_df5","tdc_css_class_style":"tdi_2_df5_rand_style"}';
block_tdi_2_df5.td_column_number = "3";
block_tdi_2_df5.block_type = "td_block_related_posts";
block_tdi_2_df5.post_count = "3";
block_tdi_2_df5.found_posts = "19";
block_tdi_2_df5.header_color = "";
block_tdi_2_df5.ajax_pagination_infinite_stop = "";
block_tdi_2_df5.max_num_pages = "7";
tdBlocksArray.push(block_tdi_2_df5);
</script><h4 class="td-related-title td-block-title"><a id="tdi_3_1c4" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_2_df5" href="#">RELATED ARTICLES</a><a id="tdi_4_991" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_2_df5" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_2_df5 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://freepressokc.com/mother-of-stavian-rodriguez-launching-lawsuit-against-oklahoma-city/" rel="bookmark" class="td-image-wrap " title="Mother of Stavian Rodriguez launching lawsuit against Oklahoma City" ><img width="218" height="150"    data-srcset="https://freepressokc.com/wp-content/uploads/2020/12/Stavian-Rodriguez-attny-presser-12-14-20-DSC04087-218x150.jpeg 218w, https://freepressokc.com/wp-content/uploads/2020/12/Stavian-Rodriguez-attny-presser-12-14-20-DSC04087-100x70.jpeg 100w"   alt="Stavian Rodriguez news conference" title="Mother of Stavian Rodriguez launching lawsuit against Oklahoma City" data-src="https://freepressokc.com/wp-content/uploads/2020/12/Stavian-Rodriguez-attny-presser-12-14-20-DSC04087-218x150.jpeg" data-sizes="(max-width: 218px) 100vw, 218px" class="entry-thumb lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2020/12/Stavian-Rodriguez-attny-presser-12-14-20-DSC04087-218x150.jpeg"  srcset="https://freepressokc.com/wp-content/uploads/2020/12/Stavian-Rodriguez-attny-presser-12-14-20-DSC04087-218x150.jpeg 218w, https://freepressokc.com/wp-content/uploads/2020/12/Stavian-Rodriguez-attny-presser-12-14-20-DSC04087-100x70.jpeg 100w" sizes="(max-width: 218px) 100vw, 218px"  alt="Stavian Rodriguez news conference" title="Mother of Stavian Rodriguez launching lawsuit against Oklahoma City" /></noscript></a></div>                <a href="https://freepressokc.com/category/government/" class="td-post-category">Government</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/mother-of-stavian-rodriguez-launching-lawsuit-against-oklahoma-city/" rel="bookmark" title="Mother of Stavian Rodriguez launching lawsuit against Oklahoma City">Mother of Stavian Rodriguez launching lawsuit against Oklahoma City</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://freepressokc.com/he-died-scared-says-niece-of-man-shot-and-killed-by-okc-police/" rel="bookmark" class="td-image-wrap " title="&#8220;He died scared&#8221; says niece of man shot and killed by OKC police" ><img width="218" height="150"    data-srcset="https://freepressokc.com/wp-content/uploads/2020/12/Bennie-Edwards-protest-12-11-20-DSC03993-218x150.jpeg 218w, https://freepressokc.com/wp-content/uploads/2020/12/Bennie-Edwards-protest-12-11-20-DSC03993-100x70.jpeg 100w"   alt="Bennie Edwards" title="&#8220;He died scared&#8221; says niece of man shot and killed by OKC police" data-src="https://freepressokc.com/wp-content/uploads/2020/12/Bennie-Edwards-protest-12-11-20-DSC03993-218x150.jpeg" data-sizes="(max-width: 218px) 100vw, 218px" class="entry-thumb lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2020/12/Bennie-Edwards-protest-12-11-20-DSC03993-218x150.jpeg"  srcset="https://freepressokc.com/wp-content/uploads/2020/12/Bennie-Edwards-protest-12-11-20-DSC03993-218x150.jpeg 218w, https://freepressokc.com/wp-content/uploads/2020/12/Bennie-Edwards-protest-12-11-20-DSC03993-100x70.jpeg 100w" sizes="(max-width: 218px) 100vw, 218px"  alt="Bennie Edwards" title="&#8220;He died scared&#8221; says niece of man shot and killed by OKC police" /></noscript></a></div>                <a href="https://freepressokc.com/category/government/" class="td-post-category">Government</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/he-died-scared-says-niece-of-man-shot-and-killed-by-okc-police/" rel="bookmark" title="&#8220;He died scared&#8221; says niece of man shot and killed by OKC police">&#8220;He died scared&#8221; says niece of man shot and killed by OKC police</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://freepressokc.com/response-to-stavian-rodriguez-death-strains-police-community-relations/" rel="bookmark" class="td-image-wrap " title="Response to Stavian Rodriguez death strains police-community relations" ><img width="218" height="150"    data-srcset="https://freepressokc.com/wp-content/uploads/2020/08/DSC03808-218x150.jpg 218w, https://freepressokc.com/wp-content/uploads/2020/08/DSC03808-100x70.jpg 100w"   alt="protest" title="Response to Stavian Rodriguez death strains police-community relations" data-src="https://freepressokc.com/wp-content/uploads/2020/08/DSC03808-218x150.jpg" data-sizes="(max-width: 218px) 100vw, 218px" class="entry-thumb lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="218" height="150" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2020/08/DSC03808-218x150.jpg"  srcset="https://freepressokc.com/wp-content/uploads/2020/08/DSC03808-218x150.jpg 218w, https://freepressokc.com/wp-content/uploads/2020/08/DSC03808-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px"  alt="protest" title="Response to Stavian Rodriguez death strains police-community relations" /></noscript></a></div>                <a href="https://freepressokc.com/category/government/" class="td-post-category">Government</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/response-to-stavian-rodriguez-death-strains-police-community-relations/" rel="bookmark" title="Response to Stavian Rodriguez death strains police-community relations">Response to Stavian Rodriguez death strains police-community relations</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_2_df5" data-td_block_id="tdi_2_df5"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_2_df5" data-td_block_id="tdi_2_df5"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
                        </div>
                    </div>
                    <div class="td-pb-span4 td-main-sidebar" role="complementary">
                        <div class="td-ss-main-sidebar">
                                                    </div>
                    </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</article> <!-- /.post -->

<!-- Instagram -->

	
	
            <div class="tdc-footer-wrap ">

                <!-- Footer -->
				<div class="td-footer-wrapper td-footer-container td-container-wrap ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span12">
                            </div>
        </div>
    </div>

    <div class="td-footer-bottom-full">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://freepressokc.com/"><img  alt="Oklahoma City Free Press" title="Oklahoma City Free Press" data-src="https://freepressokc.com/wp-content/uploads/2016/11/FPLogo-Nov1-white-150x150.png" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://freepressokc.com/wp-content/uploads/2016/11/FPLogo-Nov1-white-150x150.png" alt="Oklahoma City Free Press" title="Oklahoma City Free Press"/></noscript></a></aside></div><div class="td-pb-span9"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div><hr>
<p><strong>Sustain our journalism by becoming a supporter<br></strong></p>
<p>Oklahoma City Free Press is dedicated to providing high quality journalism that positively impacts our community. We give voice to those who aren’t heard and expose that which is hidden from the public. Click this <a href="https://pp-staging.presspatron.com/donations/new?frame=1&t=VuVQRxLy7UcJsBNvasA5tDAz">link</a> or the red button below to support our mission.</p>
<div class="pp-donate-button"> </div>
<hr>

Published by Oklahoma City Free Press LLC, Oklahoma City, Oklahoma -- Publisher and Editor - Brett Dickerson. All photography and content is under copyright. We adhere to the Society of Professional Journalists Code of Ethics.</aside></div>            </div>
        </div>
    </div>
</div>
                <!-- Sub Footer -->
				    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                                    </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; Oklahoma City Free Press LLC, 2016, 2017, 2018, 2019, 2020.    <a href="//www.dmca.com/Protection/Status.aspx?ID=64fb634b-962d-4e3b-93ec-bed7c5a4d8ec" title="DMCA.com Protection Status" class="dmca-badge"> <img  alt="DMCA.com Protection Status" data-src="//images.dmca.com/Badges/dmca-badge-w100-5x1-11.png?ID=64fb634b-962d-4e3b-93ec-bed7c5a4d8ec" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img src="//images.dmca.com/Badges/dmca-badge-w100-5x1-11.png?ID=64fb634b-962d-4e3b-93ec-bed7c5a4d8ec" alt="DMCA.com Protection Status"></noscript></a> <script src="//images.dmca.com/Badges/DMCABadgeHelper.min.js"> </script>                </div>
            </div>
        </div>
    </div>
            </div><!--close td-footer-wrap-->
			
</div><!--close td-outer-wrap-->



			<script type="text/javascript">
				var _paq = _paq || [];
					_paq.push(['setCustomDimension', 1, '{"ID":339,"name":"George Lang","avatar":"98880de19d53fb7944f3dcaa708a875d"}']);
				_paq.push(['trackPageView']);
								(function () {
					var u = "https://stats1.wpmudev.com/";
					_paq.push(['setTrackerUrl', u + 'track/']);
					_paq.push(['setSiteId', '22896']);
					var d   = document, g = d.createElement('script'), s = d.getElementsByTagName('script')[0];
					g.type  = 'text/javascript';
					g.async = true;
					g.defer = true;
					g.src   = 'https://stats.wpmucdn.com/analytics.js';
					s.parentNode.insertBefore(g, s);
				})();
			</script>
			                <div class="td-more-articles-box">
                    <i class="td-icon-close td-close-more-articles-box"></i>
                    <span class="td-more-articles-box-title">MORE STORIES</span>
                    <div class="td-content-more-articles-box">

                    
        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://freepressokc.com/suspect-dies-shootout-okc-pd-officers/" rel="bookmark" class="td-image-wrap " title="Suspect dies in shootout with seven OKC PD officers" ><img width="100" height="70"    data-srcset="https://freepressokc.com/wp-content/uploads/2017/07/DSC_0399-100x70.jpg 100w, https://freepressokc.com/wp-content/uploads/2017/07/DSC_0399-218x150.jpg 218w"   alt="2920 SW 23 Street - shootout location" title="Suspect dies in shootout with seven OKC PD officers" data-src="https://freepressokc.com/wp-content/uploads/2017/07/DSC_0399-100x70.jpg" data-sizes="(max-width: 100px) 100vw, 100px" class="entry-thumb lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="100" height="70" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2017/07/DSC_0399-100x70.jpg"  srcset="https://freepressokc.com/wp-content/uploads/2017/07/DSC_0399-100x70.jpg 100w, https://freepressokc.com/wp-content/uploads/2017/07/DSC_0399-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="2920 SW 23 Street - shootout location" title="Suspect dies in shootout with seven OKC PD officers" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/suspect-dies-shootout-okc-pd-officers/" rel="bookmark" title="Suspect dies in shootout with seven OKC PD officers">Suspect dies in shootout with seven OKC PD officers</a></h3>            <div class="td-module-meta-info">
                <a href="https://freepressokc.com/category/crime/" class="td-post-category">Crime</a>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-07-13T20:52:33-05:00" >July 13, 2017</time></span>                            </div>
        </div>

        </div>

        
        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="https://freepressokc.com/northside-neighbors-load-town-hall-seeking-answers-on-homelessness/" rel="bookmark" class="td-image-wrap " title="Northside neighbors load town hall seeking answers on homelessness" ><img width="100" height="70"    data-srcset="https://freepressokc.com/wp-content/uploads/2019/08/DSC08460-100x70.jpg 100w, https://freepressokc.com/wp-content/uploads/2019/08/DSC08460-218x150.jpg 218w"   alt="Town hall" title="Northside neighbors load town hall seeking answers on homelessness" data-src="https://freepressokc.com/wp-content/uploads/2019/08/DSC08460-100x70.jpg" data-sizes="(max-width: 100px) 100vw, 100px" class="entry-thumb lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="100" height="70" class="entry-thumb" src="https://freepressokc.com/wp-content/uploads/2019/08/DSC08460-100x70.jpg"  srcset="https://freepressokc.com/wp-content/uploads/2019/08/DSC08460-100x70.jpg 100w, https://freepressokc.com/wp-content/uploads/2019/08/DSC08460-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="Town hall" title="Northside neighbors load town hall seeking answers on homelessness" /></noscript></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://freepressokc.com/northside-neighbors-load-town-hall-seeking-answers-on-homelessness/" rel="bookmark" title="Northside neighbors load town hall seeking answers on homelessness">Northside neighbors load town hall seeking answers on homelessness</a></h3>            <div class="td-module-meta-info">
                <a href="https://freepressokc.com/category/politics/" class="td-post-category">Politics</a>                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-08-02T09:57:36-05:00" >August 2, 2019</time></span>                            </div>
        </div>

        </div>

                            </div>
                </div>

    <!--

        Theme: Newspaper by tagDiv.com 2020
        Version: 10.3.9.1 (rara)
        Deploy mode: deploy
        
        uid: 5fd9cccaf3a28
    -->

    <script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/worth-the-read/js/wtr.js?ver=5.5.3' id='wtr-js-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/wp-smush-pro/app/assets/js/smush-lazy-load.min.js?ver=3.8.2' id='smush-lazy-load-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=a50385a2d79d6600973a7e697f735a0b' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.3.9.1' id='td-site-min-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/comment-reply.min.js?ver=5.5.3' id='comment-reply-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=a50385a2d79d6600973a7e697f735a0b' id='tdb_js_files_for_front-js'></script>
<script type='text/javascript' src='https://freepressokc.com/wp-includes/js/wp-embed.min.js?ver=5.5.3' id='wp-embed-js'></script>

<!-- JS generated by theme -->

<script>
    
</script>


</body>
</html>